1.2 cannot find iTunes xml file

Also, you may want to double check the path to your XML file – if your Core is running on Windows, you’ll probably need two slashes at the beginning of the NAS drive’s host name, like this:


I have the same issue with version 1.2 (running Roon Server 1.2 on Linux, Roon 1.2 on Mac).

When you enter the folder that contains the xml file it accepts the folder and then comes back with the same error “iTunes Library XML file not found in …”. So it is not a Windows only issue in my view. Read rights on the file is not the issue, I checked those.

Hello Mike,

There are two slashes at the beginning, when I posted the question I forgot to enter them. Also, xml is updating. I can’t find anything different from what it’s supposed to be. In the meantime I shall access my library as a watched folder.

Thanks of your assistance,

@JSE @BahamaBob – any change with Build 128?

Did you ever solve this? I’m trying out this Synology port of Roon for Linux and it can’t seem to find my XML.

Build 128 solved the issue with not finding the xml file. However, since all the pointers in my xml file point to another directory outside the iTunes Media Library folder, Roon simply scanned my xml file and did not import any albums. I’m still using Roon through a watched folder.

Unfortunately didn’t solve it in 128. Roon Linux Server and Roon Mac. Still seems not be able to find the xml file.

Currently have the music folder as watched folder, so bypass the issue, but for Roons best solution it should work :wink:

Yes, I can’t get it to work on Linux either. I have my iTunes Media folder in a non-standard location, but that shouldn’t matter I think.

Just moved to Debian and same issue here. :frowning:

Hey guys, I looked into this and I realize there’s a requirement that must be met for iTunes watching to work, which I realize we need to document a little better. @kevin and I are going to work on getting things updated.

We added a browse button in 1.2 because we heard from a number of users that they kept their iTunes XML in a non-standard location, and were having issues setting Roon up using a symlink.

While there are cases where your Core and iTunes library are on different machines may work, there are also some cases that will not work, so I want to be clear about what you can expect here.

The iTunes XML references a path for every file in your iTunes library. Because of how iTunes works these links can reference files that no longer exist and, depending on your setup, they can reference paths that are inaccessible to your Roon Core.

So, if your iTunes library is not being imported, the things to confirm are:

  • Can my Core machine access the XML file?
  • Can my Core machine access and understand the paths in the XML file?

@pwright92 @Lundmark @JSE @BahamaBob – a few questions.

  • First, can you guys open your XML file in a text editor and confirm the paths that are being sent to Roon?

  • Then, can you confirm these paths are accessible from the machine running your Core?

Meaning, if your XML points to:

Your Core can access:

I have a sneaking suspicion there may be a bug here, and it’s also possible we’ll be able to do better here in the future. More information about your setups will help guide our testing, so please let me know the details and thanks in advance for your help guys!

If Roon is using the path, mine will never work. My Mac has the original and Roon using a backup of the iTunes folder. The path in the xml is for the Mac not the NAS. Would setting up symbolic links help?

Yes, the Core have access to the paths. For me, that’s not the issue.

The issue is that Roon can’t seem to read the XML, even though it had no issues adding the path I specified. It’s definitely a bug!

Yes, the Core have access to the paths. For me, that’s not the issue.

The issue is that Roon can’t seem to read the XML, even though it had no issues adding the path I specified. It’s definitely a bug!

Same for me…

OK @Lundmark @JSE – can you guys let us know all the details we need to put together the same setup as yours? We’re going to try and reproduce this.

In particular, it would be good to know:

  • Where is the XML stored?
  • What operating system is the Core running on, and on which OS was the XML created?
  • How does the Core machine have access to media?
  • Basics of the network

We’ll try to match your setup(s) as closely as possible, and hopefully we’re able to see the same behavior as you guys.

Thanks for taking the time! Here goes:

  • XML is stored in /volume1/music/iTunes
  • The core is running on DSM 6.0 on a Synology ds1515+
  • The core holds the media in /volume1/music/iTunes Media (I’ve also experimented with placing the media in it’s standard location, but no dice). Roon runs as root, so privileges shouldn’t be an issue.
  • 100/100 MBit connection to an AirPort Extreme connected directly by Ethernet to the NAS box. Most clients are Wi-Fi except for the Mac mini which currently runs the core and acts a player for the living room

To me, the most confusing thing is that Roon accepts the iTunes XML location but intermittently claims it cannot find it afterwards

Here my setup is:

  • XML is stored in /media/md0/itunes/ (on software raid5 array)
  • The core is running on Linux 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64
  • The core holds the media in /media/md0/itunes/iTunes Music
    Core is running setup with your official install script on Ubuntu Linux
  • 1Gbit connections everywhere, So Roon on my mac has a wired connection via a Gbit switch to the Core running on the Ubuntu Linux server.

Have it setup now as watched folder and started to add all new albums into an organized (by Roon) folder. Guess I won’t use the iTunes xml file anymore, but happy to help solve the issue for other users.

Does anybody know if the iTunes XML issue has been fixed? Roon 1.2 was never able to find my XML on Linux on my Synology NAS, and so none of my music carried over when I moved Roon from a Mac to the NAS.

It seems to have been fixed, but I just realized a very important limitation that might prevent an iTunes library from ever working on a Linux (and NAS) device: none of the paths are correct in the XML, and here’s why:

OS X, which is where I’m running iTunes, mounts my music share as /volumes/music/ but on the Synology NAS, the path is /volume1/music/. Since iTunes runs on OS X, the former is what gets written into the XML, but the latter is the actual path for all the music files that Roon are looking for.

I’ve been mulling on this for a while but I can’t see that there’s a solution to this problem. Any ideas?

I discussed some of the limitations of our iTunes watching in the thread below, specifically in regards to situations where your Roon Core is running on a different device than iTunes.

Interested to hear your thoughts on the questions I asked there @Lundmark.


Thanks Mike. I commented on that. I really should get rid of iTunes I guess.