1.2 losing wi-fi airplay endpoints [Solved?]

as soon as my system updated to 1.2 I’ve lost all wi-fi connected endpoints i.e Airplay and Airport Express devices.
I manually enabled RAAT server access through the OSX firewall and all missing devices have been powered off/on as has my router .
Roon is running on a Mac Mini, My hard wired audio devices, ID40, MC2000 and Mac Mini all show up but my hard wired Apple tv4 has always been missing.
The missing devices all show as connected on my routers network map and all play Tidal via the Airplay linkon my iPad.

Hey @GeoffD,

From your description it sounds like your are using the iPad as a remote device - that can be the reason of the issue.
iPad/iPhone release is out, would you mind to take an update, restart Roon Core and check zones once more.


I’m using Roon on my Mac Mini at the moment as I can’t get music anywhere other than my main listening room without my AirPlay zones
I’ve just updated the iPad app anyway and rebooted everything but still my four wi-fi zones are absent.
I’ve now tried turning the Mac firewall of altogether but no improvement.

We’re struggling to find an explanation for what might have changed in 1.2 that might have caused this. We did do some work on AirPlay discovery issues for 1.2, but all of those changes were Windows-only. Just went back and checked to be doubly sure about that.

A couple of questions to help narrow things down:

Have you made any other changes to your network, or taken major software updates lately?

What network interfaces do you have active on the Mac Mini?

(If multiple interfaces (e.g. ethernet and wifi) are enabled at once, I suggest disabling one or the other, then restarting Roon to see if things get better. Even if that’s not a realistic way for you to operate long term, it might teach us something about the problem).

Thanks, and apologies for the trouble you’re having. I’m sure we’ll get this sorted out.

Success! but the opposite of what you mentioned, go figure!
My Mac was setup for ethernet access only, the wifi was turned off. i tried turning it on and bingo, my wifi airplay zones appeared including my Apple tv4 box that has never shown before now even though its ethernet connected to the same switch
Once again, many thanks. I now have my essential music back in my studio.

Do you have multiple WiFi access points, by chance? Maybe a router and some others?

No sorry, wifi is just via a single router that’s Ethernet wired to my 8 port gigabit switch that feeds. most of my network.
The only ‘dual’ part us that the router (BT Home Hub 5) runs both 2.4ghz&5ghz channels?

@vova @brian , after upgrading to 1.2, the Airplay stability in Roon towards my Nad D7050 became sketchy, at best. It shows up as a device only occasionally, and then disappears after a while. The amp is available on the network and works fine with other Airplay devices, like my iPad. It’s available only occasionally in Roon audio setup, and I did enable it yesterday when it showed up for some time, but this morning it was gone again. Any thoughts?

With 1.2 I no longer see my AirPlay devices on my network. Has AirPlay been removed from 1.2 or am I doing something wrong?


AirPlay devices are still supported in 1.2 but you may have to go back into Settings --> Audio and set them up again.

See if that works, if not get back to us.

No Airplay devices show up on the Audio Settings screen. I installed 1.2 on top of 1.1. Was I supposed to remove 1.1 first?

Hi again,

Installing over the top of Roon 1.1 should be just fine. I’ve split this out into its own support topic and I’m leaving a flag for @Mike or @vova to follow up with you.

In the meantime time you could try rebooting all devices (including router) to see if that helps.

Rebooting the server (NUC) fixed it. I should have thought about that before. Thanks.


Hi after upgrading to 1.2 Roon no longer recognises my Naim Muso,I have disabled the firewall to no effect.

Hi Martin,

If you haven’t already tried it then power cycling everything has made a difference for some.

If that doesn’t resolve it, can you describe your setup, both hardware and software ?

Hi Andrew,
Thanks for your reply,not sure what power cycling is.

Power off. Power on. :slight_smile:

still no luck i’m afraid,I am running Windows 10 and connecting Muso as a device that Roon has found on my network,all I have in that setting now is Airplay (Air receiver).

Hi Martin,

Can you describe your system in more detail as per this thread. What kind of wired connection did you have to the Muso ?

I just pulled together a few threads about what seem to be AirPlay discovery issues. I know that a couple of these threads were marked [solved] after some troubleshooting, but it really seems like something is wrong here, so I don’t want to close them out prematurely.

@vova, this is almost certainly a regression related to that fix for multiple network interfaces on different subnets on windows. Still not sure how that code is touching macs at all.

We are on it.