1.3 - Roon no longer sees my Meridian MS200 endpoints [Resolved]

Hello Support,
I’m running core on QNAP server and control and output on Mac Mini+Dac.
I have another output through Meridian MS200 and Airport Express (Airplay) in other rooms.
All are in the same network.

I have just upgraded to Roon v1.3 (build 193) stable (64bit) on both server and control. Roon sounds great as always through the Mini.

Later after the update I turned the MS200 on but Roon does not see anymore the MS200.
Mini and Airport are both OK.

I can see the MS200 on the network and log in through the browser.
I’ve restarted the server and control with no success.
I’ve checked under Settings/Dev/Enable Meridian Audio Streaming is checked.
Any ideas?

Have you restarted the MS200? In my experience they need a lot of that.

If it’s on a wireless bridge, restart the bridge too.

And is it on the latest firmware?

Hallo Ludwig,

I don’t have that experience with the MS200. Normally in that room everything is switched off at the surge protector and it is always started from cold.

I run everything through Devolo powerline adapters and they were also running OK.
To make shure that it wasn’t the adapters, I moved the MS200 closer and hardwired it directly to the same switch were my NAS and Mini are connected, restarting again the MS200.

Now that you mention it, I went to the Meridian support site and there is no Firmware update available.

Thanks for the help.

So you are saying when hardwired you also had trouble? What happened? Just always invisible or what?

Firmware you’ll need to get using a Sooloos app on Windows. But I can’t guarantee that’s your problem.

Yep, always invisible, not seen at all by the Roon app.

I also don’t think the problem resides on the MS200 as it was working on the previous version.

Can you tell me the name of the Soolos app on Windows? Do you mean ControlPC? I dropped Soolos long ago as I came to experience with Roon, it was too cumbersome for me.


Hi @Juan_Antunes ----- Thank you for the report and my apologies for the troubles.

May I kindly ask you to please describe your network configuration / topology as well as providing insight into any networking hardware you may be implementing in your setup. I want to get an idea of how your devices are communicating and what tools are being used to make those connections possible.


Exactly the same issue after upgrade to 1.3 with Meridian 818v3.everyhing is hardwired.

The devices are up and running on the network.

Just for the record, I am not having this issue with my 818v3 or my MS200 (hardwired and wireless bridge respectively). So you both are having some specific issue related to your set-up.

I’m sure @Eric will get you sorted.

The software you are looking for is ‘Meridian Sooloos Configure’ - this will allow you to update the firmware in the MS200 (current version (of Configure) is 31).

As to where to find it - good luck, I’ve spent about 10 minutes so far and can’t find it online (Meridian ‘Support’ site has dead links and it’s not listed in the Product Support section on the main site for any of the Streaming products) If I find it somewhere, I’ll add another post.

If you haven’t used Sooloos for some time, you’ve missed at least the following:

Sooloos 2.435 ID40, ID41, MS200 and MS600 all updated to firmware version 1.162.
Sooloos 2.477 MS200/MS600/ID40/ID41 Audio Endpoints build 164 – minor fixes to TCP/IP stack
Sooloos 2.515 Improved filtering of Multicast IP packets in MS200 and ID41 – (build 169).

That dev menu was shown unintentionally and should be removed by now. Can you upgrade to the latest build (B196 I believe) and see what happens?

If you still can’t see the MS200, try the following: in the Roon(Server) folder where your database files are held, there’s also a Settings folder containing a bunch of settings files in text format. If you open up ‘enable_meridian_streaming’ – what does it say?

Dear all, thank you for your kind support.

I’ve solved the issue. To whoever has the same problem:

1st - I harwired the MS200 directly to the same switch as the server to avoid routing issues.
2nd - Meridian does not allow us to pull for Firmware updates, they prefer to push it. I ran the Sooloos configuration to check for any issues.
3rd - I paciently kept everything connected until my QNAP Sooloos updated to v2.515 and the MS200 sofware to version 1.0 build 169.
4th - I checked also on Roon server folder that the setting for enable_meridian_streaming was 1.
5th - After the long wait Lazarus returned from the dead… both on Sooloos and Roon.

I kindly and gratefully thank You all :sunny:


Special thanks to Matt and Ludwig for the hints.:slight_smile: