1.3 - Sonic Transporter not connecting to remote

Ok , now the iPad app is working flawlessly . Not a single problem connecting .

However , the iPhone app still has connection problems .

I deleted the iPhone app and reinstalled and still the problem with not connecting .

Wow Jim, that’s really strange… the app is identical on iPhone and iPad. Just a different mode for the UI design, but the backend is identical. In fact, we only have the single app in the app store. This leads me to believe network and/or devices are somehow breaking stuff for you.

Hi Danny, yeah it is really strange.

Overall though both the iphone and ipad are working much better .

Try to give every device a fixed IP address in the router. It worked for me.

Why would this be an issue? DHCP isn’t continually changing IP’s, i doubt it to be very problematic in most cases. That being said though, it’s never a bad idea either.

I have tried fixed ip addresses for all devices and it does not help .
The iPhone still gets stuck on initializing . If I close the app out a couple of times I can get the app to show the Sonictransporter is ready .
The sonic transporter is not really initializing because there is music playing .

It’s all apple devices with Linux and the Sonictransporter. , not just iphone. now.

The mac connected to the same ethernet switch has zero issues. I still have no problems with not connecting on a mac core.


Is your SonicTransporter working now ?
Or maybe it was only the iPhone connection ?

I just did a complete reinstall of Roon and the connection problems still occur on iPads and iPhones .

I’m at a loss really at this point . Roon staff have been very helpful .
It does connect most of thetime .
I have tried new cables , new switches , direct connection of the sonic transporter to the google router to no avail .
I have Roon software in my Mac and it has never been an issue connecting with my devices . It works flawlessly .
Just not with the Sonictransporter .

Very strange. Can you post a picture like I’m having attached here:

Look at the devices yesterday that popped up ! Didn’t do anything and everything was duplicated . This is after a complete reinstall of Roon on the sonictransporter

Not sure if I can help, but :
Maybe delete all files here in SonicTransporter:

And reinstall Roon again.

Or temporarily install Roon on a computer, in order to verify if the problems is still present.

What kind of router do you have ?
Maybe check if a firmware update is needed.

Possible to test with another router?

Disconnect your iDevices from the network and after a restart of your router, which I suppose is also your dhcp server, reconnect your iDevices that may also can be restarted.

I suppose you have only one wireless network available, and use dynamic leases for wireless, and fixed IP’s for your wired device.

But I guess you already more or less have done all these things