1.8 Build 831 install on QNAP - Can't browse/link to my music folder

Roon Core Machine

QNAP TS 879 Pro – Firmware
Xeon E31275 3.4 Ghz CPU 16 GB Ram
32 TB Storage in Raid 6

Networking Gear & Setup Details

All connections are wired –
HP 16 port ethernet switch HP 1410-16G switch
Sagecom Fast 5566 Modem

Connected Audio Devices

Database is on a SSD drive attached to the server as an external drive and recognized properly on the ROON application page on the QNAP server

optional QNAP M.1 SSD PCI card is in the server to provide Cache

I Phone 8 and IPAD Mini as well as networked PC – all used as remote controls
Lampizator headless Linux based PC used as main endpoint - with Combo 384 Amenero USB input
Several other endpoints that all worked fine – but I’m willing to ignore until I can access my music storage on the server

Number of Tracks in Library

Roughly 18,000 Albums (250,000 tracks) all very well tagged & organized in a shared folder ( Music) on the server – and also mapped to a networked PC with a monitor

Description of Issue

After successfully updating to Roon 1.8 build 831 – on the QNAP server ( Manual install) ---- I was no longer able to access my local music files stored on the same server – my remote/control apps were also updated to build 831 – Tidal still works fine and outputs properly to my endpoints – but I cannot browse to any local folders and can’t set them up

I researched the forum and followed the advise to rename my roonserver folder on the NAS to Roonserver old --------- restarted the server and the roonserver folder was rebuilt on the QNAP – but still no access. I also tried to restore a database backup ------- but the ROON OS also will not find the back up files because they are in my music folder --------- I tried copying one of the back files from the server & was going to put it into a Dropbox folder to access from Roon – but the file is 14 GB – and drop box only allow 2GB files size on the free version – & i have no need to subscribe for larger file size option so I have not restored the back up file ( last backup before update was Nov 4)

I’ve made serval attempts to find the Music folder – by accessing it as a Network folder – with various attempts and syntax variations — SERVER/Music – using the IP address – and/or proper drive names – I can’t get Roon to find any files or directories on my server – period ------- all I get is the screenshot below .

I have used Roon for roughly 4 years – and love the program. It has always worked well for me and the only change I have made to my system – is upgrading to the newest version

Any suggestions or guidance would be appreciated – I’ve downloaded the log files – but don’t understand how to attach them to this post.

Please let me know if you need the log files & How to send them


Bart Gilchrist

Sorry – that screenshot was incorrect ----------- this is the proper screenshot

Hey @Bart_Gilchrist,

Thanks so much for reporting this — we’re sorry we didn’t get a chance to get back to you until today.

I wonder, could you please download and install the latest build (850) from the QNAP app center?

Do you see an improvement?

Seems to have solved the issue – My library is rebuilding itself and I assume it should be done in a few hours.


1 Like

Hey @Bart_Gilchrist

Thank you for letting us know that build 850 resolved this issue for you!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.