1.8 has serious bug on Android

Core Machine (Operating system/System info/Roon build number)

Intel i3 NUC running Linux Mint latest core build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired gigabit ethernet
Android pixel c tablet running Android 8.1

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NAD C 658 ethernet

Description Of Issue
Problem is on the tablet. Run roon app there, and issues are:
1 any notifications stop play of music
2 going back to home screen stops roon
3 catastrophic bug is that when you return to roon, the screen is entirely messed up random blocks of color, etc. Worse, it is stuck that way until you kill the app and restart it

This is a really bad bug.

Not had any issues with display on my android devices been perfectly fine so it’s not across all of them. Pixel 4 and Samsung TabS2.

Interesting point. Maybe I should try my phone too. All I really know here is that with a vanilla Android system on a Google tablet, the 1.8 version fails spectacularly. 1.7 worked fine on the same hardware and OS. I hope Roon can sort this out.

Just another data point: Galaxy Note 10, 10+ and S20FE not exhibiting this issue here with 1.8. I have other problems with it, but this is not one. Hope you get it sorted!

Aren’t those phones? Maybe it’s a tablet problem?

Yeah. Could also be an older Android problem as the tablet in question is running 8.1 versus my phone, for example, which is running 11.

Generally problems started with Android 10 as it significantly changed the network stack. My older tablets were reliable . I will see if I can dig one out and try it.


Hi Jan, have you tried removing the app and re-installing it?

Yes, I have. Also rebooting the tablet, just in case. No luck.

Jan have you had a look at this thread

OK, I took a look at that thread. First, it seems like there is no connection to the core at all for the Android devices, which is not the case for me. I have connections, I just cannot go to the home screen and back to Roon - the display wipes out. There are a couple of things brought up in that thread that were changed and seemed to help, but those are not applicable for me:

  1. Mac address of the android device changing. MAC address of my tablet is definitely fixed
  2. The IP address of the Core machine running Rock is variable, and fixing it seemed to help - I am running my Core on a NUC running Linux Mint with a fixed IP address already.
    I am an old Unix hand, so I don’t run DHCP unless the device forces me to :slight_smile:
    Also, it was 1.7 they were having trouble with, and I never had any difficulty with that version.

I’ve got a Samsung S6 Tablet, and S9+, both work OK

I have these kind of OpenGL glitches as long as I use Roon on my Pixel C (i.e. since 2016). My current workaround is to pin the Roon app, but not really workable if you use your tablet for other apps as well.

Hi Jan it is a good idea to have a fixed IP for the Core. Reserve yourself an IP in the router if you know how, and then you can set that ip address in the Android Roon client.
Things should go much smoother after that I hope


It’s the other way around for me.
Devices on 10 are better than 9 with Roon.
My tablet running 9 freezes in 1.8 every time screen goes off.
Kill brings it back but it is a mild annoyance.

When 1.8 is running though it is very smooth and looks great on a tablet screen.

Edit to add : its now occurring when you swipe close the app. It’s as if it’s still running so hangs when reopening.
Force kill allows it to open again.
This is with build 748 - stable

Is this because the 8 and 9 tablets are getting old and can’t cope with the memory demands any more?

Roon is a big app and I cannot see it comfortably working on a tablet with 2 or 3 gb of memory (most tablets of that era). I can’t find my Pixel C, so will have a good look for it today. It was always rock solid with Roon (but battery is pretty much useless now) and from memory it only has 3gb ram.


Edit not a sniff of an issue with the Android phones in my house, all working a treat :pray:

Age could well be the case.
My tablet running 9 can be very sluggish in general lately.

It does appear that every version of Roon gets a bit more demanding with caching requirements.

Now Roon lite, that would be a thing for lower powered devices and take things like Focus out :roll_eyes:

(Oops I retract the statement in the event of people being ■■■■■■ off)

Yeah, that might push a few people in here over the edge

1 Like

I have always set my IP manually to be fixed for my Roon Core machine. Maybe that’s why I had no trouble with 1.7 on my pixel C. How do you set that address in the Roon app though?