1.8: non-matching/self tagged albums missing in Composers View

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear, Ethernet, Music on NAS.

**Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc

Brooklyn Bridge (ethernet) and many others. Problem doesn’t care.

Description Of Issue

While perhaps assumed, this was not a problem in 1.7.
Especially evident with classical composers.
Most, if not all, of the albums I have, for various reasons not used the Roon tagging/matching are missing from the Composers View. As an example I have 57 JS Bach albums in the directory. Some of these are duplicates by different artists. Roon shows only 19 of which two, correctly shown, reside in other directories. As best as I can determine the missing ones are those that were/are not matched to Roon’s metadata database.

I can go to the artist, if I remember which one I want, so they are in my Roon database.

Did I (hopefully) miss a new setting somewhere? Suggestions appreciated.

Hi @Jan_Erik_Neun

Can you share some screenshots of an example here? Thanks!

I have managed to make it “better” by flipping the setting to tell Roon to use the genres from my file tags.


That said, and hopefully it’s a clue, I don’t particularly want my library to depend on someone’s (or mine) idea of which genre something belongs in. Rant over.

Below is one of the examples of a problematic recording. As one can see the tracks are correctly assigned to JS Bach. Yet when filtering on Composer=Johann Sebastian Bach, this recording does not show up until I go in and add the Classical tag to the Genres tag. The second image.

I hope this helps. While I personally have a sort of a workaround I do not plan to revisit all the classical in my library to solve something I feel I shouldn’t have to. Thanks for listening and I look forward to the next 1.8 release.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.