1.8 unable to tag

Roon Core Machine

Windows server 2019
Intel NUC I7 16GB

Networking Gear & Setup Details


Connected Audio Devices


Number of Tracks in Library


Description of Issue

Just wondering why I can’t add tracks to tags from MacBook Pro M1 (apple CPU) version

You have to add tracks to your library before you can add them to tags.


Thank you for your help @David_Snyder .

This is somewhat confusing. So, I wanted to add some tracks from my history / Queue to an existing tag. Tried both queue and history. No dice. Although it would appear that I can add the track to a playlist if I want to (that seems inconsistent/weird to be able to do one and not the other). So,after your tip, I tried to add the album in question to the library. I still can’t add to tag.

Perhaps it’s because the track was played in the past…(ie in the history it wasn’t in my library…) no, that’s not it. In fact, the album reports it’s been added to the library (toaster popup thin with the chevron at the bottom) but the icon next to play now it still spinning. Has it got stuck, has it got added. I don’t think the Qobuz track is being added to the library as, yes, other tracks in my library I can tag appropriately. I’ll investigate this further.

Restarted Roon…no change.

Why can I appear to add a non-library track to a playlist but not a tag?

Thanks @BlackJack and @David_Snyder

Adding to the library makes sense. For some reason the problem I am having was being exacerbated last night by albums not being added to the library in a timely fashion…maybe internet. Anyway, revisiting this, this morning, all versions of the album are in the library but the problem persists!

I have three versions of the album shown here. As you can see they have all been added to the library:

I can drill into any of them and readily tag each track if I want to (you can see that both the playlist and the tag button in the tooltip is available here:

But…from history (and indeed the queue) I can only add to playlist, not a tag. Is this correct functionality?


I’ve never tried to add a tag to tracks from the History view. This could be a UI bug or there could be some other reason why this does not work. Perhaps history always shows a historical view of the state of the track and is not updated after you add the album to your library. Difficult to say, but it sounds like you’ve mostly figured this out.

If the track in the Queue or History is the one from Qobuz (directly) and not one from your Library, well then this is expected behavior. You need to play (add to Queue and History after play) the version from your Library to be able to “Add to tag” from Queue or History. There is no update being done to the non-library versions that are there from the past. Reason (from the document linked above):

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.