1 of my 3 Node2is is detected only as airplay

Hello! I just set up my Roon Core in my desktop PC W10. The home network is composed of a Tp-Link Archer C80 router, 2 wired Bluesound Node2i and via WIFI a 3rd Node2i plus a MiniPC with Daphile installed. Everything is runnig smootly except for the Node2i in my living room (wired) which was in no way detected by Roon as “Blueos Roon Ready” device like the other 2 brothers, but only in Airplay.
I already tried the following to have it discovered, always keep an eye if the device got listed without success:

  • several restarts of Core PC;
  • several restarts of Node2i;
  • switched the Node2i from wired to WIFI connection and back;
  • assigned via router a different IP (i.e. from to
  • renamed the Node2i as “Living” from “Living Room”.
    I can see from settings/Audio that every now and then for an instant a third box is flashing among the Roon ready devices with the other 2 Node2i stably on the screen, but it is so fast I can’t even tell if it is really the missing Node2i in the living room.
    Any suggestion on what else I can attempt? Thank you!

I know you already changed the IP address but that behavior seems reminiscent of a conflicting IP address somewhere.

I had the same behavior quite some time back where an errant audio zone would flash into view for a split second.

If not a conflicting IP there is something it does not like about that node setup.

Have you checked in Bluos that all three have identical settings for connection and playback etc?

Thanks Kevin.
Following your hint I checked and the only different setting found was the “Audio clock trim” OFF for Living Room and ON for the other.
Hence I switched to on, assigned a new IP e restart the Node, but except for the IP in the Airplay group there were no changes.
I also renamed it again as last attemp, with no result.
Could it be that Roon remember the MAC address of the device?

UPDATE: after all above I also reinstalled ROON core upon the previous installation and… Living Room Node2i then magically appeared!

2nd UPDATE: I had the not so strange idea to group all the Nodes. Once done on the Living appeared first a red triangular warning sign and the icon moved from Node to Generic device, then Living disappeared again for good (or bad in my perspective).

3rd Update (attempt):
I made a clean installation of Roon Core (deleting all data files - FYI Windows was not able to uninstall Roon directly with “Error launching installer” message popping up, but I had to go to “C:\Users*username*\AppData\Local\Roon” and delete many GB of data and then W10 offered to delete from the register the orphan entry). Then all 3 Nodes appeared. When I played some Tidal music on Living Node it disappeared again from Roon ready devices list, remaining in Airplay only.
BTW I have to report that after the latest restart of the Node I unplugged the LAN cable and realized that it didn’t take the permanent IP I assigned him with Archer C80 router but a different one.
Then I checked its Mac address and changed from (wired) 90-56-82 etc. - Lenbrook Industries Limited

Can it be a routing/ DHCP issue indeed?

After few minutes from the launch of a re-indexing of the library of the missing node it appeared to stay among the other Roon ready devices and playing music from Roon, alone or grouped.
It worked well already for some days: hope it will continue.

1 Like