100% CPU on QNAP


I just got a QNAP YA-453B, and thought I would try Roon on that box using a USB SSD for the DB
Music files are on the previous QNAP NAS box
Network is 1G netgear the network and setup that is working fine with Roon running on a laptop under Windows.

I’m getting 100% CPU utilization whenever I run Roon on the QNAP, any suggestion on what could be the issue?

CPU is at 100% without streaming and Roon is not doing any background analysis, I tried re installing still same issue.

The QNAP’s processor is below the minimum requirement of an Intel Core i3 processor.

I’m sure you meant TS-453B as I never heard of an YA-453B. If so, with 2 or 4 GB RAM? 4 GB is the minimum specification for Roon. Maybe your QNAP is just constantly swapping?

I have no problems running my Roon Core on a TBS-453A-8G.

Hi, yes it’s TS, that was a typo
It’s 4G

I disabled all music sources then re enabled again and I’m getting cpu utilization from 30 to 60 % now with ROON running
Less than 5 % with ROON disabled

If I check the resource monitor of my QNAP, Roon’s CPU usage is approx. 1.25 - 1.75 % while streaming 24/48 content to one zone (slight use of DSP - PEQ and volume leveling). Either your core is still analyzing your library in the background or other processes are using up your CPU time.

Is this while it is still indexing your music files (this consumes a lot of cpu power)?
Is the issue resolved?
If the cpu reaches 100% again, can you check the resource monitor and see if there are several Roon processes that utilize high cpu load?

No indexing, I moved the dB from my previous setup on a laptop

No it’s not gone, when I disable the music sources and then re enable, it would stay normal for 1 or 2 hrs then cpu will hit 100% again

Only on ROON process running

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.