101 for casting to display - help please

ROCK installed on NUC, connected to network by wired
Running Roon remote on various Android tablets via wifi
Trying to cast to Panasonic GZ1000 smart TV connected to wifi
Music is through Meridian 681 and works perfectly

Hi all, I need a casting 101 (or even simpler). I was reading up in the KB and would like to get my large screen to display my Roon remote display. But I don’t really know a lot about casting, and I got all confused.

The Panasonic is new and supports mirroring, which I think is casting - but it might not be.

What devices need to be talking to other devices? Does the Rock do the casting, or is it from the remote device? Do I need a physical chromecast (I don’t currently have any displays showing in Roon)

The KB and other posts will be helpful once things start talking, but I am stuck at 101 level.

Screen mirroring is not supported, Chromecast or Android TVs are supported as they have chromecat and certain web browsers work on TVs will act as a display receiver.

You need to enable Chromecast as a display in the settings and then you can set that device on any endpoint playing music to be it’s default display using the little tv icon.

To use it in a browser you need to put in the url that you find in the settings menu under displays.

The core does the sending they remotes are just controls for the core.

1 Like

Thanks, I decided just to buy a chromecast.

Anyone notice that the new chromecast with google tv dongle times out the roon casting and it is a devil to get it back?

Ok, as always, completely resetting the Google Chromecast TV dongle via a factory reset and deleting and reinstalling the Google Home app fixed the problem. There appears to be no difference between the two Google dongles: Chromecast and Google TV.

1 Like

Well - just as i thought it was fixed - my Google TV Dongle did default to screen saver after about 15 minutes. I just have to press the down arrow button on the google remote and Roon comes back. This is a little annoying. There is nothing in settings that lets me overide this.