2 or 3 mins to load/play a Qobuz streaming track

I have the Innuos MKIII music server (SSD drive, 2 TB). This is my Roon Core. Also, this is where all my music is stored. And, this is the device that streams Qobuz for me.

I am using a hard connection from the internet to the Innuos MKIII—cat6; and running at average of 40 mbps for downloads.

I have a Lab12 DAC1 SE, non-oversampling dac.

Innuous software is version 1.4.2, and the server says it’s up-to-date.

I use Roon version 1.600416, which came-out a few weeks ago.

I’ve also integrated Qobuz streaming through Roon and Innuos since February, now version 5.3.1 b2.

The problem I’m having is that, when I’m streaming on Quobuz, the albums and tracks start extremely slow—2 to 3 minutes most times. Often, they just hang–particularly an album start-up, information or search.

This problem started only after I installed the new Roon software version and the new Innuos software version a few weeks ago. Until then Innuos, Roon and Qobuz were all getting along on this very same system.

I’ve checked all settings on Innuos, Roon and Qobuz. Also, I’ve un-installed and re-installed Innuos, Roon and Qobuz.

Roon works fine when it plays tracks from my own library. Qobuz works fine when it plays on my other systems. So, I believed that the problem stemmed from the integration with Innuos.

I wrote Innuos and they told me it was a Roon software issue that had something to do with Linux-- the operating system on Innuous; and furthermore, that it is a known issue for other Innuos equipment users too, but seems “local.” (Not sure what that meant.) They directed me to support at Roon.

In any event, please help me. This problem is really interfering with listening. My only other option is not to have Qobuz in my system, which I like a lot. I did not like Tidal.

Thank you very much!

If more equipment info is needed, let me know. But, pretty sure my amp, pre-amp and speakers have nothing to do with this.

Hi @john_horn — Thanks for reaching out!

We’ve been communicating with @Innuos about similar reports to what you’re experiencing. It doesn’t always occur with this configuration, so there is likely something environmentally that is causing this behavior to occur.

Starting out, I was hoping to gather some more information about the network:

  • What router is in use?
  • Is there any other networking gear (switches, access points, etc.)?
  • What network device is the Core connected to?
  • If you run a speed test, what is your download speed?

Additionally, can you provide some information about your audio devices?

  • What device are you playing to?
  • Does this behavior occur with all endpoints?
  • If you play to System Output of a remote device does the same slowness occur?


Hi Dylan

Router: I’m not using a wireless router on this–just LAN Cat6. However, I do have a wireless router and it may be possible that the CAT6 is running through it. So–

  1. Modem is Actiontec T3200. Internet is provided by phone company as DSL, not cable. 40 mbps down and about 3 or 4 up.
  2. Next, there is a switch in the line–this is a Cisco 4 port Meraki z1.
  3. Next, the wireless router is possibly being used as a switch for the cat 6–this is a Cisco Meraki A40.
  4. Next is the endpoint–the Roon Core–Innuous MK3 server (as described in my last post)

I am not using any other player. I control the MK3 through Roon on my iPad or iPhone as controllers. I have not set those up as players however. To keep things simple, only my MK3 is an output/player. So–

  1. the device I’m streaming into is the MK3. As noted on Roon itself, the MK3 is has a “partnership” with Innous and there is no computer or other device involved in the play–the MK3 is a computer dedicated to storage, playback and streaming.

  2. If by endpoint you mean another device like an iPad or a laptop, I don’t know if the behavior would occur with all endpoints, because I don’t have any others set-up. I can make my microsoft laptop into a player and try playing through there. I’ll let you know what happens.

But, if by endpoint you mean a different cat6 Jack, I can easily try another Jack, which I will do after work today.

System Output. not sure what you mean there. If you mean an iPad or laptop, I can try setting up my iPad as a player along with a microsoft laptop.

Hi @john_horn,

Thanks for the details here.

First, I notice that there is quite a bit of networking hardware involved here. Just to confirm, the chain is:

ISP provided Actiontec T3200 > Meraki z1 Switch > Meraki A40 Wireless Access Point > Innuos Core machine

Meraki switches often have lot’s of configurable options like other managed switches which, as mentioned in our Networking Guide, can often require some advanced configuration.

I think that, starting our with our troubleshooting, we should try to narrow down where this behavior is stemming from. It would be good to know if only the Innuos Core is having trouble in this network configuration, or if all Roon Cores have similar issues here.

If you have a Windows or Mac machine that you can connect to the network in the exact same way as the Innuos Core, and you use this machine as your Roon Core, do you experience the same issue?

Regarding my endpoint comment, by endpoint I mean Zone in Roon. What audio device are you playing to from Roon? If you select System Output of a remote device as the Zone in Roon, does the same issue occur?

Thanks again Dylan! Glad to have your help!

I should note from the get-go that it is not my forte. I’m only 6 months into Roon and the audiophile world. (Just wanted to listen to music.) I bought Innous because it was “dedicated” and “all-in-one” and I did not have to set-up a laptop to a streamer with a NAS drive etc. etc. But Innuos, and it’s Linux OS does not seem to play well with Roon. Also, the complexities of the Innuos package are overwhelming on something like this. Each new Roon version has caused problems, but this time much more severe and intractable.

So, to the matter at hand:

I did the what you suggested. I’m happy to help. Please see results below.

But, I’m using the exact same equipment, software and set-up as before and it all worked fine until the Roon/Inuous updates a few weeks ago. All evidence points to a Linux-Roon integration problem in the new versions. This according to Innuos; but also according to other Linux users in touch with Innous on their own machines/systems, not just mine. Innous said there were many users with this problem. You seemed to reiterate that. In any event, testing in two other operating systems (mac and Microsoft) might confirm a Roon-Linux integration problem; but it won’t get us any closer to knowing what that problem is with Roon + Linux. And, my testing tonight seems to confirm the problem is not in my internet/network.

I’m hopeful we can get move forward to the Linux-Roon integration in the new versions, having ruled-out my internet/network.

I Tried four progressive things this evening, after doing another speed check (47 down and 4.5 or so up):

  1. I rebooted Innuos Zenith MKIII server 4 times. No change. Totally hanging at times; other times 1.5 to 3 minute waits to start a track when streaming through Roon with Qobuz.

  2. I Plugged-in the cat6 to another jack that does not travel through the Meraki A40 wireless access point. Plugged MKIII directly into the 4 port switch located next in line to the DSL modem. This is the first piece of equipment after the modem/firewall. (plugging directly into the modem did not work, as one might expect in front of the firewall.) Again, No change.

  3. Played Qobuz streaming within Roon on another output device–my iPad. Roon core was still MKIII. This output seemed to perform a bit better (say 30 to 45 seconds to play a track instead of 1.5 to 3 minutes). Likewise, when trying on my iPhone as another output device. Not sure whether this was coincidence or an improvement. I believe it was an improvement, because I repeated it many times. But it was not very remarkable.

  4. Deactivated MKIII core. Set-up a new Roon core on my pc laptop. This gave me remarkable results and super fast play. All tracks came-up almost immediately.

So, we are back to Innuos MKIII server and the unsolved Linux + Roon integration or interface issue that Innuos posited and (rightly or wrongly) faulted to Roon.

Again, thank you for working on this. I appreciate it. Let me know next steps.


Hi @john_horn,

Thanks for the testing here! This is definitely some great data and confirms where this behavior is stemming from.

One thing I was hoping before completely moving away from the networking setup — Can you share some screenshots of the router settings? Are there any settings related to IPv6 that you have enabled?

Hi Dylan,

Great questions! I was thinking the same thing. This morning, I emailed my IT person who set this up and I asked for a list of all settings on each piece of equipment in the network. I’ve not heard back, but will post asap when I know.

Hi Dylan,

I have the settings and IP addresses etc provided by my IT person. How can I get these to you offline?

Send him a Private Message (PM). Click on his avatar to reveal the Message button, and click on that.

1 Like

hi geof,

The message button does not appear. (i’m logged-in, etc.). what am i missing?

Not sure why you can’t see the PM button - I’ve flagged a moderator for assistance…

Try now John.

Cheers, Greg

1 Like

That worked. I’ve just delivered the PM to Dylan so he can see all network settings.

Thanks to all! I was just expressing amazement to Dylan: I don’t know how you-all do this. I’m pulling my hair out!


1 Like

Thanks @john_horn (and Greg and Geoff)!

I received your messages and have updated the ticket for the technical team with the network details. Moving forward with troubleshooting we were hoping you could do the following:

  • Reboot your Innuos Core machine
  • Reproduce the issue and make note of the time that you press play, the track from Qobuz you’re trying to play, and what time it actually starts playing
  • Respond here with the track and timestamp inforamtion

Once you’ve done this I’ll enable some additional diagnostics on your account so the technical team can take a closer look.

Thanks again, John!

Hi Dylan,

I’ll try that when I get home tonight. Will run those timed tests. And, I should mention that the 2 or three minute delay I complained of initially was also timed by me using a stopwatch over many tests–the slow times were real and not imagined. there were also outliers at 5 minutes or longer to start and even total hangs.

Meanwhile, like magic, on Sunday (yesterday), all tracks started within 7 seconds or less. there were a couple of exceptions–43 seconds in two instances.

Maybe that is the end of it; but maybe not… I’ll see what happens tonight; and let you know. Otherwise, I hope we can keep the ticket open and see if this problem (which lasted many, many weeks before suddenly disappearing on Sunday) repeats itself.

I’ll get you more stats tomorrow.

One other thing: my IT guy, Ben, sent the following message:

"Hi John,

We looked through your network device settings and didn’t see any IPv6 addresses or settings to enable/disable IPv6. Another place IPv6 might be enabled is your music server. We can take a look through those settings if you give us remote access. Otherwise you can look through it yourself too. Let us know if you have any more questions."


1 Like

Hi Dylan,

The problem re-surfaced, to a degree.

11:00pm cst june 5th. Track: “come on to me” by Paul McCartney. 61 seconds to start

About 10:50pm cst june 5th. Track: “slip Kid” by the Who. 56 seconds to strart.

tried many other tracks with almost identical one minute start times.

let me know what to do next. thans.


okay, checked again this morning. Still the same.

June 6, 2019, 8;20 am cst. track = “Bridge of Death” from Cherynobl soundtrack. 1:01.23 minutes to start track from Qobuz through Roon on Innuos music server.

internet 34mbps down + 4 up.

Thanks, @john_horn!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hi @john_horn,

I wanted to reach out with an update here. We’ve tried enabling diagnostics multiple times but, unfortunately, the diagnostics report hasn’t been received any time we’ve tried. We’ve contacted Innuos about this and are discussing our next steps here with them. We will be sure to update you ASAP.


thank you, dylan.

I’m beginning to suspect equipment failure, based on:

ruled-out network issues;

Roon cannot find the core many times lately and core suddenly disconnects;

the streaming problems I’ve complained of persist, but can vary from 1 min download time to five minute download time to 7 second download time, with no apparent outside action;

and now, you are also having trouble getting onto my core for diagnostics.

if this appears to be equipment failure in the final analysis, would you kindly advise Innuos, with a copy to me; and ask them to please get in touch with me to pursue repairs or replacement under warranty. thank you!