24/96 ALAC files not playing

I have a strange problem when attempting to play 24/96 ALAC files via ROON -> Naim Nova
If I play direct using Naim app and not involving Roon, all is fine
If I try to play via Roon the track starts but then stutters and stops. Eventually it selects the next track and repeats etc
I have no DSP set and no normalisation of volume
Interestingly if I change the sample rate settings of my device in Roon to max 48 kHz it will happily play ( I can see the signal path is displaying final format as 48/32 )
Roon is running on a Linux box and will happily manage all exotic DSP settings on files that are not 24/96 ALAC … so I dont think it is runnung out of steam
Any suggestions ?
Thanks in advance

Run top and see whats going on… it does sound as if either your network or core can’t keep up with the load though.

Thanks for that
The processor is barely breaking sweat … 10 - 12% max … same for memory
And as I said I can switch on all sorts of fancy DSP on other files ( not 24/96 ALAC ) and it is no problem at all

I have the logs but not sure how to upload them

Some additional info from logs ( would upload complete set but not sure how to attach )

04/14 16:13:59 Debug: [raat/tcpaudiosource] disconnecting
04/14 16:13:59 Warn: [raat/tcpaudiosource] send failed: Object reference not set to an instance of an object
04/14 16:13:59 Warn: [raat/tcpaudiosource] disconnecting + retrying
04/14 16:13:59 Warn: [zoneplayer/raat] Error during streaming: System.Exception: serverside buffer overrun
at Sooloos.Broker.Transport.RaatTcpAudioSource.SendFrames (System.Net.IPEndPoint ep, System.Int32 stream_id, System.Int64 streamsample, System.Double buffersize, Sooloos.Audio.StreamFormat format, System.Double gain, System.Double peak, System.Byte[] buf, System.Int32 nsamples) [0x0060d] in :0
at Sooloos.Broker.Transport.RaatZonePlayer+<>c__DisplayClass31_0.<_StartStream4>b__1 () [0x00591] in :0
04/14 16:13:59 Warn: Track Stopped Due to Error

As stated previously all resources are running below aprox 15% during this

Hi @Fred_Bloggs,

Does this issue only occur on the Nova or can you also reproduce it with the same ALAC files on other zones (that support 24/96)?

What does the Signal Path look like when you attempt to play the ALACs? Could you capture a screenshot before the stream ends and post it here?

Hi, thanks for reply
When I play this file ( and other 24/96 ALAC ) on other zones ( google speakers ) it automatically downsamples and plays ok
When I set the the max sample rate for the Nova in Roon to 48kHz it also plays ok ( attached success.jpg )
When I set max sample rate for Nova in Roon to 384kHz ( so no forced downsampling ) it fails ( attached failed.jpg )
File(s) will play on Nova if sent direct ( not via roon )

Hello @Fred_Bloggs,

A. How is the Naim Uniti Nova connected to the network? Via WiFi or Ethernet?

B. If you use Roon’s DSP engine Sample Rate Conversion with the “Max PCM Rate” option, do you see the same error?


Its wifi but as I say playing these tracks outside of roon is fine
Roonserver and music server is the same Linux box so same path
I have just tried DSP set to Max PCM Rate and same problem

Hello @Fred_Bloggs,

Roon Ready (RAAT) streaming is a bit different than other methods.

RAAT sends the device a full uncompressed PCM stream, equivalent to a .wav file. This is what allows Roon’s DSP + Multi-room features to work as well as they do.

UPnP and other playback methods either send the original file to the device or use compression to reduce the bandwidth requirements on the network.

That said, we will continue to troubleshoot this issue further to determine if this playback error is related to bandwidth or some other factor.

Please use the instructions listed under “Option 2” to send us a full set of logs.



I have uploaded files as requested (westiebj-LOGS.zip) and shared with community.roonlabs.com

Hello @Fred_Bloggs,

Could you please post the share link in this thread? You may also send me a PM as well.


Hi John
Not sure how to PM you ?

Hello @Fred_Bloggs,

Click on my name and then a “message” button should appear.


Unfortunately all I get is badges and some other stuff … no messaging info
Sorry to be a pain but dont really want to share the link to for everyone if it can be avoided

It looks like below. The blue message button.

Hi ged

Thanks for your help

Bizarrely I had been doing that and no message option
Just tried it again …and there it was :open_mouth:


1 Like

Hi …
A small update from my side
I have converted the ALAC 24/96 files to FLAC 24/96 files with the same result
Played via the Naim app all behaves ok
Played via Roon and same problem … starts to play ok and aprox 5 secs in stutters and stops

Can you move the nova temporarily so you can connect via ethernet and see if it still does the same thing?
Use the headphone socket rather than move speakers.

What can I say … well done that man !

Both server and Nova on Ethernet now and it worked first time ,
Played several files at 24/96 flac and alac and all now works

It’s always the simple things … ( well sometimes )

Roon must add some serious overhead as the files stream fine using direct methods
You live and learn

Thanks !

1 Like

Takes a simple person to suggest the simple :slight_smile:
Actually, well done you for trying. You’d be amazed how many people flat out refuse to try.

1 Like