44k Upsampling to DSD512.... dropouts

Core Machine (Operating system/System info/Roon build number)

NUC8i7BEH, 16GB,256GB m2, 1TB SSD, ROCK, Version 1.0 (build 227) stable - Version 1.7 (build 710) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

UltraRendu USB>Ultradigital i2s>LKS MH-DA004 DAC

Description Of Issue

44k Upsampling to DSD512-dropouts.

A little history, I had been using an SGC 1st generation i5 with ROON for a few months. It was working great, was able to handle upsampling without any filters to DSD256 with ease. Since my DAC can handle DSD512, I thought I’d like to give it a go to get something faster since the SGC i5 couldn’t handle it. I opted for the NUC8i7BEH which I put together yesterday. I let it run all last night getting the library together, restoring from a fresh backup taken off the i5

Today I had my first audition of the fresh new NUC. I enabled upsampling to DSD 512 for 44.1K, DSD256 for everything else. I played several 44.1K tracks from the internal SSD drive right from the start. Whatever I threw at the new NUC it played just fine, for about an hour or so.

I started to get dropouts on a 24bit 44.1K track off of Tidal. Then thinking it may be just the track, I tried another local 44.1K 16bit track, dropouts as well. Processing speed is 2.1-2.3x at DSD512. Changing upsampling to DSD256, dropouts vanish. NUC is hardwired to the router. Changing ethernet cables, controlling the NUC with an Ipad or local PC via ethernet etc, same issue.

I have no filters enabled, headroom adjustment to -3db enabled or disabled same issue, Parallelize Sigma Delta Modulator enabled, Enable Native DSD processing on or off, same issue. Is it that this NUC can’t handle this type of upsampling, or am I missing something?

is your library still analysing? not importing but analysing

It is not analyzing at the moment. I don’t believe it was then either.

I will check next time it happens. Should this NUC be sufficient for what I am trying to accomplish?

While this is typically an OK speed its getting closer to the 1.4x bare minimum but this target could have moved as roon features and loads can push lesser spec systems to marginal performance.

this could also be related to internet speed for tidal stream too or if there is any other network load. How is the DAC connected to the NUC? if wifi then this could be the straw thats breaking.

Everything is hardwired. There was zero load on the network, just one endpoint, no other users.

The DAC is fed I2s HDMI from the Sonore UltraDigital, which is fed from the USB of the Sonore UltraRendu which is fed from Cat 6a from the network.

Just saw processing speed of 1.5 at the start of a track when the dropout occurs. Also see it at 2.5 on the very same song. Tried the same song, Norah Jones “Don’t know why” both from Tidal then from LAN via internal SSD on NUC with the exact same stuttering results.

So assuming the NUC is not up to the task of upsampling the simplest audio track from 44.1K to DSD512, which NUC is? If none, why is it DSD upsampling to 512 listed as an option in Roon? If someone can suggest a desktop configuration that is known to work for what I am trying to accomplish, that would be helpful. I was hoping to stick to supported hardware to avoid the conundrum I appear to be in.

Try direct connect your DAC to the NUC via USB.

1 Like

Sometimes it’s something else in the chain that drops the ball. Petter has a valid suggestion imho worth a try. The core Nuc “should” be ok

I think my DAC only supports DSD512 via I2s, I will check that later. Can someone at Roon try to play this track on a Nucleus+ to see if it plays without stuttering with the same upsampling configuration please?

Hi @fmzip,

Looking over the documentation I found online for this DAC it seems to only support DSD512 via Windows and not Linux:

The machine uses the Italian Amanero USB module, supports PCM and DSD decoding in USB access mode, PCM supports 44.1K ~ 384K various rate, DSD support DSD64, DSD128, DSD256, DSD512 (Windows).

That’s correct, over “USB”. I am going thru i2s

I just tried my Dell XPS 15 laptop ( i7-6700HQ 2.6 GHZ 8mb) as the core to make certain it wasn’t my DAC or Ultra Rendu posing the problem.

Upsampling 44k to DSD512 worked perfectly. Processing speed with the laptop was 1.3x. Odd?

Let’s close this out, the NUC8i7BEH is shipped back to the vendor.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.