5 minutes to load a single track since 2.0 Build 1211

Hello, @Mike_O_Neill and @CrystalGipsy. Mike, the full story for me is spread over a couple of support threads. Important to understand that after I had backed up my NAS files to separate 16Tb drives, disconnected the NAS from Roon and started the process of adding tracks to my library from scratch, I did reach a point at about 130K tracks when the “adding music to library” actually stopped. At that juncture, Roon operated flawlessly — quick searches and startup of playback.

Since I knew I was then still short by many tracks from what I had when the NAS was connected, I thought I needed to get Roon to restart the track additions. So, I rebooted my Roon core server and that got the track addition process back underway. But it then made it virtually impossible to use Roon again. Sigh.

My point is that I don’t think there’s any good purpose to trying to rebuild the Roon database a third time now, at least until Roon’s tech team looks at the log files I have sent along to them over the past couple of weeks.

Crystal Gypsy is correct in that I, too, have seen other reports herein by others with similar issues. It really does feel like a bug, unfortunately.

To your question about the size of data on my hard drives, I do have about 1,400 multichannel and Dolby Atmos 5.1.2 files on there. Those are very big — often 6-8 Gb per album. I also have the legacy iso files on the drives, which do take up space, although all DSD files are converted to separate DSF stereo and multichannel files for Roon playback. Further, the vast majority of other tracks are 24/96 at a minimum, up to 24/384.

I should mention that Roon ARC is essentially non-functional through this as well. I constantly get the error message about a poor connection out of home, which I know is not the case from my early access use of ARC before this whole database thing went sideways. JCR

1 Like

Cool! 10 chars

Roon will analyse a file for level etc normally these will be <200 Mb, so presenting a 8gb file may be the cause . it may simply run out of resources for such a big file . You could try turning analysis off , see if that helps.

My biggest files are possibly 500Mb , a symphony movement in 24/192 so I have never approached any limit. Mostly mine are 44.1 or 96 with a very few 192

the Logs will no doubt show this when the support guys get around to analysing them.

@Mike_O_Neill , I’ve had the analysis stuff in Library shut off. This doesn’t stop Roon from continuing its attempt to slowly add additional tracks.

Let’s see. 20 hours ago, Roon had identified 270 of 28K remaining tracks. Here’s where we are now, 20 hours later:

1,000! Yikes, that’s a mere 36.5 tracks an hour, with audio analysis shut off. JCR

I know you know , but that’s not right :stuck_out_tongue_winking_eye:

Roon is calling home to mama for ID so once again it points to network. Either yours or theirs.

I added 3 albums say 30 tracks in probably a minute, that,s right

Have you checked DNS Settings, I am not an expert on that , but it looks like You to Roon has a disconnect?

I am still a bit concerned over the massive file size, I have not seen another user with such a collection, I could be wrong.

@support should comment on such files in your logs

Not a lot of help :cry:

Geez this is really unfortunate situation - do you have “Background Audio Analysis” turned off? Also, are the drives holding the music files internal or external USB connected to core?

Hello, @Swisstrips. I do have background and on demand audio analysis turned off. These drives are externals, connected by USB3.0 to the Roon core server. I did have my NAS connected via Ethernet and was having the same issues, which is where this all started. So, after I had backed up the entire NAS to the external drives — that took some time with 43Tb of data, about 40Tb of which are my music files — I disconnected the NAS from Roon and pointed my music folders in Roon to the external drives. This was to prove up that the adding music to library issue wasn’t because of my NAS being slow on I/O, it being a Synology 1813+ with an older, smaller processor. The experiment to me demonstrates a Roon bug.

@Mike_O_Neill , I’m not sure what I would be looking for in DNS settings. I can tell you that I have Gb internet streaming and no issues with network connectivity for any other situation on the Roon core server or otherwise at our home. JCR

If you have 4 USB external drives , have you tried disabling 3 of them , leaving just one as a watched folder. Settings> Storage Theoretically a USB controller will work with 4 external drives (up to 127 devices !!) but you will obviously suffer on speed USB is slow relative to SATA

I assume these are externally powered USB HDD like Seagate/ WD etc.if not the power will be shared too.

Use the 3 Dots to Disable each one.

Its worth a try , I have run 2 external drives in the past but normally a singled one

Also if you go to Settings>Storage what do you see ? Certainly on ROCK as you start up it will rescan all external USB drives , but NOT the internal Drives that means all 48tb , that will be slow. On mine the USB drive shows 67134 but at startup that starts from 0 and rescans to the number , maybe check that . You could be spending resources rescanning drives

I wonder if you are asking too much of USB

I added internal drives to my Windows PC so they were SATA connections . My PC has a gaming mother board just to give me more SATA points than a normal MB. I have 1 SSD and 4 HDD internally. (Audio and Video)

Depending on how handy you are you can extract the HDD from the USB housing and mount it within the PC chassis and connect by SATA. If my suspicions are correct.

@Mike_O_Neill , this was an interesting experiment. I sequentially disabled the USB drives so that I could see what might happen if only one of them was active. With drives 1 and 3, the adding music to library is complete. If only drives 1 and 3 (and their corresponding folders) are active, the spinning semicircle is gone from the Roon home page and tracks, albums, searches and playback all occur quickly. These two drives account for 159,452 of 278K total tracks.

Drive 2 is where the action is at. It has 27K of tracks that Roon is trying to import at below snail’s pace speed. Roon stops functioning, for all intents and purposes, if only Drive 2 is enabled, clearly because of the importing issue.

To close the rest of the loop on your comments, the external drives are actually internal drives that are running in an externally powered docking station. This test, however, suggests that installing the drives internally would make no difference, just as using my NAS via ethernet still has the same issues.

So Roon obviously doesn’t like something on Drive 2, which is probably the same thing that is on the NAS. I want Drive 2’s content, of course, which is for albums with artists G-R and includes 600 of my 1,400 multichannel/Dolby Atmos albums.

This leads to the next experiment. I have identified a series of folders on Drive 2 that hold mainly old mp3 files which, frankly, I don’t listen to (but they are helpful to find a corresponding TIDAL album). I’m copying those folders off to Drive 4, which has always been disabled from Roon. Once the copying is complete, I will start deleting the folders sequentially from Drive 2 to see if one of them is the big holdup. JCR


I wait with baited breath :smiling_imp:

1 Like

Ok, @Mike_O_Neill. I can now report back on where I am at now.

Having pulled a batch of older mp3 out of hard drive 2, I seem to have gotten the music adding to library to stop. So, I went back to my Synology NAS and moved the same set of files out of my watched folder. This led Roon to do a full rescan of my NAS watched “Music” folder under new production build 1223.

The result:

All is working fine off the NAS!

Is this due to Roon getting hung up on some the tracks I moved out of the watch folder, just simply because of a fresh scan because the old database was corrupt or something to do with build 1223 over prior versions? I don’t know….

But now, what is the 16,137 track difference between what Roon reports as imported and the number of tracks on the home page? I ask because, for example, my 8 channel version of John Williams’ Berlin Concert no longer appears in my library, even after a forced rescan. Before I started down this odyssey, that album was available. (It sounds really good.)

I also note that Roon garbled the track ordering for Toto IV and has separated the versions of albums in many cases. For example:

Why is this not appearing as a single album with multiple versions? I’m not looking forward to fixing this all through my 200K+ tracks.! Thanks. JCR

About the Let it Be: What is your setting for Settings > General > Show hidden tracks and albums? Set it to No if you want album versions grouped. If yes, each version is displayed separately

Ah, @Suedkiez . My bad for not saying earlier that show hidden tracks and albums is indeed shut off, which is why I am asking how to fix, short of manually going through my entire library. JCR

Oh OK, I thought that must be it because it seems weird to me that you seem to have so many that are not auto-grouped, but no idea why.

Roon will auto group Let It Be’s if the Album Name tag is Let It Be in each case with no additional text, maybe post a snapshot of the file folders …

If in your folder you have a structure “Let it Be [Super Deluxe]”., “Let it Be [Version 2]” anything in [Version] after the title will be interpreted as the Version. You can also use a Custom Tag [Version]

If your Album folder are anything else Roon will treat them as separate albums eg "Let it Be - Some Descriptor "

Its the same with Box Sets if you have a box with 10 CD’s nd the folders are named CD1, CD2 and they all have a common Album Name Roon will group them as a Box. If the album folders contain more than CD1 eg CD! - Abbey Road Roon will see each folder as a separate album and try to ID accordingly

It Sounds like you’re on the right track though

Hi @Mike_O_Neill . Ok, got that.

Can you help with the example album, the John Williams 8 channel Berlin concert? It’s in the same watched folder on the NAS that it has always been, yet Roon won’t recognize it. JCR


But its not showing a multi media 8.1 version. Roon is only as good as its data sources. Discogs shows much the same as a 2 CD set

It’s the digital media source. As earlier noted, Roon properly recognized and played the album for me until the new scan of my entire library.

For comparison, this 8 channel recording of Stravinsky is recognized by Roon, even though it does not appear in MusicBrainz as an 8 channel recording:


And here is how it appears in Roon:

When Roon doesn’t recognize my 8 channel recordings, they still appear anyway, just without the full metadata:

So why doesn’t the John Williams Berlin Concert show up in one way or the other? The Olympic theme in Dolby Atmos is one of my favorite demonstration tracks. JCR

Hi @Jeffrey_Robbins,

Please allow me to ask about the current status.

So the problem with endlessly adding music to the library (see 5 minutes to load a single track since 2.0 Build 1211 - #47 by Jeffrey_Robbins) is solved for you and everything is working as it should? The overall responsiveness of the Roon system etc. is also fine?

I have noted that Roon has released an update Roon 2.0.12 and ARC 1.0.33 are live! - #3. Can we please assume that this update fixes the problems described?

Thank you

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.