7" Display Issue with Ropieee


I have Ropieee running with the official 7" display, and the display keeps saying “Zone not found”.

I have the endpoint enabled and the extension enabled:


What else am I missing, I cannot seem to find another setting to make the screen work.

Have you configured the zone in RoPieee’s web interface?

Make sure you enter the zone name precisely as in Roon.

@Jim_F, now the display is working but I cannot seem to do anything with the display buttons. Like I press the next song the screen refreshes but the next song does not come on.

I have the Remote Control zone set up too:

Sorry Leo, I’m not familiar with the remote control. However, looking at your screen shot, it says Remote Control = none.

That has nothing to do with the screen but with remote control units like the Flirc.

So what am I missing?

The screen is working but the next song, pause, and previous song buttons do not work.

play with the screen rotation

Have you tried rebooting the core and the Pi?
From the screen shots it looks like the settings should be right from what I can see.

Does the touch screen work? Can you get to the menu on the 7" display (touch lower right corner to toggle through modes to the menu) or turn the screen off and on using the touch screen (upper right corner)?

(I’m not close to my Roon system so this is from memory) You need to enable the Ropieee remote extension in the Extensions tab in your Roon settings.

1 Like

I figured it out.

The image on the screen has the correct orientation but the touch screen is all flipped. Hitting the upper left-hand corner gives me the menu instead of the bottom right. Hitting the bottom left-hand corner turns the screen off.

I changed the orientation to “default” instead of “rotated” and it is working correctly now.

I guess i don’t understand why by default the setting would be set to “rotated”

@spockfish feedback submitted just in case:
unique identifier 31549c005217fe09

For many cases, this is the setting that is required.

It depends on the orientation of the screen in the case you are using.

Why would the touchscreen orientation not match the image orientation? Those two are always the same…

I don’t know what that means. It will always be landscape. I guess some cases align the screen 180 degrees to some other cases, therefore the ability to rotate the screen in RoPieee. IDK.

Some (older?) touchscreens address the pixels that way,

What Nathan says. In most cases that are out there the screen is mounted ‘up-side-down’, hence the default is set to that.

1 Like

Ok. Now I know and it’s working. So thank you all