7Inch Display not Tab

Hi Harry
@spockfish ,
I have installed my 3rd RoPieee XL system .
Just attached the original 7inch display, which works flawless on my first system, but here the Display tab does not appear.
All messages show up during boot on the display until system is up and running.
Have send Feedback note 40dfd972f32eb24e.
Do you have any idea, what the problem could be?
thanks a lot and with best regards

The screen needs to be present upon installation. You can not attach it later on. Is that the case here?

Ahhh, was checking further and read the beginners guide again. :thinking:

The display is only detected at the time of
initial installation and the software
installed then. Re-flash if adding the
display to an existing RoPieee endpoint.
So, I flash it now and hope it works afterward.
I’ll post the result here again.
Sorry for inconvenience.

1 Like

Ah, sorry you were faster.
Yes, seems this is the problem.
Sorry again
But wow, you are fast :slight_smile:

Hi Harry, @spockfish
sorry to bother again.
Reflasched and I see during boot that the Display is deteced…
When finally RoPieee XL up and is RUNNING I get the Message
“Unfortunately the installation has failed.” on the web interface.
The latest picture on the display is:

I flashed two times with the same result.
Internet is connected via Lan-cable.

Any idea?

I think you’re good. Now you need to use a browser to go into the RoPieeeXL setup menu.

Thanks Jim,
unfortunately the RoPieeeXL setup menu shows the following error message.
thanks a lot for your support

Did you leave the RPi4 connected by ethernet to your network and the internet while going into the RoPieee setup menu using a browser?

Yes, still connected to the cable.

nope, still not working
rebooted Rock and Ropieee. Reflashed the SD card.

I now tried to get the latest Ropiee (without XL) version from ropiee.org but links don’t work?!
Get the message:


The request could not be satisfied.

CloudFront wasn’t able to connect to the origin…

For flashing yesterday I used the latest version I had on my PC.

maybe that’s the reason?

The SSL certificates where expired for RoPieee’s infrastructure. That has been resolved now. You can try again.


Yes, this solved it. Thanks a lot.
System now works flawless.

So, here a quick picture of what I’m up to.
ES8038Q2M board connected by I2S interface for Raspiee.
Now with basic Ropiee driver.
5inch display with Roon/Ropiee (works nicely)
Additional Coax and Optical input
separated power supply for raspi, DAC
separated transformer for 5 Volt Raspi, DAC,…
small display from DAC into the front
5inch display on top with the possibility to rotate a bit related to listening position.

Thanks again and best regards from Aachen/Germany

Hello Klaus,
I thought that Ropieee only supports the 7 inch display. Nice to see that a 5 inch display also works. Can you tell us the brand/model of the display?

Hi Jan,
yes, the official statement is the support of the 7inch display only. I fully understand this, as there are so many displays available that it would be really difficult to test and support these.
It is important to notice that only displays with the direct connection (DSI) may work.
I read within another post in this forum about the 5inch display.
OSOYOO 5 Inch DSI Touch Screen LCD Display 800x480
I ordered it at Amazon and it works perfect.
Initially I made the mistake to simply connected it and was expecting it functions immediately.
Point is, that only at initial installation with a newly flashed SD-Card RoPieee searches for the display and if found installs the required software.

1 Like