A couple of questions

Hi All.

I just gave Roon + HQPlayer a test and so far I’m pretty impressed, but:

  1. Sometimes HQPlayer gets confused and I have to try skipping/pausing/etc to get it to fire up again. Once playing, its buttery smooth, but the changes sometimes get it confused. Is this something that is being addressed for a smoother overall experience?

  2. George @ Exasound indicated they will come out with a hardware DAC volume control similar to the JRiver plugin which syncs the DAC hardware volume with the software when the “Control API” is out. When is this API going to be released?

I’ll probably have more later, but so far positive first impressions. Now to hook up Tidal…

Hi Greg,

  1. What changes are you making that confuse HQ Player ? You should be able to control playback from Roon without experiencing any disconnections (there were initial problems in that regard which have been fixed). If making changes to HQ Player filters etc. it is best to wait until HQ Player stops (as distinct from pauses) before bringing up settings etc.

  2. The API is in the works, but no announcement has been made as to release. I suspect it is likely to be in the next major feature release (whether that is 1.3 or not), but that is pure speculation on my part.

It seems that 96khz source doesn’t up-scale to DSD properly.

For example, Leonard Cohen Slow, or anything from that album just makes HQPlayer go crazy with play/pause flickering on HQPlayer and nothing plays.

My HQSettings are: DSD5v2 256+fs, closed-form, SDM (DSD256). HQPlayer backend NAA to my NUC which is streaming to my e20 in native DSD.

It is generally working quite well, with the exception of higher than 16/44.1 material.

Any ideas?

I haven’t heard of Tidal streaming 96 kHz source files. Can you upload a screenshot showing the audio path in Roon ?

Closed form filter won’t play certain sample rates (I think the source has to be an exact multiple of 44.1 kHz), but in my experience it just doesn’t play those files rather than causing glitches. Try another filter and see if that makes a difference.

Sorry the blending between Tidal and Local is very seemless. I was originally browsing in Tidal but played my local copy (This is not a bad thing!)

you are correct, closed-loop does fail on 24/96 material. It works with other filters.

Do you have “Auto rate family” enabled in HQPlayer settings and rate drop-list set to “Auto” in HQPlayer main window? closed-form doesn’t allow upsampling to different base-rate, so the output sampling rate needs to be switched when necessary. e20 should support DSD256 with both 44.1 and 48 base rates (rate families).

Plain “Auto” as rate should be enough as such, then it’ll stick to highest rate that is equal or less than the set rate limit and is possible with the currently selected filter.

I do have Auto Rate family enabled. The dropdowns in HQplayer were forced to various settings for testing. I changed them back to auto (except closed-form on the left)

Still experiencing flaky behavior. This time with local 16/44.1 material. I tried changing zones but roon+HQplayer doesn’t handle that very well. Other general instability. Its not a very smooth experience I’ll be honest. Here’s an example where the HQplayer NAA crashed when I tried to change zones and I had to restart the NAA daemon. I had no idea it crashed.

This also meant having to restart HQplayer because reloading the NAA daemon wasnt sufficient. I had no way of knowing this. Not good.

[networkaudiod] (4764): Using ASIO default buffer size
[networkaudiod] (4764): Using ASIO buffer size: 8192
[networkaudiod] (4764): Latencies: 8192/24576
[networkaudiod] (4764): Not using ASIO output ready notifications
[networkaudiod] (4764): start failure: clASIOMiniEngine::StartAudioClient(): ASIOStart()
[networkaudiod] (4764): enter streaming mode
[networkaudiod] (4764): exception: clAlignedAlloc::SetSize(): lAllocSize < 0

Also seeing random exceptions in HQPlayer. said it stopped working.

Now I am chasing down random restarts in both my HQPlayer and NAA daemon

You may not want to set output mode to auto, because then it’ll start switching between PCM and DSD output modes. Just the sampling rate.

This error is from the ASIO driver (failed to start playback) and rest of the errors are result of the earlier failure. networkaudiod may exit if it encounters unrecoverable error, it doesn’t mean it crashes.

If you can email me your exported settings, log file from start to a crash and exact steps how to reproduce the crash, it would help a lot finding where the problem is and fixing it.

Here are my exported settings when it crashed. I can’t give you steps to reproduce, I was just browsing a combination of tidal and local (nas) music. I was also swapping roon between exsound direct, and via hqplayer. I usually pause the first stream, but not always. It could be related.

<?xml version="1.0" encoding="UTF-8"?>
	<engine auto_family="1" cd_drive="D:" channels="2" cuda="0" direct_sdm="1" fft_size="512" pipeline_sdm="1" sdm_integrator="0" type="network" volume_limit="-3" volume_min="-60">
		<defaults bitrate="11289600" dither="5" filter="15" modulator="3" oversampling="12" samplerate="384000"/>
		<network address="Default" dac_bits="32" device="exaSound ASIO64 (2ch)" dualwire="0" ipv6="0" pack_sdm="0" period_time="0"/>
		<transport dsd_6db="0" pdm_conv="5" pdm_filt="0">
			<directory album="Philharmonics" artist="Obel, Agnes" path="\\nas\Music\Music Library\Alternative, Folk, Pop Rock\Agnes Obel\2010 - Philharmonics\Philharmonics" performer=""/>
	<interface full_screen="0"/>
	<log enabled="0"/>

and on the NAA daemon:

[networkaudiod] (424): ASIO format set to DSD
[networkaudiod] (424): ASIO DSD buffer size is in bits
[networkaudiod] (424): Rate available: 2822400
[networkaudiod] (424): Rate available: 5644800
[networkaudiod] (424): Rate available: 11289600
[networkaudiod] (424): Default ASIO channels: 0 in / 2 out
[networkaudiod] (424): Default output channel 0: Out 1
[networkaudiod] (424): ASIO DSD format MSB1
[networkaudiod] (424): Default output channel 1: Out 2
[networkaudiod] (424): Set channels: 2 (2)
[networkaudiod] (424): Set sampling rate: 11289600 (11289600)
[networkaudiod] (424): ASIO channels: 0 in / 2 out
[networkaudiod] (424): Output channel 0: Out 1
[networkaudiod] (424): Output channel 1: Out 2
[networkaudiod] (424): ASIO buffer sizes: 32768/98304/262144 granularity: 32768
[networkaudiod] (424): Using ASIO default buffer size
[networkaudiod] (424): Using ASIO buffer size: 98304
[networkaudiod] (424): Latencies: 98304/458752
[networkaudiod] (424): Not using ASIO output ready notifications
[networkaudiod] (424): start failure: clASIOMiniEngine::StartAudioClient(): ASIOStart()
[networkaudiod] (424): enter streaming mode
[networkaudiod] (424): exception: clAlignedAlloc::SetSize(): lAllocSize < 0

I’m back to listening with HQplayer, so If I obtain more granular steps to reproduce I’ll let you know.

next problem. If I play an album (tidal in this case) I can’t seem to skip tracks. The >| button does nothing…

EDIT: Working now. I had to re-click Play Album and it started working again. Weird.

Found another issue. skipping tracks in tidal doesn’t always play (unrelated to the issue mentioned above which I havent been able to reproduce yet). About 1 in 10 “next” starts looks like it is starting to play but doesn’t.

Here is what happens:

  1. the audio of the currently playing song stops
  2. according to the gui its playing the next song (I see the animation)
  3. according to hqplayer the stream is still going (the drop downs are all greyed out)
  4. no cpu activity on the hqplayer machine, and no audio.

If I pause, I will hear audio as if the state is backwards… but then stops a few seonds later as the buffer runs out

If I then play again it usually works normally

Sounds like Roon has lost control of the transport- you have stop the HQ Player - make sure it is not working- then try again with Roon -

Yes… it lost control of the transport. So Is there a ticket for this? You are answering it very nonchalantly as if its a known problem?

Currently its somewhat unusable as I have to constantly do this.


Here’s a good example. If I play from Tidal (season 2 episode 3, glass animals) using Exasound direct, it works just fine. However, if I use HQPlayer streaming DSD256 to my DAC I get dropouts exactly at the same spots… my USB connection light is going crazy and I hear audio dropouts as if the buffer is running out on the DAC.

This is all on the same network. I tried increasing HQPlayer buffer to 100 and 250 but it drops out at the same spot.

Any ideas? This is poly-sinc-2s, DSD5v2 256+fs. cpu usage on that machine is 20-30% while HQPlayer is playing. I have auto rate family and pipeline SDM enabled

Update: seems to be really program material dependant. Some songs work fine, while this glass animals song drops out in exactly the same spots.

Yes - sounds very frustrating - Apologies if I sounded dismissive in my last post - I have been playing with HQ player settings for a couple of weeks - I have been trying the same with DSD 256 files via Roon/ HQ Player - and have tried a matrix of settings for a smooth output (see my other post which shows the settings I have settled on for my Devialet) - I can’t seem to get a smooth output via HQ Player. The problem is that the HQ Player guide is not as clear for a “man on the street” to understand in terms of what are the optimum settings - I have sent an email to Signalyst for guidance - waiting to hear back. For now I am simply using Roon direct to Devialet via AIR protocol - the SQ is pretty good, including playing back DSD 128 which is processed by Roon at 176k.

Well I just purchased HQPlayer, so I hope there is a fix for this, otherwise I will have to consider cancelling that purchase until this matures :confused:

More info - its definitely program specific as it happens in exactly the same spot. Doesn’t matter i its DSD256 or DSD128. It sounds like a bug in HQplayer.

Another update: Only happens with upscaling PCM to DSD. PCM upscaled doesn’t have this issue.

Could it have anything to do with handling silent passages?

Hoping jussi_laako can offer some thoughts here

Thats both of us purchasing HQ player - so I do share your sentiments.

No issues for with various PCM audio and DSD 64 files/ streams. PCM upscaling for TIDAL works fine for me - except I cannot see any SQ benefits as compared to straight Roon/ Devialet via AIR - the Dev up samples TIDAl to 192 k in its DAC - perhaps HQ Player cannot add any more to SQ here. This was mentioned to me by another Dev owner at this forum.

With DSD 128 - I do experience clicks in the playback - at first I thought it was my AIR protocol with DEV (as widely reported here and other internet chat forums) - but I eliminated that by doing tests without HQ Player etc - and tested different scenarios with and without HQ Player - suffice to say I am pretty sure its not AIR as it has not played up once with Roon/ Dev. I did the test with USB and the HQ player provided the same issue on playback of DSD 128 files. I am hoping its the settings on the HQ player and like you am looking for a resolution.

Why do you purchase something in first place if something doesn’t work properly?

This kind of talk doesn’t help anything, but instead get people on my most-hated-list.

What is your volume setting in HQPlayer? Does the “Limited” counter stay zero at all times?


Whilst you are looking a Greg’s issue - could you pls look at my settings which were posted on

Could you pls provide some guidance on the optimal settings for a Devialet. Many thanks. Rash.

I apologize about my snarky comment questioning HQPlayer maturity. I agree it was uncalled for.

I also have verified this is not an HQPlayer (only) problem. I do not encounter any issues (so far) playing back lots of local pcm files in HQPlayer’s interface (no roon).

The issue appears to be either entirely roon, or a roon/HQPlayer integration issue.

I have followed up with jussi via email for logs