A little convolution problem with DSF tracks [Resolved - bad file header]

Hi from France,

I’m a new user of Roon and I’m actually in testing period during the 14 days free trial period.

I must convince that I really like using Roon because I really like the different features, its ergonomics and, a very important thing, the sound quality provided by the combo Roon Server + Roon bridge driving a DAC Wyred 4 Sound DAC2 DSD SE on my HIFI system.

At this time my prefered configuration consists of two computers with Intel i7 4790S CPU 8GB and 4GB of RAM with a minimal install (no GUI) of Fedora 24 server with Planet CCRMA RT kernel installed and tweaked a little bit for audio.
One of the computers is running as Roon server and only Ronn Server is installed on it. The other computer is running as player PC with only Roon Bridge installed.
I can tell you that a such configurations is awesome in term of sound quality with Roon.

In another hand one of the reason I decided to give a try to roon is because Roon is now including convolution for DRC.
I must convince that is doing this job very well.
But I’ve just noticed a problem with a particular configuration of convolution filters.
In fact, if I use directly wav impulse files mono (L + R) or strereo in zipped folders there is no problem everything works fine.
But if I use the same impulse wav files combined with convolution configuration files (.cfg) I can play my flac tracks without problem but I can’t play my DSF (DSD) files in this particular configuration of convolution files. I get this message:
“Transport failed to load media due to unexpected error communication with audio device”.

It’s not a great problem as convolution works with all kind of tracks with other convolution configurations but, I don’t know the reason why, my system sounds a little bit better with the convolution configuration with .cfg files.

Is there a reason to this problem or is it a bug in Roon?

Manny thanks in advance for your help.

Best regards.

1 Like

I think your CPU is running out of puff, or maybe you haven’t turned on the parallelism sigma-delta modulator option. Fell in this trap myself

Hi wizardofoz,

many thanks for you reply but an i7 4790S CPU is not a really tiny CPU and convolution is perfectly OK with direct wav impulse convolution file in zipped folder even when DSD files are played.
The problem occurs only with exactly the same wav impulse convolution files but with .cfg files added in the convolution zipped folder.
In this case, Flac tracks a re payed but not DSD tracks and the message I mentioned in my previous post appears.
I don’t use native DSD, so DSD files are converted to PCM 176.4 kHz to suit to my W4S DAC.
I get the same problem even if i toggle Parallelize Sigma-delta Modulator to “yes”.

I’ve noticed something else strange. Here is the audio chain when I’m playing a DSD file with sample rate conversion disabled in DSP Engine:

And now audio chain when I’m playing the same DSD file with sample rate enabled to DSD with sample rate to DSD64:

We can notice that the convolution filter seems to double the sample rate length of the convolution filter.
Basically the sample length of my convolution filters are 131k taps and when DSD file is played with sample rate conversion enabled to DSD 64 it appears that filter length is 262k taps.
Is it normal?
I must mention that in the case I’m using sample rate conversion to DSD elements such as voices which could be played in the center of the sound stage are deported to the right side.
I can notice the same behaviour with flac tracks converted to DSD (center deported to right).

I don’t know if these two problems, the first i mentioned in my previous post and the second i’ve just mentioned are linked to the same thing.

Please try this:
Set by “Device Settings” : General: Hide Volume Control in Roon on YES

@support maybe the boys in HQ can run this one through the mill.

I guess you seem to have enough puff there based on the additional screen shots, so clearly there is some other thing going on.

You will be asked for more info I guessing as noted here

Hi Roony thanks for the tip but I don’t have this “Hide Volume control in Roon” item in Device setup -> General.

I just have this:

Ok, and what are your plaback settings.

Yes sure there is a problem somewhere.

In fact I have the same problem using Ron bridge on my minimal fedora install or when I’m using squeezelite on another fedora minimal installation or with other distribution such as Ubuntu. So it doesn’t seem to be relative to the endpoint which is used, apparently.
I’m using wav filters made with Acourate, 64bits 131072 taps for the sample length in wav format, I’'m using a zip folder with these impulse wav stereo files with sample rates from 44100 to 384000Hz which are working perfectly with FLAC and DSD files if I don’t use DSD sample rate.conversion (centered soundstage problem). Another zip foder with mono left plus right impulse wav files (same characteristics) is working the same.
If I use zip folders with the same impulse wav files but with addition of cfg files) FAC files are correctly played but DSD aren’t played as i described in my first port.

Perhaps there is just some limitations to convolution usage at this time. :wink:

I hope this description is quite accurate as English is not my native language, I don’t know if I express myself quite clearly.

Here are my playback settings:

Try to disable: MAX Sample Rate (PCM) and MAX Bits per Sample (PCM).

J’ai ce même problème, mais j’ai seulement une poignée de pistes .DSF. Je contourne cela en désactivant la convolution tout en jouant ces pistes.

(I’ve always wanted to try google translate) :slight_smile:


I’ve yet tried that but it doesn’t help.

In fact the Wyred 4 sound DAC accepts 352,2kHz or 384kHz in theory but it is not stable for these sample rates (sync problems) and not only with Roon but with Squeezelite or JRiver too. It’s the reason why I have set Max sample rate up to 192kHz.

Hi Mark, not so bad translation from Google translate.:wink:

Note that convolution of my DSF is OK if I don’t put cfg config files in the convolution zip folder and, in this case, I don’t need to disable convolution.
As I think that direct DSD convolution is not possible with Roon for the moment,(only HQPlayer seems to be able to do that) DSF files are restituted into WAV 176,4kHz which is normal and the SQ is very good, however.

It could be interesting to get an advise from the Roon’s support team as I could become a new Roon’s customer. :wink:

Interesting, I’ll try that tonight when I get home later tonight.

Hi @Le_Dom ----- Thank you for the report and sharing your feedback/observations with us. Both are very appreciated!

I had a chance to discuss this thread with my team today and we would like to test with the same content you are using in house that is being referenced in your report (see below).

If you could send us the content via a dropbox download link in a PM we will take a look and see what we come up with :microscope:


Hi Eric,

many thanks for your reply.

PM has been set to you.

1 Like

Hi everybody,

Finally last night before I went to bed I got an idea.
"Damned, I have the impression I’ve put a bad header in config .cfg files for 176,4kHz and 352,8kHz sample rate.

Effectively I have typed respectively 176000 and 352000 instead of 176400 and 352800 in concerned cfg files when I’ve edited them… :scream:
After typing the right values for the headers, now it works!!!
Even when i convert sample rate to DSD the sound stage is no more deported on the right side but only if I use convolution zipped packages including cfg config files.
If I use convolution zipped packages without cfg config files, with just impulse WAV files the soud stage is still deported to right side when I enable DSD sample rate conversion.

A post was split to a new topic: DSF does not play with convolution