Abrupt Roon failures [fixed]

Good morning,

I am running Roon 1.1 Build 88 on a dedicated Mac-mini with Intel I7, 8G RAM, 1600 MHz DDR3, OSX Yosemite Version 10.10.5.

Roon is not seeing two external drives that it previously could read. Some of the Hi Def music files are still in library but will not play. I removed one drive (Lightening connection) and copied it to a second external drive (USB connection). Reinstalled but no luck, Roon would not add it or read its contents. The Mac-mini sees and reads all the drives, only Roon cannot.

I am able to stream Tidal, but not play files I have ripped or downloaded.

Thanks in advance,

Hey @RICK_VANDENPOL – I just sent you a PM. Let’s get some logs from you and we’ll figure out what’s going on here.

Can you also let me know what you’re seeing in Roon – is there an error when you add the drive? Can you post a screenshot of the Storage tab?

Are you seeing any error when you try to play the local content that is in your library?

Thanks for the rapid reply, Mike. Following is a quick reply of possible general interest. I will reply to your PMs next.

I tested Roon fairly systematically over the weekend. I had not been paying close attention, but it seemed like some of my Hi Def albums were missing. Initially in the Storage tab was an error message to the effect that the drive (or file or folder) was not available (I paraphrase). I confirmed that the Mac-mini could see the drive and open the albums listed. Standard definition files would play (on iTunes by default). The drive (Drive #1) was connected by a Lightning cable. I copied Drive #1 to a USB connected drive (Drive #2). I clicked “add a folder” and I browsed for Drive #2, clicked it, but it did not appear in the window. The screen froze, and when I attempted to Cancel I could not. I exited Roon, restarted the Mac-mini and tried again. I did not get an error message, but when I clicked Cancel I saw some apparently random pixels here and there. Then Roon froze again. I did not attempt to type the path name for Drive #2, and instead began reading Roon FAQs. One Hi Def album would play, but others listed in the Library would not, or would revert to a similar cut in TIdal - and Tidal seems to work fine still.

Thanks, Rick

The Mac-mini is in a different location right now. I will post a screen shot when I can get reunited with it.

Hi Mike,

I got an error message when I replied to your email. It is pasted below. Do I need permission to email you?


We’re writing to let you know that the group you tried to contact (community) may not exist, or you may not have permission to post messages to the group. A few more details on why you weren’t able to post:

  • You might have spelled or formatted the group name incorrectly.
  • The owner of the group may have removed this group.
  • You may need to join the group before receiving permission to post.
  • This group may not be open to posting.

If you have questions related to this or any other Google Group, visit the Help Center at https://support.google.com/a/roonlabs.com/bin/topic.py&topic=25838.


Mike, Two screen shots are provided.

I will run the code you sent later. Any way to communicate directly?



I received a note that you sent a PM. Is it in Outlook - I cannot find it.



Had some trouble pasting the two screen shots. Switched to a PC; they are above. The later version shows the pixelation I described.

No error message when trying to play files.

Will run code in a few hours.


Clarification: the top image shows pixelation when attempting to Add Folder. The lower image is a screen shot taken immediately prior to trying to Add Folder.


Hi Mike,

Hi Mike,
Using the Roon portal, I sent the logs using the codes you provided. I have not heard anything back from Roon for a couple of days. (I think a new topic was started by Roon with the heading “Local Playback Issues.”) In any case, as of today nothing plays in Roon. Tidal had been playing, but Tidal no longer plays. My local drives cannot be seen by Roon but the host Mac-mini can see the drives, read the folders, and play the CD-quality files via iTunes).

Can you assist me?


Hey @RICK_VANDENPOL – sorry for the slow response. The team has been analyzing your logs while I was at CES and we’re running slightly slower than normal.

I just responded by PM requesting a bit more information, so take a look and we’ll figure this out.


Mike Sure,

I will send it Saturday. Work is keeping me away from my music hardware. Roon did auto-update but I get the same errors when I try to add a watched drive.

I was not able to attend CES this year - bet Roon got a lot of buzz! The blogs and tweets. Must have been humming.

Any chance of getting me flagged by your filter as a “safe sender” in Outlook? I use a lot of public space in these communications,


I looked in Outlook email inbox but your last PM was Jan 13.

Can we move this bug fix forward? Any value in me removing Roon software and reloading it? Does my lifetime license permit that?


Hi Rick, yes you can re-install. Suggest completely remove the Roon folder to be sure.

Hey @RICK_VANDENPOL – sorry for the slow response here. A few clarifications:

Our community site has the ability to send email notifications, and you can customize when these notifications are sent by visiting Preferences.

However, the only way to post in public topics or private messages is to access the site directly – responding to the email notifications isn’t supported right now.

Moving on, I looked over the feedback from your logs, and it seems like maybe we’re confused about the issue here. Your original post says:

From what we’re seeing in your logs and in the screenshot above, no external drives have been added to Roon. Have you followed the instructions here?

Let me know if I’m misunderstanding something and we’ll get this resolved for you soon @RICK_VANDENPOL. Thanks!

Nick, Thanks I will try that next.



Thanks for explaining how email communication works with Roon. I will use the Roon web portal exclusively to send communication to you.

Sorry for any confusion about my descriptions. Please let me summarize the crash:

  1. Originally Roon allowed me to import files from an external Lightning-connected drive; I also had another external drive connected by USB. All music files on both drives were found and listed in the Roon library. (Lightning drive contained hi def files; USB drive contained CD-quality files.) Everything seemed perfect, sounded great, Roon capabilities were best in class.

  2. The first glitch was a few weeks ago: I could not play some hi-def albums that I had been able to play previously. Others did play fine. The hi-def files that would not play did show in Roon Library.

  3. Next Roon could not find some hi def files in the Roon Library. Forcing a re-scan did not solve the problem. My Mac-mini could see all of these files. I tried a work-around by copying all of the hi def files onto a third drive (also USB).

  4. Roon was not able to add the new drive. The Mac-mini could see all of the files on all three external drives. I re-booted the Mac, but to no avail. Tidal worked fine. Then all external drives and all files on them disappeared from Roon. I contacted Roon Support.

  5. The screen shots I sent were taken when, “Roon (was) not seeing two external drives that it previously could read.” The previously appeared (as I recall) under “Watched,” not “Organized.”

  6. Tidal no longer plays on Roon. It will search and find music but it will not play that music.

I am running Roon 1.1 Build 88 on a dedicated Mac-mini with Intel I7, 8G RAM, 1600 MHz DDR3, OSX Yosemite Version 10.10.5. I have not yet upgraded the OS to El Capitan.

Thanks again for your help,

Ok, understood Rick, thanks. I had PM’d you some instructions for sending us logs, and I’d like you to follow those instructions again, but first let’s have you follow these steps:

  • Add a watched folder that’s the drive you’re having trouble importing. This should reproduce the issues you’ve described above in 2-4. Note what time you’ve reproduce these issues.
  • Try to play some TIDAL content, to reproduce issue 6. Note that time as well.
  • Use the Support ID to send me a dump of logs
  • PM me the times of the various failures you described above, and we’ll take a look


Hi Mike,

Done! I tried adding “Lacie on Lightning” at 6:49 am Mountain Time. I tried playing a Tidal track at 6:57 am. “Lacie” would not add; Tidal searched but would not play.

Thoughts about removing and re-installing all of Roon? If I lose some tags and settings, it is better than not being able to use Roon at all.



Strange event: Just before shutting down, I opened the library and found Lacie (the new drive) had loaded. I can play at least two songs - I have to log off for an appointment. Tidal also plays.

No idea what is different.