Access problems after changes in my network [Resolved]

Hi all,

sorry to come with a second problem in a short time.
The situation: I went from a PC as core to a NUC running ROCK two month ago. Everything worked fine. Yesterday I chanced some things in my network (installing google wifi on a fritzbx – but the NUC and my audio devices are hard wired by LAN).

Now it is difficult to get access to ROON on my PC, phone and Tablet. When I start ROON on my tablet, it takes up to 10 seconds in three steps (see below) before I can start. For me, as a ordinary person, it looks like ROON is searching the old core on the PC. It is no problem, to see ROCK in my browser (last picture).

Thanking you in anticipation

Sorry for my poor English

Vielleicht kann sogar jemand in Deutsch antworten – bei diffizilen Problemen/Lösungen wäre das sehr hilfreich.

Hi @Christoph_Eichenseer ----- Thank you for the report and sharing your feedback with us. The insight is appreciated!

Moving forward, besides the mentioned Fritzbox are there any other networking devices in your current setup, or is the Fritzbox the only one? If there indeed are other devices involved, please provide the make/model of the hardware being implemented and where they are located in your configuration.


Hi Eric,

thank you for your reply!
Here my language problems start :frowning:
Hope, this picture of my network-situation helps. The fritzbox also has a wifi funktion, but I switched it of, cause I use the google wifi.


What’s acting as your DHCP server? I’m assuming that you have now disabled it on your Fritz!box, leaving the DHCP server on the Google WiFi as the sole provider? If you have both working, then this could lead to trouble.

Hi Geoff,

would you recommend, to switch this (red square) off?

I am a little bit afraid to chance something, because I am not a network specialist.


Yes, that’s the one - but then you also need to make sure that your Google WiFi has its DHCP server switched on…

And after doing that, reboot your ROCK and your SoTM so that they pick up new IP addresses from the Google WiFi DHCP server. Then you should be in the state where all your hetwork devices are sitting in the same address range supplied from the Google Wifi unit.

I have to say that I am not familiar with the Google WiFi units. I am assuming that they have a DHCP server… I’ve taken a quick look at the online help, and frankly, it’s not very clear to me…

I’ve just had a quick look at the Google forum for the WiFi devices, and it appears as though the DHCP server will give out IP addresses in the range - and it’s not changeable. I’ll bet that your Fritz!Box is configured with its DHCP server having a default address range of - i.e. a completely different subnet address range… Since you can’t turn off the DHCP server in the Google device, you’ll have to turn off the one in the Fritz!Box.

Thank you very much.
Here in germany it is 9:00 pm and I will meet some friends this evening.
I will try tomorow.


Hi Eric, hi Geoff,

today I had a long, long telephone call wit the google wifi hotline (very friendly, very helpful).

To make a long short: ROCK an SOtm must be wired to the google wifi (and not to the fritzbox). So I connected ROCK via LAN and the SOtM via wifi (there is only one free LAN port in the google wifi box). And now everything runs like a charm.

Thank you very much for your help!

1 Like

Glad it’s up and running. Just one thing - if you can, the SOtM will probably perform better in Roon if it’s connected via wired ethernet, rather than WiFi. You could connect a simple unmanaged ethernet switch (5 port or 8 port) to the google wifi, and then connect ROCK and the SOtM to that…

Hi Geoff,
why do you recomend a LAN-connection of the SOtM? Soundwise or because of stability?

its just say that wifi is subjected to all sorts of radio interference and that a Lan based wired connection is a known quantity, known quality, and dedicated physical connection.

This topic was automatically closed after 6 hours. New replies are no longer allowed.