Account-Specific Inability to Connect to Core with Roon Remotes

Core Machine (Operating system/System info/Roon build number)

Desktop, laptop, or Nucleus+. Windows. It doesn’t matter what I use because I can replicate the problem, which only affects the account.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
AT&T Fiber Modem. Netgear Orbi Mesh Router. The cores are connected via ethernet. It is on the same network as my phones

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue

I am not able to connect using Roon remotes on either android or ios. It starts out looking for a core and doesn’t find one. I click to connect to another core, and it finds my core on the network. Clicking that core freezes the app then crashes it. Any attempt to re-open the app results in an immediate crash after that. It stops working completely. I can uninstall and reinstall, and this brings me back to looking for a core, once found, crashes again.

I assumed this was a problem with the apps but just for kicks, I logged in with another account and activated a free trial. Tried to connect with the apps, and it worked perfectly. So to clarify, the issue only occurs on my real Roon account and for some reason doesn’t occur on other accounts. Any idea what might be causing that and how to fix it?

Edit: I was able to login earlier with my real account and I connected to the Nucleus+. However, since then, I shut off all power in my house (for unrelated reasons) and powered back on. It is no longer able to connect to the same nucleus. So my guess is that it’s network related, but I am not very savvy in that area and I would appreciate help.

My music folder is on a NAS - could this be causing issues?

Can you log into your account on roonlabs.com with the troublesome account?

Yes, this is the account. I can also login on the core, or a remote that is on a pc. But not android phones or iphones.

Hi @Omie_Omie,

Welcome to the forum!
It sounds like you have two issues here:

  1. Being unable to login with your previous Roon account

  2. iOS and Android remotes crashing when you connect to any Core (Nucleus / Windows)

Next steps:

  1. I’m curious to see what your Core logs show for item #1, can you please reproduce the issue and then send me a set of your Roon logs from the machine you used as a Core? You can use these instructions to access logs. You were also having the login issue on Windows and not just the Nucleus, correct?

  2. Is there any change if you try to uninstall and reinstall the Roon app on these devices? Were both the Nucleus and Windows PC using the same (restored) database or was the issue occurring on a fresh database as well?

Hi Noris, thanks for the reply.

  1. I am not having issues logging in with any account, on any device. The account login itself works fine. On mobile apps, I don’t get a chance to login. The app sees my desktop core and my nucleus+, but if I click on either of those when they are connected to this account (which is the one I want to use permanently), the app crashes immediately and will not recover unless I reinstall (or delete data + cache). If connected to either core while the core is logged into a different account, it works, asks me to login, and it works fine. (only 1 core at a time works, which is by design.)

  2. Uninstalling on every device and reinstalling produced identical results. But turning off my modem/router produces different but related results. For example, I was initially able to login to the Nucleus core with this account via mobile app. Then when I shut my power off and back on (the internet equipment restarted), i was no longer able to do this with the nucleus.

I have no idea what is causing this issue, but it is somehow related to the nucleus. Is there some way to make all my devices completely forget any trace of Roon so I can reinstall cleanly? I feel like when I uninstall, the software is leaving enough data on the devices and the old data is interfering when I reinstall.

Or can someone from Roon just delete my other accounts so nothing could interfere with this account login?

Hi @Omie_Omie,

Can you reproduce the crash on one of your remote devices and let us know the time that the crash occurs? We’ll enable diagnostics on your account and take a look with our team at the specific crash that you’re seeing and it should give us a bit more insight into what’s going on here. Thanks!

Okay, I just reproduced it on my android at around 9:05 am PST. The app is frozen now because I clicked “connect” to my core.

Hello @Omie_Omie,

Thank you for letting us know that timestamp! We’ve tried to enable diagnostics mode for your Android device, but it appears to be failing to deliver logs, the Roon app is crashing before it’s able to upload the logs to our end.

You are able to reproduce this crash when the Windows PC is connecting as a Remote to the Nucleus Core as well, is that correct?

If so, can I please ask that you reproduce the issue, note the exact local time + date of the failure and send us a set of your Nucleus Core and Windows Roon logs by using these instructions?

Any questions, just let us know. Thank you and Happy Holidays!

Hi Noris,

No. I am not able to reproduce this crash using ANY system or platform except cell phone devices used as remotes. I have tried 4 different cell phones, 3 Android and 1 iOS – same exact issue causing the remote app to crash. Interestingly, a brand new Android tablet had no trouble connecting, and didn’t crash. Windows remotes do not crash or have any issues. And different windows devices can take over as the main Core – the other windows devices will connect to the new core as a remote, and the cell phone remotes will still crash.

Before I installed the Nucleus, these issues didn’t occur. I have fully reset the nucleus and even unplugged it. I will be returning it. But my account still has this issue.

Please also note, if it helps, that using a different login eliminates the issue. The issue only occurs while using this account.

1 Like

Hi @Omie_Omie,

Thank you for the additional details and Happy New Year!

Unfortunately, I am still not seeing any logs from your account being delivered to our end.

Getting a log set, even if only from the Core you used for the test can help. Can I please request that you reproduce the issue and send me a manual log set for review? Hopefully this will contain further clues.

Hi noris,

Other users with the same issue exactly have shared their logs and on those threads, you said you weren’t able to see the issue.

How about instead of all this troubleshooting, can you just move over my subscription to a different account? This issue only occurs with this account. I am happy to cancel it and transfer over to another account, which I have confirmed isn’t having these issues. Is this possible?

Hello @Omie_Omie,

Thank you for your patience here while we looked into this issue further.

Looking over your logs, it appears that the issue here is that Roon is crashing due to failing to get your year of birth as your profile is currently missing one.

Can I please ask that you navigate to your Roon profile and manually specify a birth year on your account? Once you have configured this the crashes should stop:

Hope this helps!