"Add to Library" ignored - Bug


Since the last Update (Roon 1.6, Build 401) I have consistently encountered a bug where upon returning to a previously added to library album, it’s not recognised as being inside the Library and thus no specific actions can be performed.

Briefly: Add Album to library - all ok. Album appears in library. Play track from that album, go from the Queue or Search to that album and it’s not recognised as being in the Library. Also, in the Now Playing screen, the Favourite Icon is missing for these albums. Seems that the bug affects Tidal albums only (I don’t have Qobuz to test).

The behaviour is illustrated in the screen recording below:

Roon core running on Mac Mini. Behaviour is the same from my Mac and iPad app. All are updated to the latest Roon 1.6 (Build 401).

Anyone else encountering this?

Thank you!

Hi @Stefan_Stefan,

Can you confirm where you originally played this album from?

Had you started playback of the album before adding it to your library?


Thanks for getting back. Indeed I now tested this behaviour and can confirm that it occurs when adding an album to the Library while it’s playing results in the above described situation.


Thanks for the info, @Stefan_Stefan!

In this case, this is expected behavior. The tracks in your queue, at the time they were added, are not from your library. When you add this album to your library, the queue does not switch to play the tracks from your library — they continue to play the tracks from outside of your library.

Moving forward, if you were to play this album again from your library, things would work as you are expecting.

Unfortunately they are not. Even if i go back to the album after adding it to the library, and adding something to the queue or from search - the behaviour repeats.

I’m positive this is something new, as it would have annoyed me quite a lot :)) maybe I’m not describing the issue properly or something else happens but there is a behaviour that was not present before.

Maybe it’s linked to the sync with Tidal - The album appears in my Tidal favourites, so Roon is adding it there. What I think might happen is that it does not updated it’s internal library immediately and this appears as not in library.

In any case, I can assure you there is something weird and new going on here. I just tried this with another album and again - it’s the same thing.

I should make it clear - it’s happening for any album - not just the one I captured in my video.

Also tried forcing a sync with Tidal from Services and restarting the core. The album does not register as being in the Library unless I access it specifically from the Roon Library > Albums.

Hi @Stefan_Stefan,

Can you confirm where you are adding this from? How are you navigating to the album for playback? Are you getting to it from within your library (i.e. from the Album browser) or are you navigating to it another way? When you start playback from the album is it showing as being in your library?

The one in my recording was added by searching.

Simplest way to reproduce this:

  • Left bar > TIDAL > Click on a new Album [Album opens, album view] > “Add to library”.
  • Leave album, go wherever… Tracks, Playlists, anything…
  • Go back to: Left bar > TIDAL > Click on a new Album [Album opens, album view] - Album does not register as being in the Library. Button “Add to library” is active again.

Album appears however in Left bar > (library) Albums. Click on that album and the button is “Focus on similar”

Hi @Stefan_Stefan,

This is also expected behavior, see Mike’s explanation here:

When you navigate to the TIDAL section of Roon, you’re looking specifically at TIDAL versions of these albums. Even when you have a TIDAL version of the album in your library, what you’re looking at in this section is not in your library.

While this may seem a little strange, this allows you to see the original version of the TIDAL album in full, regardless of whether or not you’ve made any edits to the version in your library, or if you only have some of the tracks in the version in your library.

If you navigate to the version that is in your library and start playback, things should be working as expected here, but if you’re seeing otherwise using different steps than listed above, please let us know!

Thanks for your patience with this.

I’m aware of what you’re describing, however, is the following expected behaviour?

  • Looking at the album I tested this yesterday with, it’s now always showing up properly. So some kind of sync must have happened in the mean time, as nothing changed.
  • The “American Love Song” Album I added today exhibits the behaviour described above.

What difference can there be?

Look at the example below starting from History:

If this behaviour were present before, I should have noticed - as this is my typical music discovery process - doing this daily.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.