Add to library increasingly slow

Roon Core Machine

MacBook Pro 2013 2,7 Ghz Intel Core i7
16 GB RAM 1600 Mhz DDR3
500 GB SSD

Networking Gear & Setup Details

WiFi (no problem)

Connected Audio Devices

HD 5 GB Western Digital
By USB to MacBookPro

Library Size

8.000 albums
160.000 tracks
80.000 files
4.000 CDs ripped
3.000 albums Qobuz
1.000 albums Tidal

Description of Issue

"Add to library" increasingly slow

The “add to library” function gets slower and slower, consuming more than 20 seconds to add an album, both in Qobuz and in Tidal.
The rest of the functions, playback, search, etc. have no delays and function normally.
When starting Roon, the add function is normal, but in each add / delete cycle the time is lengthened by 1 or 2 more seconds until it becomes unfeasible.
The writing icon in the library eventually lights up briefly two or three times with each addition.
Could the problem lie with the format of the hard drive (NTFS on Mac)? It is my only suspicion, but I am surprised that it has worked without this problem 1 month from its installation to about a week ago.
The recent environment is as follows:
The library is on an external HD, called “None”, connected by USB to a MacBook Pro. The files are accessible and play normally.
This disk is a backup of the main server (Innuos Statement) with Linux operating system, which formatted the disk with NTFS. I tested it with the MacBook Pro and when I saw that it accessed the files well, I considered it valid.
Could it be due to something other than NTFS?

Hello @Luis_Cacho,

Thanks for letting us know of this and sorry about the trouble. Could you please also share one more screenshot with us? That of your audio analysis.

What are your settings in Settings → Library → Background Analysis Speed (please, scroll to the bottom) and On-demand Analysis Speed?

Thanks for your attention. Does audio analysis also apply to streaming? I have upgraded to 814 and the problem persists.

A post was split to a new topic: Very slow adding to library

Hi @Luis_Cacho

Can you try changing the DNS your router is using: