'Add to Library', is not working

Hello,

I’ve experienced some difficulties with the ‘Add to Library’ function. Sometimes it works like it should, but most of the time really my favourite albums that I’d like to keep are not added to my Library. They are also not being displayed in my ‘Overview’.

Can someone help me on this please?

With kind regards,
Sjors

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

1 Like

I’ve moved you post to the support area.
Could you share screenshots of what you are doing to add an album to your library.

I’m getting the same issue intermittently so would be interested in the answer to this. Sometimes when I add an album to my library, I see the spinning disc and get the message that it is added, but then the addition fails and I have to repeat the process.

2 Likes

Hello, thanks. Actually I’m just selecting the + beside an album I’d like to add.

Yes that’s exactly the issue I experience

And how long do you wait before you move to another page?
Sometimes I have had this happen when I click the plus and move straight to another page, it fails to add.
When you click the plus you will see a blue dot on the top left three horizontal bars , thats a sign its adding, I now wait until the blue dot has gone then I know its added.

But this could well be a glitch that should not happen ever so lets see what official Roon response is.

1 Like

I get that too sometimes. Restart your core and it’ll work.

No idea why it happens.

I have the same problem. Both are recent Qobuz albums that became playable since Friday 14th. One of them can now be added to my Roon library (since 3 pm; not at 2 pm). The other one still can’t. Try: artist “Olivia Vermeulen” album title “Hello Darkness”

That is likely a different issue.
One that involves Qobuz latest releases synching with Roon which can sometimes take a couple of days.
You can try going into settings: services: Qobuz and force sync.
But it’s more likely just a waiting game.

Oh and welcome to the Room community!

Restarting my Roon core did help. I can now add the other album

1 Like

I’ve stayed on the page and not moved away for up to 5 minutes. If I press the spinning disc again it tells me again the album is added to my library but the disc continues to spin and it is not added, after leaving the page and checking. I don’t wish to restart my core each time this happens, I’d prefer to move on and not add the album, possibly try later.

1 Like

I can confirm this bug on my side. Sometimes it works, sometimes not.

Hmmm…
Do we see this just on Qobuz or both Qobuz and Tidal?

Yes I’m playing my music with Tidal not Qobuz.

I can wait for hours I think… It says ‘Added to Library’ but the wheel keeps on spinning and unfortunately in the end the album is not added to Library

Have you tried to restart the core?

Yes I have just done that. I see now that the added albums ARE in my Library, that’s good. But still, they are NOT displayed in the ‘Overview’ screen, unfortunately…

Yes I did. But the album I choose + for now appears NOT in my Overview, nor in my Library. It’s become really a strange thing to me now… The wheel keeps on spinning, as well.

Hi Sjors,

In your post 2 days ago you said they now appeared in your library. In your post now you’re saying they’re not? Which album is this stubborn one?

Yes now it doesn’t seem to function I guess. I’ve only tried one album don’t know exactly which one it was sorry