'Add to Library', is not working

Hi Sjors,

In your post 2 days ago you said they now appeared in your library. In your post now you’re saying they’re not? Which album is this stubborn one?

Yes now it doesn’t seem to function I guess. I’ve only tried one album don’t know exactly which one it was sorry

Add to Library is still not working today. First two albums I tried, Septicflesh Esoptron and Septicflesh Ophidian Wheel, failed the same way as before… I think it a bit sad to see it’s been dysfunctional, for days now.

Anyone here got something good to say on this and make my day please ? :slightly_smiling_face:

I’ve tried adding these two and had no issues. However, now I can’t remove them :joy: Something’s not right.

EDIT: Had to reboot ROCK and now they’re gone.

Hi @Sjors_Ehv,

We’re sorry to hear that you’ve been having some difficulty successfully adding albums to your Roon library. We’d like to help you figure this out.

Please do the following:

  1. Recreate the issue by trying to add a couple albums to your library.
  2. If they fail to load please note the album/albums you attempted to add and your local time it this thread.
  3. Then please use the directions found here and send over a set of logs to our File Uploader?

We’ll be watching for your log files and take a closer look. Thanks!

2 posts were split to a new topic: Tidal albums are added to my Roon Library but then stop playing and display ‘not available’

Same problem here, it‘s hit and miss. A reboot of the core usually fixes it, but this shouldn’t be a long term solution.

2 Likes

Thankyou jamie, I’ll soon try to do that…

Still happening sporadically for me. I’ve just added a bunch of R.E.M. albums to my library, all from Qobuz. They all added except ‘Reckoning’ which is still spinning in the background as I type this…

Restart your core and it’ll work. Whilst it’s not ideal for when it happens, we need to wait for support to figure out why it happens :slight_smile:

Thanks Raz, although as I’m adding to my library every day and sometimes multiple times (as with adding all R.E.M. albums today), restarting my core each time is not good :weary:

UPDATE: This may be useful for others. I’ve since used the ‘back arrow’ < to exit that album screen. The album was not displayed in My Library section of the R.E.M. page I returned to. I used ‘back arrow’ < again, going back to what I was doing before looking up R.E.M. I then used ‘forward arrow’ > to re display the R.E.M. page and as if by magic, the album is in fact added. No core reset required.

1 Like

Fully agree. It happens to me, although quite rare.

Hi jamie, it’s really bad I think I could note for you really every single album that I’m encountering now they all wouldn’t seem to Add to Library…
I’d wish for a proper long-term solution on this one

Sjors_Ehv, see my earlier UPDATE. Does that work for you?
To me, this seems like information is being lost between the core (in my case a NUC) and the Roon remote device (in my case an iPad)

Hello Ross_ByTheSea, I’ve tried it but it doesn’t work here. Will you be happy with this kind of solution ?

Hello jamie, I’ve tried to add four new mainstream albums to my library. FKA Twigs CAPRISONGS, The Weeknd Dawn FM, Snoop Dogg Algorithm, Adele 30. The first three were added successfully, however Adele 30 failed the same way as before.
The new update I’ve installed. My time zone is Central European Standard Time (Amsterdam). Tried to find the ROON Log files on my MacBook like you said. Unfortunately Finder doesn’t give me one single result for this search.

Hello Sjors, no I was only suggesting it may be a temporary workaround, but if it doesn’t work every time (as it did for me) then we are no further forward. Let’s await Roon Support.

1 Like

Hello again @Sjors_Ehv

We’re happy to help you with this. The logs I requested are the best way forward. I’m hoping that you have a chance to send those our way soon.

Also, can you please edit your initial post above and use the template I added to provide your setup details? This will help us troubleshoot your issue.

Hello jamie, Thank you for the help.
Okay, let me find some time soon and I will try to do this.

1 Like

Thanks! We’ll be back in touch once we’ve had a chance to take a closer look at your logs.