Add to library still not working most of the time

Sorry to be the bringer of bad news again, but Add To Library from TIDAL still doesn’t work more often than it works. I’m opening a new Topic as @mike requested in the old thread - sorry guys.

Sometimes, although it doesn’t add, if I restart Roon server the album is there. But mostly it isn’t.

Usual setup for me - brand new Mac Mini running OS X El Capitan 10.11.2. Roon Server 1.1 (build 99) stable (64-bit).

For example: Try adding no 2 in TIDAL’s album top 20 now - A Head Full of Dreams by Coldplay. No spinning wheels. Add To Library highlights for the duration of the mouse click … then nothing. No feedback. No success/fail, just nothing. Go back a level and back in - nothing.

One suggestion: At least give us a status line somewhere that says why this is failing - even if the only reason is “TIDAL timed out”. At least we’d know something was being attempted.

Note: This has never worked reliably.

Thanks - Paul

+1 Very flaky. Sometimes works.

Having multiple problems with the “+ Add To Library” function.

Problem One
Sometimes it works. Other times there is no response to clicking the button, and no spinner either.

I’ve noticed that if I click on the Add to Library button, and it does not work (no response, no spinner), then when I reboot my RoonServer, the album is added. I’ve done this three times. Result is always the same. Here’s pics…

Clicked Add to Library and nothing happens. No spinner either.

Rebooting RoonServer…

Screen I see when the RoonServer has restarted. It’s in the library now.

Problem two
Sometimes albums in my library do not show as such.

Here’s a Tidal album I got to by browsing albums. Clearly in my Library.

Next I can go to a local playlist that has that album. If I click the album, I get this… not in my library.

It’s worth noting however, that sometimes I can click that same album in the same playlist, and get this.

My Gear
Picture below should detail my setup.

Thanks for the help. :relaxed:

Just a networking suggestion. I would move both the RoonServer and NAS on the same switch as the rest of the chain and only have the iPad go through the router for the remote.

Daniel - unless you are suggesting that a network issue is at the root of this problem, this appears to be an OT subject that I’d be happy to discuss in another thread. But only because it’s been brought up here - and because I heartily disagree and don’t want people to be misled by the advice - I’ll reply…

There is nothing wrong with this network setup for use with Roon. Could things be done to optimize it? Sure. Does anything need to be done for it to work better for Roon? Absolutely not. It is sufficient for purpose.

A ping from the RoonServer to the SonicOrbiter SE (or the Aries Mini) is consistently lower that 60ms, typically more like 30ms or less. If Roon needs better than that to operate well, then that’s a nasty little secret that they’ve been sitting on, and I seriously doubt that’s the case. Frankly

And a little update to that… that slow response appears to be with the SonicOrbiter SE. If the RoonServer pings a PC hanging off the same switch, the reply is consistently <1ms. It really does not get better than that. Which is to say… the network is fine.

This is done and coming for our next release.

We’re still working on identifying the exact conditions under which this feature gets slow, and while we’ve made some changes to improve performance in some cases here, so far we haven’t been able to reproduce consistent failures. We’re working on it, guys.

If you’re still having issues, it would be helpful to know your Tidal region, a link to the album you were trying to add on Tidal’s site, the exact steps you were taking in Roon to add the album, and whether the issue persists after you reboot your Roon Core.

Thanks all!

As before, it’s not happening every time, but it does continue for some albums. Heres an example…

  1. Region - huh? Can’t find that anywhere in Roon or Tidal. But I am in the USA.
  2. Link to album I was trying to add, on Tidal’s site.
  3. Exact steps:
  • From iPad Roon app’s menu button, selected “Playlists”.
  • In the playlist browsing screen, selected a playlist that had been previously created on Tidal, using the Tidal website.
  • in the playlist screen, clicked on a album name.
  • In the album screen clicked “+ Add To Library”, with no result. No spinner.
  1. Rebooting my RoonServer core caused the album screen to redisplay, but with the album now included in my library.

The example I linked to above is particularly interesting because it is an album that had previously been in my library. But now - a few days later - its album screen showed me the “+ Add To Library” button. As if it wasn’t anymore.

Here is a link to an album that was never in my library, was not added when I clicked the “+ Add To Library” button, but was added after my RoonServer rebooted.

I have a similar problem.
Many times (not overtime, though, seems to be random) if I try to add tidal albums through roon, it seems to time out:
“Adding the album takes longer than usual, roon will keep trying in the background” (or something along those lines).

Albums that seems to be added successfully show the “add to library”-button if I search for them after having added them to library via roon.

If I add these albums through tidal by starring them, they show up immediately in the overview-screen and don’t show the “add to library”-button.

This behavior is consistent across two machines, one running windows 10, one running mac os.

If it helps, I’ve got a few more clues to this problem. Nothing has changed for me since the last post except that I added a few more albums to the Tidal playlist, using the Tidal website. Then going into the “Services” section of “Setup” to synch Roon with Tidal.

In those instances where tapping the “+Add to Library” button resulted in nothing, rather than reboot my RoonServer’s PC, instead I just closed the cover on my iPad. This is the Apple add-on cover that puts the iPad into some kind of sleep mode when you close it. Opening the cover back up, Roon is a blank screen for a few seconds. Then it pops up the screen I left on (as it should), but to my surprise, the album was now showing in my library! I did this several times, worked every time. Much easier than rebooting my RoonServer, but may provide a clue to resolution.

Also should note, the when some albums were selected in the iPad Roon app using the synched Tidal playlist - as described previously - sometimes albums previously added, no longer appear to be, based on the presence of the “+Add to Library” button. Closing the cover and reopening it worked to resolve that too.

Got another clue…

Added another 15-20 albums from the Tidal playlist to my library today. I found the when I clicked on the album name in the playlist, thus bringing me to the album screen, that if I waited 30 seconds before clicking “+Add to Library”, it added the album to my library every time. Not a single glitch.

I’m having the same problem on build 101 (64bit Mac), many but not all albums.

An example which refuses to stick is Lucinda Williams, West. I’ve tried waiting 30 seconds but that didn’t seem to work.