"Add Watch folder" button issue

I have the same issue In the storage menu, the button to add a watched folder does not even work. I bought a new computer and everything else works, except half my music is on drive e connected by USB to a USB hub, as before. Help please.

Bill - [personal information removed by support]

Hi @William_Endelman ---- Thank you for the report and sharing this observation you’ve made with us, the insight is appreciated.

Moving forward, to give us a better sense of what equipment you are implementing may I very kindly ask you to pease provide the details of your setup using this link as a guide. Please also include a screenshot of your “storage” tab.

Furthermore, I would like to also have a better sense of what the failure you are experiencing “looks like”. Can you please verify if…

  • You are receiving any error messages in the application when the issue occurs.

  • My sense is that you are unable to add the mentioned external drive in the application (please do correct me if I have this wrong). Are you not able to add ANY watch folders at all , OR is it just when you are trying to access the external drive?

  • My assumption is that there are no issues accessing the drive from the OS level, but please confirm this thought.


Thank you for the prompt response. I do not get error messages. The drive is recognized in windows explorer. The grey add button will not let me add ANY watch locations - on the computer drive or external drive.

I also just noted could not edit the schedule backup fields. It seems an interface problem with the settings screen.

I m rubbing new Dell XPS 15 laptop with Roon on it. I have a 500 GB external laptop drive in a case connected by USB to a “Pluggable 3.0” brand USB HUB, which is concocted to one of the computer USB jacks, which works fine.

Thanks, Bill [Personal information removed by support]

it dies not look like the print screen worked… I’ll try again.

Thanks for the screenshot @William_Endelman, appreciated! Would kindly please provide me with the exact specs of the new device hosting your Roon core or a link to where I can review the specs of the device?


Here is a link. it is similar to the computer on the left except"

Windos 10 professional
1TB hard drive

Great, thanks @William_Endelman!

I have a similar laptop at my desk and as quick test I mounted an external hard drive to the unit with about 100 albums on it to confirm if I had any issues adding the external drive as a watch folder. As I was expecting, I did not. As this is fairly common configuration amongst our user base we need to determine why your setup is responding differently.

With the above in mind may I very kindly ask you to please provide…

  • The make and model of the drive you are trying to use.

  • Please confirm how the drive was formatted, and what it was formatted to.

  • Please walk me through the steps your are taking (procedurally speaking) when you try to add this drive in the application. Having some screenshots of these steps would be appreciated, if possible :wink:


It was the laptop drive removed from my ASUS computer that I put in a 3.0 USB case. Brand unknown. It was FAT64 formatted. I tried plugging it directly into the laptop - window explorer reads files, but I can;t add the drive. I tried a second external drive I have, and no success either. Yet I can copy files between all drives all day long.

Is there way for me to refresh the Roon install?


I don’t think that’s going to help.

You’re able to add any folders right? Like, say, the Downloads folder on your local hard drive, as opposed to the external hard drive? None of these work?

Are both drives formatted FAT64?

AH Ha! I found the issue. It is a separate screen issue that I hadn’t mentioned. The top of the screen cuts off unless I use F11 for full screen, which then cuts off the close app symbols. What I just realized is that I need ti click BELOW the add folder bottom,. not on it. There is a display issue! which seems to offset the controls. Any help on this.

Thanks, Bill