Added Nucleus+, now my phone cannot find it

Hi – I just purchased a Nucleus+ and have a couple of questions.

(1) It comes with a free year of Roon, but I have a lifetime. Is there a way to get a rebate? I was told I could get $59 and there would be instructions in the box. Wrong. How do I get this?

(2) Installed the Nuc+. I successfully migrated my library. But now my phone, which I use as a remote, cannot find my Roon Core. My phone is an LG G8s ThinQ running android. I have tried uninstalling Roon from the phone and reinstalling it, but this doesn’t help.

Details of my system: The Nuc+ is ethernet connected to my router. I also have a QNAP NAS ethernet connected to the same router. I have a BluSound Node2 as an endpoint device that connects to the router by wifi, it is wired to my amp.

I also have a MacBook attached as a remote (it was my old core); that works fine now as a remote. There is no problem at all there. It is just the phone that has stopped working. However, the BluOs app on my phone for the endpoint is Roon ready and still has limited functionality. I can see what is playing on Roon (including art) and I can pause/start/advance/go back a track. But I cannot chose music.

Using the computer, which works fine for picking and playing music, I can see no way to add a device as a remote. Please tell me how to do this IN DETAIL. I found a site that says “click on Settings and add device.” But that is totally insufficient. Explain in detail like: Settings>Setup> ? >? etc. I have pretty much gone through everything in settings and cannot find a way to do this.

(3) Since changing to the Nuc+ and using my computer as a the remote, a new red warning has appeared in the upper right (exclamation point in a triangle). It says “Metadata Improver: Halted. Roon needs a new update.” OK. How do I stimulate manually a new update? I have it setup to auto update, so why isn’t the darn Nuc+ autoupdating?

I am frustrated. I dropped $2600 and I have a worse set up then before… Please help/

To try to clear (3), and presuming Nucleus+ has a version of ROCK installed, go to the web gui and reboot the core.
I get this issue on occasion running ROCK and a reboot of the core, or even just a restart of the server software, always clears the error.


Thanks, Michael. In regards to (3), I do not know if the Nucleus+ comes with a version of ROCK pre-installed or if it installed automatically when I connected to my router and powered up.

Can you send me the specific address for the web guide page on rebooting the core? I have looked around and haven’t located it; doubtless I am doing the wrong thing in looking in the wrong place.

I have a QNAP nas. What do you mean by “reboot the server software”? I guess this is a rudimentary question, but I really don’t know how to address that.

Sorry for being dense. This is a new world for me. Thank you for your patience.

Ok - with the proviso that the Nucleus runs ROCK, go to ‘settings’, then ‘setup’, then ‘configure’, then select the IP address shown in your setup - steps marked here as 1, 2 & 3:-

…then either reboot the server or restart the server software, marked here:-


Nucleus runs a nucleus version of Roon OS, while the GUI looks similar and the roon part is the similar it has other functions like C4’s automation interfaces.

The access to the web GUI posted will be similar

1 Like

Sorry for the trouble here, @Geoffrey_Braswell!

I’ve tagged our @accounts team about your first question. They’ll be in contact with you soon.

For your Android remote — Can you try giving it a reboot and let us know if it helps? When you’re searching for the Core what do you see? Can you share a screenshot?

Just to confirm, is the MacBook also connected via WiFi?

For the metadata improver message, let’s definitely try a reboot from the Nucleus Web Administration Interface.

Hey @Geoffrey_Braswell,

This is Rebeka with accounts. Thanks a whole lot for reaching out and, @dylan, for tagging accounts. I’d love to help clarify.

The 1 year of Roon that comes with a Nucleus+ purchase (by the way, congrats on getting one!) cannot be credited towards the lifetime subscription or be redeemed for anything else than 365 days of Roon.

Instead of leaving it unused, you could either redeem it on a new account (maybe gift it to someone?) or, if you’re interested in having a second subscription on your account, I’d be happy to get that started for you. That way, if you want to set up another Core you could use both Cores at the same time.



Thank you, Michael, Thank you Dylan! Rebooting solved the problem with the Android phone that Michael mention. But now there is a new problem: about 1/3 of my albums won’t play. I get an orange message towards the bottom of the screen that says:
“Play was interrupted because a track failed to load,” which is quickly replaced by a second message saying “Too many failures. Stopping Playback.”

What is causing this? I read the page you directed me to, reinstalled the OS, rebooted again, and precisely the same albums cannot play. They all worked perfectly when I used my Mac as the core.

And yes, the Mac is connected by wifi. The only physical cabled connections I have are router to the NAS and router to the Nuc+. If it matters (and it shouldn’t because I ordered the Nuc+), I have about 150k files.

Thanks, Michael. That solved the android phone problem!

1 Like

Hi @Geoffrey_Braswell,

Thanks for letting us know that rebooting resolved the Android issue!

Looks like you have another thread open regarding this issue, so let’s continue the discussion there:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.