Adding albums - bug (Roon 1.8/764/778/783)

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

iPad Pro 12.9 (2018)

Description Of Issue

Qobuz Album does not “add” (additional version added to local version) after selecting the ‘plus’ icon under Artist. Icon just spins (hangs) - see screenshot. The album is shown as added after quitting the app and relaunching.

Edit: the same behaviour is observed on my Win 10 64 bit machine.


Hi @Daren_Peacock

Are you seeing this will all Qobuz albums, or just certain ones?

Was this working for you before? Were there any changes around the time this started happening?

@dylan I’ve just tried adding another Qobuz album (via versions) and am getting the same behaviour. However, instead of exiting Roon I navigated to the home screen and noticed the album has been added under ‘Recent Activity’. Clicking the album from here shows the added album without a spinning icon.

However, I’ve tried adding an album from the ‘Qobuz’ new releases screen (AC/DC - Power Up) and I get the spinning icon (despite the “added to library” banner appearing) but this time it has not been added (even after exiting and restarting Roon).

This problem has started in Roon 1.8.

Update: I’ve just tried to add another album from the Qobuz screen (Bruce Springsteen - Letter to You) and it was added immediately. I’ve tried another and that was added as well. It therefore seems to be album specific.

Two issues. First, under the specific Album view, there are times when you have a version in your library but it does not show up under Library Versions. But if you look closely at the versions listed as Qobuz Versions, the ones that are actually in your library but not listed under Library Versions will not have a + sign next to them. With some albums, you can try all day and you won’t get every version to show up under Library versions.
Can we talk about the whole Overview/Discography thing? - Roon Software - Roon Labs Community

The related issue is that if you try to add an album to your library that is already in your library using the “+ in circle” icon next to the album in album view, it will spin forever.
Can’t add to library or heart after + (spins forever) - Support - Roon Labs Community


Thanks for this. I now realise that the AC/DC album I’m trying to add is already in my library (as Qobuz). Perhaps related is the issue I’ve been getting where I already have a local (lower quality) version. It does get added but there’s no confirmation in the Album View as the icon keeps spinning.

Also it stops you giving individual hearts to the tracks in the album until you find a different route into the album ie via the home page then through recently played.

@dylan this a definitely a bug. Having played around with this, it is really a UI issue that happens where the album is already in the library (in whatever format). The album does get added (subject to below) but the icon continues to spin on the album page. If you click the band name you will see the album BUT ONLY IF you allow the “added to library” banner to disappear when in the album view. If too hasty, the album doesn’t get added.

Still an issue in Build 778.

@dylan Is there any news on this?

@dylan on rare occasions Roon will not add a Qobuz album where a local version is present.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.