Adding folder of new music to Storage

Roon Core Machine

Roon Nucleus (Core), Windows 10 PC

Networking Gear & Setup Details

EE 4GEE router, on Ethernet

Connected Audio Devices

LINN Majik Network Audio Player, MELCO N1 EX NAS, CHORD Qutest DAC

Number of Tracks in Library

c. 2300 Albums

Description of Issue

My MELCO NAS has just been returned upgraded to the EX version and in order to use the ROON ready option I am on Twonky server instead of MinimServer2 and have exited the UPnP option under USB DAC to ROON ready option. I see on File Explorer (PC) the directory Network\N-0708 within which my music is visible but I cannot get ROON to add the new network share \N-0708\share and each time it says "Could not connect to share: Unauthorised. Any help to resolve this please? Many thanks, Brian

Sorry, I did have two slashes before N-0708.

The password you did provide does not match (to the username you provided) or the username you provided is unknown to the Melco. Please provide a username that is allowed to access the storage and a password that matches the username (is needed to authenticate the user). If you need help to set this up on your Melco or retrieve the current configuration of your Melco, I suggest you read the manual or contact Melco support: Support – Melco Audio.

In MarkUp (the language that is really being used), a backslash is also an escape character. Use three next time and you’ll see two.

Hey @Brian_Schrire,

I wanted to check in on this thread and see if @BlackJack or @BrianW’s suggestions helped you get your storage settings sorted out?

I’ll be monitoring this thread for your reply :+1:

Hello Benjamin and thanks to you and @BlackJack for getting back to me. Unfortunately the problem remains and I’ve run out of permutations to try and resolve it. Melco has a standard User name and Password which I had used and had been accepted. I have been in contact with Melco support who have tried their best to help - for instance with the EX upgrade of the N1, they say to use \internal rather than \share when setting up a Network Share. In File Explorer (my W10 PC) my music path is Network/N-0708/Internal. I have tried all combinations of \N-0708\Internal; \N-0708\share, etc. to no avail - all of which result in “Could not connect to share: Unauthorized”. A puzzle is at one time I used to be able to see my file structure in Settings/Storage after clicking + Add Folder. Now I simply get a blank page under Choose Music Folder except for the option to +Add network share which results in what is outlined above. Why I can’t see any file structure so I’m able to actually choose a storage folder, I don’t know. In addition I have tried all the ways I know to ensure the PC is sharing with my repaired and updated EX version of the NI but I can’t be certain it is actually doing so. All permissions are Turned On in Network Sharing but I don’t get a sharing tab in right clicking Properties on the folder Internal under N-0708. If I click on the Security tab, it says I have permissions for Everyone (under Group or user names) but as soon as I tick all the Allow boxes and click Apply it comes up with, “An error occurred while applying security information to \N-0708\Internal, Failed to enumerate objects in the container. Access is denied”. I start getting uncomfortable in this area but can’t discount that sharing issues may be part of the problem. Any help gratefully received. Thanks, Brian.

Please share a screenshot of Roon’s Settings|Storage page.

When and where? Can you access the Melco device from your PC, adding and deleting content?

Note: The Roon Nucleus supports SMB v2. If your Melco for example accepts only connections with SMB v3 and higher, then you’re out of luck.

Then I would suggest you try: smb://N-0708.local/Internal

This is in any instance the response from the server hosting the share you try to connect to. It means that Roon can contact the server successfully, but for some reason the access to the share is not granted (Unauthorized) by the server (your Melco device). Possible reasons I can think of: Roon is already connected to the share and a second connection is not allowed, a share with the name provided doesn’t exist, no or wrong access credentials (username/password) were provided.

It seems unlikely to me that the Melco device who is most-likely running Linux of some sorts and a simple share will accept/support Windows remote administration commands. So to me this looks like expected behavior.

1 Like

Thanks @BlackJack. To answer a few of the questions for now:
The Melco User Name and Password was asked for on connecting with the MELCO [nobody & nobody] and yes I can access the device from my PC and add or delete content.
Also sadly, the smb. string you suggested resulted this time in “Could not connect to share: Host not found”
Screen shots of the ROON settings/storage pages attached. On clicking browse I am always just returned to the empty second page so browse is not allowing me to see a file structure.
I will check with Alan at Melco about the smb version used.

If you go to that share in your Windows file explorer and then click once in the address bar, a string of the format \\hostname\sharename should be displayed that you should be able to use as is in Roon.

Thanks - am away from my setup for a few days but will try this when back.

No luck that way either sadly, @BlackJack, ROON just won’t accept any combination of the Windows file explorer string. At whit’s end here! Also is it normal not to be able to see ones file structure in the Choose music storage folder page. If one could see the actual file structure it would surely be easy to simply point to the location of the share wanted? Thanks anyway for the suggestions. Brian

Can you post a screenshot of the Add network share screen so that we can see what you have entered into the fields? The Workgroup field should be blank, but the other fields are required. Thanks.

Many thanks Geoff - Eureka it works!! I had got so used to trialling various network share combinations without making sure all fields were filled in each time. Problem solved!

Please note that you try to setup storage on your Roon Core, a Nucleus+ as per your original post. I don’t know how much of the local file structure a user might see there, but local is local anyway – that does under no circumstances include non-local/remote shares. As soon as a user is able to successfully establish a connection to a remote share, its contents become browsable.

Note: The Windows network browser is not a file browser, it is a (mostly) mDNS-SD based browser for available/supported (by Windows) announced services on the network. Choosing an announced file (share) service from there might lead you to that service opened in a file browser seamlessly, provided you have (Windows login credentials) or can provide access credentials that allow accessing the share.

Thanks @BlackJack - a suggestion from Geoff Coupe finally put me on the right track so problem solved. Your advice is much appreciated. Brian

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.