Adding music directory directly into Qnap roon server? [Solved]

“Roon Server is running on your NAS now, and your music files are probably living on your NAS too. Instead of using a network protocol like SMB or AFP, the best solution is to have Roon Server directly speak to the files already living on your NAS. This has the benefit of being faster and automatically picking up changes changes to your library.”

From the above statement I take it to enter the directory of the music folder on the Qnap into the actual roon server installed on the Qnap. How do you access the room server to tell it where the music folder is?

The QNAP has symbolic links to every shared folder in the directory “/share”.

Here is an excerpt from the QNAP package instructions:

If your path on the NAS is


then you will want:


But where do i enter this. In the installed server on the NAS? If so how?

Once you have a server installed you need to configure it from a client installed on another machine. So install Roon on a Mac or PC, or download the iOS or Androiod app on a phone; and then connect into the Server

Ok I will have another look at the client. When I installed the client on OSX it asked where the music folder was and needed the full smb:// structure to find the folder. Are you saying once the client is loaded you can then change settings direct on the Qnap server app?

This question I suspect is more Qnap related.
Ive installed an SSD as a single drive internally for the roon database.
When asked to make a new volume I do and also name the volume RoonServer but the server doesn’t find the drive.
I then need to make a shared folder with the name RoonServer for the server to find it.
Ive seen the example of formatting the external drive and then naming the drive but I think when installed internally the same naming conventions don’t work that way.

The volume name/label is just relevant for USB connected drives, If you inserted a ssd internally, you just need to create the “RoonServer” share on that new volume…

Thanks Christopher, Nice to know thats as should be.

Ive exported the library and now want to add the exported directory to roon. Ive tried the following, None have worked.

What am I missing?
Roon Directory

This should be a local folder. Have you clicked the “Add local folder” button that can be seen in your screenshot?

You won’t need user and password for a local folder.
Your first path should be correct “/share/ROON”.

Thanks Christopher, Thats where i was going wrong.