Adding Music stuck on Linux [Solved]

I have the same issue with adding tracks to library. The folder with files is scanned successfully, but the files are not added to the library. Rebooting the core changes the numbers of added and identified tracks but the process is not moving.

My system:

  1. ROON Core 1.2 running on Lubuntu 16.10 VM under QNAP Virtualization Station
  2. The music files are (mostly ALAC) stored on the same NAS
  3. ROON Bridge is running on a dedicated Win2012 mashine

The process is stuck on “Adding Music to library”:

Please help!


Hey @Go_Ga – you’re on Server 2012 right? Can you try installing the codecs linked here?

I’m guessing that will fix that here, but let me know if not.


Hi @mike,

My ROON Core is now running on Linux (Lubuntu) and I already installed ffmpeg, libav-tools. Do I really need to install codecs on my Win2012 where only ROON Bridge is running? Some of my files are DSD (.dsf). Could this cause my trouble?

Hey @Go_Ga – sorry I missed that when you switched your OS :wink:

I just sent you instructions for getting us some logs over PM. Take a look and we’ll go from there once we have the logs.


Hi Mike,

same problem with me since I moved the library to Roon Server for Linux. The wheel ‘Adding music to library’ is running for the last 24 hours now. I stopped Tidal and restarted Roon Server but the wheel keep on turning. Any ideas how to solve the issue?

Update: Still 12 hour later wheel is turning unchanged

Hi @Peter_Muller ----- Thank you for your feedback and I apologize for the inconvenience. While I try to narrow down what could be going on here, I wanted to ask you very quickly if rebooting your “core” machine has yielded any different results, in regard to the issue(s) being highlighted above. Your input is greatly valued, thanks!

  • Eric

Hi Eric,

Yes I did reboot the ‘core’ machine and it but today it has stopped by his own, so it seems that the problem has solved by itself. Many thanks nevertheless for the support.

Best Peter

This topic was automatically closed after 24 hours. New replies are no longer allowed.