Adding music to library stuck

Core Machine (Operating system/System info/Roon build number)
Roon Core running on Intel i5 Nuc Roon 1.8. additional 2TB SSD drive just for Music

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Sotm Sms 200 to Chord DAC

Description Of Issue

Adding music to the library seems to be stuck at 2829 tracks, 2829 added,2758 identified. It’s been at the same number for more than 12 hours now.
I’ve renamed the Roon database, Restarted my Roon Core. Same issue as before.

Have a look in Settings - Library - Skipped files and see if there in there. If they are it should give a reason why.

Hi, thanks for the suggestion. I’ve now removed the files that we’re unable to be read. How now do I restart the scan?

Go to Settings - Storage - Click on the 3 dots to the right and select “Force Rescan” on each of your storage locations.

It’s also worth noting that after removing any music from the library it’s best to select Settings - Library - Library Maintenance - Clean up Library - Tick the Radio button - Press - Clean up Library. This only cleans the Library and does not remove files from your storage location.

Thank you very much.

Can you explain what Background Audio analysis means? It’s currently analyzing tracks.

The Roon Knowledge Base is a good way of finding a lot of the information you require. This link will give you the information on Background Audio Analysis: -

Hope this helps.

Scotav, thank you so much for all your help. I’ve got it working now.

1 Like

No problem David, glad you got things up and running.

Hey @David_Kci,

A belated welcome to the Roon community :wave: (I’m sorry it’s 12 days late…)

I’m really glad that you engaged on our community and with other Roon subscribers to discover more about how Roon analyzes your music and how to finalize it.

Thank you @Scotav vid_Mbanugo for helping every step of the way :pray:

@David_Kci, enjoy the music :musical_note: