Adding music to library - stuck

Roon Core Machine

Taiko Extreme
Windows 10
Build 1169

Networking Gear & Setup Details


Connected Audio Devices

Chord Dave + M Scaler using USB

Number of Tracks in Library


Description of Issue

I’ve migrated from QNAP NAS to Taiko Extreme my whole library. After migration, I’ve restored Roon from the QNAP backup and updated the paths. All loaded fine and seemed to be working with no issue.
After a Taiko restart I’ve started to experience the issues.
The networking is exactly the same as I had for QNAP, but on Taiko I’m experiencing issue with ‘Adding music to library’ which gets stuck and does not advance.

I had a look on the forums where it was suggested that most likely it’s networking issue. Restarting the router and switches did not help. Replacing the lan cable did not help either. Changing DNS server to google also.
The logs don’t show timeouts, but I do see ‘critical’ errors related to paths.

[storage] [directory] Unhandled storage exception: System.ArgumentException: Illegal characters in path.

Unfortunately the logs don’t specify which path is problematic and with size of my library it’s a bit difficult to find them. Also not sure if this is causing really the issue with the stuck ‘Adding music to library’.

One very interesting point: Restarting the roon service makes the ‘Adding musing to library’ advance and it gets stuck just a bit later. So I’ve been restarting roon in hope to get passed the analysis after each freeze, but it’s quite a never ending story.

Could you please help me with this?


Please post a screenshot of your storage path settings.
Please provide details of your network setup and connections.

Here are some of the paths. I got them disabled for now to avoid the never ending scanning.

ISP router - Netgear R8000 router - Zyxel GS1920 (managed switch) - Paul Pang Quad Switch - Taiko Extreme

For testing I tried with this setup as well, but with the exactly same results:
ISP router - Netgear R8000 router - Taiko Extreme

Is there a debug mode which would show in the logs the paths on which scanning fails?

I did a full restart of all my network components including the ISP router.
Now it works and actually I don’t even see the corrupted path issues mentioned in the logs.
Do you want to check something or we close this case?


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.