Admin Login Fail (SAMBA)

I am running Roon Server on a QNAP NAS and accessing it from an iMac running High Sierra version 10.13.2. Both machines are connected via ethernet to an Airport Extreme router. Since updating Roon on both machines to version 1.4 (build 294) the NAS has been reporting “admin Login Fail (SAMBA)” incessantly (not an issue before 1.4). The reports start when I open Roon on the iMac and stop when I close the app. If I ignore them, Roon seems to run fine so this is only an irritant at this point. Nonetheless, any suggestions about what is causing the problem or how to make it disappear would be appreciated.

Is this a Roon issue ?
Can you access the Qnap by it’s ip address ?
Did you assign fixed ip addresses in the DHCP server in your Airport ?
What type of Qnap, and I suppose it has the very latest firmware ?
Is the iMac only a contoller, or do you also run Roon from the iMac as well ?
I guess you have other controllers as well ? (iPhone, iPad ?)

Have you got myqnapcloud to work ?
If not make sure it’s working, as that would be a good start.

Insofar as the problem starts and stops when Roon becomes active/inactive on the iMac controller, I start off assuming that Roon is trying to login to the QNAP and failing - in my opinion, that would be a Roon issue.

Yes, QNAP and the iMac are assigned fixed ip addresses by the DHCP server. The QNAP unit is a TS-669 Pro with the latest firmware. The iMac is only being used as a controller but I had been using it as a core until a month or so ago (this login failure message did not start until much more recently). I do have other controllers (another iMac, an iPhone and an iPad) but they are rarely used for Roon. I will see if I can cause the problem with them but they are not necessary for the problem to occur. Never had any interest in myqnapcloud but I will try to set it up and see if that suggests anything that could be relevant here

If we assume this the issue. Delete or edit where your music is stored from inside Roon.

Use \\ IP address + share name.

As an example:

If you don’t like to use the admin user, you can set that specific music share as guest in Qnap, then you should not need a user and PW. Or just create a new user. I suggest you test with the admin account first.

Also the music forlder (and Roon) must be shared folders.

If the problem is logging in to Qnap, the the problem should be equal on all controllers.

Thanks for your suggestions. Problem solved. Changing the music storage location to use the IP address did not help. The storage location asks for a username and password and it did not matter whether I specified an ordinary user or admin. Rogue attempted login continued (and remember, Roon was playing music just fine).

Then I looked at the controller issue. iPhone, iPad and other Mac were working fine and not triggering the login failures so that looked like a dead end until I looked more closely at the NAS login logs and noticed that access for all three of those controllers was being logged to the IP address of the NAS (where the core is located) – not to the IP address of the controller itself. That wasn’t the case for the machine that was causing the problem. Roon usage from that controller were being logged to its’ own IP address.

Settings on that machine said that it was using the core running on the QNAP and the music library stored there just as it was on the other controllers but I decided that 1.4 had screwed up the installation on this machine. I looked for uninstall instructions on the Roon support site but the references I found pointed me to pages that I wasn’t entitled to read so I deleted the application and renamed three library folders that I associated with Roon; rebooted the machine; downloaded a fresh copy of the software and installed it. Problem gone. While I suspect that a contributor to my problem was the fact that I ran a core on this machine before switching it to a controller only, I can’t verify that.

Bottom line, I should have been quicker to do a clean install when I had a problem that nobody else was reporting. Thanks again for your help.

Did you use a restore of a backup after the clean install ? And if Yes, did it work ?

No, I didn’t restore from the backup because there was nothing that I thought needed to be restored. Could be wrong on that though.

The reason that I didn’t restore is that the problem seemed to be on my mac that was only supposed to be a controller. My core was running on the NAS and there was no problem using it for three of the four controllers so I saw no reason to assume that the roon database (which is stored on the NAS) was corrupted and needed to be restored from backup. Reinstalling the controller on the Mac required virtually no input from me so I doubt there is anything major stored on a controller machine that is worth restoring. I am sure that is answered somewhere in the knowledge base but it didn’t pop up when I was doing my troubleshooting. No problems to date though that make me think my logic was wrong.