Advice needed: "Tidal Media loading slowly"

My internet speeds exceeds 100mbs (mesh network) and still I frequently get the “tidal media loading slowly”. This is something that increased about a month ago. Deactivating DSP sample rate conversion, helps a bit, but the problem persists.
Please advice

Thanks

1 Like

Mesh wifi? I imagine that’s a latency issue more than a throughput issue.

Edit: Also, how is the mesh configured? There is a lot of overhead with wifi, and the more you do without a wire, the more likely you are to run into issues. Mesh is fine for surfing, but anything that’s in the real time category will likely experience issues. Roon doesn’t seem to buffer songs much, if at all, so it’s quick to skip the song if it has any delay.

Thanks.
Cannot deploy ethernet wiring in my premises. The Roon Core and my iFi Stream are located in two separate rooms, both can be connected to my fiber access router (which is in another room), via high speed 802.11ax wifi6. Both connected to a separate mesh router via short ethernet cable. I awarded wifi priorities to both, the Core and the iFi Stream wifi nodes
I use Tp Link X60 (ax3000) routers for my mesh network. The access router is Sagemcom f@st 5670, connected to 1gbs fiber.

Do you have any suggestion on how to reduce my wifi network topology in order to redue latency?

Thanks

Updated my TpLink network from wireless router to access point (see figure).
Will follow up on the above mentioned issues.

Thanks for the lead.

Ok.

After a while, the problem still persisted. So, in order to avoid wifi connection between the internet and the server, I moved the Roon (windows) server near my fiber access modem and connected it hardwire to the main deco router’s ethernet connection.Using RDP to control Roon on the server.

Will report back.
Thanks for the support.

Hi Moshe I seem to remember some issues with TP Link mesh networks (maybe the Velop brand) a few years ago. Not sure that still persists, as I am sure there are others her using them.
I run my NUC on the other side of an Orbi mesh through a dedicated back haul and it never misses a beat even at 24/192.

It might be worth doing some tests copying files etc to see that you are getting the speed you are expecting. I can get around 70MB a second which is enough to stream 4k mkv.

The other thing that springs to mind is DNS settings, have you tried changing the default to 8.8.8.8, 8.8.4.4 (Google) or 1.1.1.1, 9.9.9.9 as it is often mentioned.

Thanks.
Connecting my NUC wirely did not help!

Will look later at your recommendations.
Please explain what do you mean vpbt,saying “I run my NUC on the other side of an Orbi mesh through a dedicated back haul and it never misses a beat even at 24/192.”.

Cannot deploy ETHERNET backhual between my tplink routers.

The NUC server is connected now to the ethernet port of the fiber modem. The deco network is set as Access Point (not mesh).

DNS address is set to 8.8.8.8, 8.8.4.4

Still encounter these Tidal loading slowly issues! Where DSP is set with or withot Sample rate conversion.

Tottaly at loss with these issues.

Hope Roon technical support will come up with a solution.

Thanks

Moshe
Sorry I meant I am running it connected to an Orbi Mesh box via Ethernet.
That way it does not use the normal WiFi network to transfer data and it has been very reliable.

OK if it is set to AP mode not Mesh then I do not think you cannot use it for fast back haul, as that normally only works in Mesh mode.
You are not in the support thread so they will not see it, so I will copy in @support

Do you want to move the thread to the support area?

I will appriciate it if you can help or instruct me on how to move this thread to @support

Thanks again for your support

I’ve moved this thread to the #support category for you, where it will be seen by the Support team.

Thanks for the support.

I am looking for it to add my setup data

My Setup information

Roon Core Machine

|Device name|DESKTOP-UDKKRQP
Windows 10
Roon application installed (as server)
|Processor|Intel(R) Core™ i5-7260U CPU @ 2.20GHz 2.21 GHz|
|Installed RAM|8.00 GB (7.89 GB usable)|
|Device ID|0CB3F23F-98AF-454C-981D-FDDA37E32905|
|Product ID|00330-80000-00000-AA651|
|System type|64-bit operating system, x64-based processor|
|

Networking Gear & Setup Details

1Gbs Fiber modem
TP-Link Deco x60 (3 routers) + M5 (2 routers)
Connected either as Wireless Network (Mesh) or Access Point (tried both)

Roon Server NUC connected via ethernet cable to the Fiber Modem or to the main Deco X60 router (tried both)

Connected Audio Device

iFi Stream via ethernet cable to one of the X60 (not the main), feeding Hugo2 DAC via coax cable, usually Group with my Android S22 Ultra Roon app (connected to the closest Deco router wirelessly)

Number of Tracks in Library

very small
playing Tidal connect

Trying with both Sample rate conversion (off and on)

Description of Issue

see above

Hi Roon Technical Support

As you can see, I did almost anything I could. Cannot use wired ethernet in my home. The Roon NUC though is connected directly to my Fiber Modem via ethernet cable. Although I have a very fast wifi connectibity between my Tplink Deco Routers, I still get very frequent Tidal Loaded Slowly messages followed by that nasty skips to next track. Do note that this phenomenon had increased lately last 2-3 months, before it was rare.
If that will not be solved, than I intend to abandon Roon and try another more reliable service.

Thanks for notice.

1 Like

Have you tried 5ghz band there are more channels and probably less interference, the downside is the signal absorption is higher.

The other thought is to run Ethernet from the nearest node to your end point , using it a bit like a big aerial. I am not familiar with these mesh systems to know if that’s feasible. I did it with a wi fi extender for a short time when I had a problem with my main Ethernet run

Sorry I see you are already doing that

Thanks
Will try to configure my Deco TpLink network to 5ghz (only) and report.
Currently I have two main endpoints, fixed and portable (fixed: ifi zen stream and hugo2, and portable: s22 ultra connected to questyle m15). The fixed is connected via ethernet cable to one of the X60 tplink roueters and my s22 connects wirelessly to the nearest tplink router. My NUC, windows 10 with Roon application, is connected via ethernet canle directly to the fiber modem. My tplink main router is also connected via ethernet cable to a peer port on that fiber modem.

I am not using Mesh topplogy (since it had caused more tidal loading slowly issues), but rather an Access Point topology which is more like wifi extenders, causing less latencies?

Coverage wise i have 5 tplink routers (3 X60s and 2 M5s).

Thanks again.

Hi

Seems that configuring the wifi network to 5Ghz only, introduces improvment. Will continue to monitor.

Thanks

Glad to say that the Tidal loading slowly issue is significantly reduced. Those nasty skips are currently rare and far between.

Thanks for the support.