After a year, my music will stop after 1:40 of any song I play

Roon Core Machine

macOS 10.15.7 2012 Mac Mini 2.6 GHz Quad Core i7 16 GB RAM Dual 256 SSD

Networking Gear & Setup Details

Ubiquiti Dream Machine; AT&T 1 Gigabit Fiber; 5 GHz WIFI

Connected Audio Devices

Connected to Emotiva P100 Preamp via Emotiva Big Ego+ 32-Bit/384k DAC which goes through an Emotiva XPA-DR2 Differential Reference Two-Channel Power Amplifier. Speakers are Elac Uni-Fi UF5 towers.

Number of Tracks in Library

25,000 tracks on an external drive and streaming of Qobuz Account

Description of Issue

After one year of resolving the same issue, all my music, whether streaming or local library will stop playing after 1 min and 40 secs. It doesn’t matter what I play, it will stop playing and start going through each track without playing until it gets to the end of the album. This is very frustrating. After trying a few tracks, I checked if there were any updates and found there were. I updated to version 2.0 Build 1353. It has not helped. I’m still having this issue. It only happens when I try to play Roon through my stereo system. When I stream to my Sonos system throughout the house, there is no issue. Over a year ago the issue was resolved by updated the software. This did not work this time. Please help.

@Ramiro_Orta, how is your mini connected to your network, via Ethernet cable or via WiFi? That era Mac mini has only 802.11n (WiFi 4) that is fairly limited in capacity even on the 5 GHz band, so you may be experiencing WiFi interference or capacity constraints. If you are connected via WiFi, can you connect to your mini to your Dream Machine via an Ethernet cable, turn off WiFi on the mini, and then see if you experience the same stopping of music?

If music plays, then the issue can be isolated to your WiFi network, if music stops, it may be something else.

3 Likes

Are you by chance performing sample rate conversion while playing?

1 Like

This is an interesting issue. Roonies should be able to pull the logs and find out what’s happening at 1:40. In the meantime, I would start by stages. First: simplify your setup so you’re not using DSP, upsampling, etc. If no luck, Second: try individual equipment starting with the DAC. If you can borrow a different DAC try that. Go through that process with each of your components until you hit on the problem. If that still doesn’t work, wait for the Roonies. My opinion is your core is losing track of your library. But my opinion is worth what you paid for it.

2 Likes

It is an older Mac Mini, but It had been playing fine for about a year with no issues. My WIFI and network device hasn’t changed? I will try to run ethernet to it, but I believe I did this last year too and WIFI or ethernet did not make a difference. But, I’ll give it a try anyway. Thanks.

1 Like

I don’t know. I’ll check, but that is a good tip. I’ll take a look. Thanks.

Hi @Ramiro_Orta,

Connor here with Roon Support - thank you for your patience.

There are a few possible explanations for this playback stoppage after a specific range of playback.

Firstly, I would double-check the Ubiquiti Quality of Service (QoS) settings in the Dream Machine, as well as any second routers or managed switches in this network. The specific duration of playback before the stoppage suggests that, at least with any streaming content, the buffer begins with a bandwidth it is either incapable of maintaining or not permitted to maintain. The same throttling would limit Roon’s ability to pass high-quality files to networked Zones - particularly if you’re using any DSP, as mentioned above.

Secondly, there might be multicast issues in the LAN. I recommend attempting to play to a wired DAC connected to the Mac Mini itself. If you can reproduce the issue under those conditions, please take a screenshot of the signal path and share it here.

Do you have any network hardware in addition to the UDM router?

Lastly, RAATServer might be recreating itself continually after a certain duration because Roon has lost sight of the folder location in which you originally automatically installed RAATServer. Try the following at your convenience. Please be aware that this will reset your Roon Settings → Audio Tab to factory settings, so I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Let us know when you’ve had a chance to review the above, and we’ll keep an eye out for your response. Thanks!

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.