After modem / router updated my phone can't connect to Roon Server

Roon Server Machine

Mac Mini PC

Networking Gear & Setup Details

Xfiniti XB8-T Modem
Eero Pro 6 router

Connected Audio Devices

Krell integrated
Various Sonos speakers

Number of Tracks in Library

Description of Issue

So, this weekend, Comcast swapped out our modem for a new one. No big issue and everything connected.

However, now, I cant connect to my Roon Core. My wifi is the same name and password. So, I open up my Mac and Roon is running just fine. I can even play onto my Krell integrated from my PC. But, if I try and connect to Roon from my phone, it just keeps searching for my Roon Core.

I tried restarting my Mac and that didn’t work. So, my Roon Core is obviously opened but I can’t seem to interact with it unless it is just my PC.

Also, all the Sonos speakers aren’t showing up either. I’m so confused.

So a couple updates:

I can connect to my Roon Core with my iPad and wife’s iPhone. Thats all good.

For one minute, i connected to my Roon Core on my Samsung S23, then it went away and hasnt come back. So, problem may be Android related.

Ignore Sonos problem, i need to reconnect those to my network on the Sonos app.

1 Like

Ok, so last night i was able to connect on my Android phone and iPad. Then, this morning, my Android cannot find my Roon Core while my iPad still can. This is quite annoying and dont have any idea why this is still occurring.

Hey @Thomas_Stehura,

Thanks for taking the time to write in! Sorry to hear about your issues post-router upgrade.

A first thought would be to triple check all your devices are running on the same local subnet. For example, if you have two devices with IPs like:

192.168.4.X
192.168.5.X

You may run into issues - Roon needs all devices to be on the same subnet, so double-check that the 7th number matches across all the devices you plan to use Roon with. :+1:

Thank you for that. I think this ultimately isnt a Roon issue. I notice that my phone sometimes says offline on the Eero app, im still connected to wifi on my phone. During those times, i cant see my Roon Core. Other times, like now, phone is online and Roon works. Weird, but thats the root cause.

1 Like

Hey @Thomas_Stehura,

Interesting indeed!

What is the subnet mask within your router settings? Do you have any active guest networks active?

On your phone, if you head into Settings>Privacy & Security> Local Network> is Roon enabled?

With that, if you Head to settings and scroll down to Roon> Reset Roon remote on next start up, does the same issue occur?

I’ll be on standby for your reply. Thanks Thomas!

There are no guests on my network but dont know what a subnet mask is. I did check that all my components had that some xxx.xx.5.xxx throughout.

Now what im seeing is that when my samsung phone is on web6, thats when my phone is offline on eero. That is when i dont see Roon. That was a new development with this new router. When on regular wifi, which i dont know how or why it toggles, i can see Roon.

Apple products have no disruption. Apparently theres an issue with Samsung and Web6 but dont know the fix.

Hi @Thomas_Stehura,

Can you temporarily disable web6?

Yeah thats the next step, i gotta look into the modem settings to see if i can do that. Cheers.

I find this issue ironic that im having this issue with only my Samsung phone, the big Daddy that now owns Roon. Ive never owned an Apple phone before, but this issue may force me over just to use Roon.

This topic was automatically closed after 19 days. New replies are no longer allowed.