After new windows installation Roon shows blank screen after first start

Roon Core Machine

Roon Core Machine: Intel(R) Core™ i7-4790K CPU @ 4.00GHz
OS: Windows Server 2022 Datacenter version 21H2
Running perfectly.

Networking Gear & Setup Details fiber switch S5860-24XB-U, 24-Port Ethernet L3 Fully Managed PoE++ Switch fiber switch S3900-24T4S-R, 24-Port Gigabit Ethernet L2+ Fully Managed

Connected Audio Devices

NAD C368
Bluesound PULSE 2i

Number of Tracks in Library


Description of Issue

Roon Core is already installed on for years now (currently on Windows server 2022) and is working perfectly on all endpoints. No issues at all.

However this week I installed Roon on a new windows PC (Windows 10 Enterprise x64) to work as an extra endpoint to listen via this PC.
The following FiiO Q5 DAC is connected. This DAC has been working perfectly for years now with my old PC.

After installation Roon is started perfectly: so I configured the FiiO Q5 DAC as before (tried both ASIO as WASAPI). Music is playing, all looks fine. But after closing the Roon app and starting it again I get a blank screen just running it.
I cannot quit Roon normally anymore, I have to stop the program via the task manager of Windows 10.
I have uninstalled Roon, removed all leftover folders in the AppData\Local and reinstalled again. Each time the same: Roon starts first time and I can configure it, play music. But as soon as I quit Roon and restart it again: blank screen.
Any idea?


I’d try updating the graphics driver from the manufacturer site, not windows update.

I have just reinstalled refresh latest nvidia driver, but same issue.

I rather expect it to be something like a firewall issue. Each time I reinstall I get the firewall popups to confirm RAAT and Roon; I confirm them to run in both private as public profiles. But I would not expect it to run on the first time.

This is the last part of the RAATServer_log.txt:
07/15 09:26:54 Trace: [raatmanager/windows] FOUND type=wasapi id={}.{2ca1d1f5-9f78-4991-ace3-72b166cab329} usb_id=2972:0031
07/15 09:26:54 Trace: [raatmanager/windows] name=FiiO Q5 output_name=Speakers
07/15 09:26:54 Trace: [jsonserver] [] SENT [1] [nonfinal] {“status”: “DeviceAdded”, “device”: {“device_id”: “{}.{2ca1d1f5-9f78-4991-ace3-72b166cab329}”, “type”: “wasapi”, “name”: “FiiO Q5”, “usb_id”: “2972:0031”}}
07/15 09:26:58 Trace: [ipaddresses] enumerating addresses
07/15 09:26:58 Trace: [ipaddresses] FOUND vLAN
07/15 09:26:58 Trace: [ipaddresses] SKIPPED Bluetooth Network Connection: not up
07/15 09:26:58 Trace: [ipaddresses] FOUND Loopback Pseudo-Interface 1
07/15 09:26:58 Warn: [easyhttp] [2] Post web exception without response: The request was aborted: Could not create SSL/TLS secure channel.
07/15 09:26:58 Warn: [inetdiscovery] failed to register: Result[Status=NetworkError]
07/15 09:27:03 Trace: [RAATServer] refreshing @ 10s
07/15 09:27:03 Trace: [raatmanager] announcing
07/15 09:27:03 Debug: [discovery] broadcast op is complete

It gets: failed to register line at 07/15 09:26:58.

Did you have the same OS on the old PC?

Yes all the same, it’s just new mainboard, cpu and memory, rest is the same; I use a separate network card so also at this point no changes. Of course a fresh install of windows 10. I even decided not to install windows 11 especially for this reason :slight_smile:
I’m even running same firewall software (Norton 360), so nothing really changed. I already disabled firewall within Norton but no luck till now.

I worked at Microsoft for ten years so not anti windows, it’s just a complicated mess sometimes.

Hi @TC-Glenn ,

Have you tried running the Intel Update Tool yet? If you have not yet, it might be worth a try:

Yes I already have automatic Intel driver tool up and running but no luck yet.

I tried any driver reversal and install; but no luck. One last idea came just up:
Does anybody know if Roon frontend app is making use of a java runtime at all?

Well I found out the following after many times uninstall and install of Roon.
I use too displays on pc. As long as I keep Roon on my main (i.e. in nvidia registered as first) display (where Roon originally popups up), Roon stays working. As soon as I move the Roon app to my secondary screen, then it will start and comes in a locked blank screen state (staying non-responsive).
So it looks like it’s definitely a (screen?) driver issue, but very weird because it is the same nvidia driver version I was using on my old pc. Well luckely at least I found out how I can still use Roon app, but I am of course not very satisfied why I cannot move it to another screen.

1 Like

Are they both plugged into the same graphics board?

Yes definitely only one GPU in the system; I already switched cables to different ports but that is not the issue.

Just an update:
It turned out that even running Roon on the primary display was not working good enough. As soon as I minimized the Roon app, it became unresponsive after restoring the screen to previous state.
I did a full Windows 10 re-installation from scratch for the second time, and after all correct drivers installation (from Vendor etc) and nothing more, I installed Roon app again: same issue: unresponsive blank screen.
I decided to install a clean Windows 11 installation; all drivers installed; Roon installed: problem solved.
So progression to newer OS seems to be inevitable in this case :slight_smile:
Thanks for the help…


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.