After Radio selections, remove buttons on queue are broken [Ticket in]

in 1.3 if you right click on a track in the queue to remove it, the remove button and everything else on the pop up doesn’t work

Working for me. When I right click it shows me the selection/remove bar. Can you get that too, @G997?

Roon 1.3 (B194) on a MacBook (Sierra 10.12)
Roon Core 1.3 (B194) on Ubuntu (16.04.4)

working for me, would you mind give us more details: exact steps + OS you are using

Yes I get the bar but nothing works, can’t even hit the X (upper right) to get out of it…this is on my MacBook Pro

BTW, works on my iPad…

Would you mind to restart the app and see if you can reproduce

I have to quit the app to clear it…still doesn’t work (On the MacBook Pro)

also …I’m using 10.11.6 El Capitan

Latest update doesn’t fix this…

Quitting the roon app and restarting lets the remove bar work 1 time, then it becomes inoperative…

@G997 – can you give us the details of your setup (as described here) and confirm that all your devices are running the latest version?


MacBook Pro 15" Retina Late 2013, 2.3 GHz Intel Corei7, 16GB ram. 500 GB Apple ssd

Everything on latest roon 1.3 196

As stated, track remove bar’s buttons work first time and then become inoperative. Quitting roon gets it to work one time. Restarting laptop yields same results. Never had any issues with this laptop on any of the previous roon releases since I joined…

Still doesn’t work Build 200

Any idea when this will be fixed??

Pretty much necessary given how limited the Shuffle selection # works

Hey @G997 – we’re still not able to reproduce this, and haven’t heard any other reports, so something is different about what you’re doing. I’m sure we can figure this out, but I feel like maybe we’re missing a step.

Can you tell me exactly how you’re selecting the tracks to delete? It sounds like this happens every time, is that right?

And this is not a remote, right? The MacBook Pro where this is happening runs the Core?

Hi Mike

Right click. Works first time and the the it doesn’t unless I quit roon and restart. Every button on remove bar goes dead

This is a roon remote

OK Try this
Fresh start of roon
Add tracks
Start to remove a few them one at a time…all works…leaving some in queue
Add another track
Now try and remove any still in queue
Remove bar is frozen and nothing works until u reboot roon

I’m unable to reproduce this. I’m using MacOS and iOS (iPad) remotes and everything works fine.

I’ve tried on two different Roon Server Cores, MacOS and Linux.

I’m unable to test Roon (not Roon Server) as Core and Control, which I assume G997 is using.


Cheers, Greg

My iPad works fine…


Look into the number selected on the remove line

It doesn’t reset. If I go to select all, the remove button works but the number selected goes up it count

Still, when I right click on one track, I can’t remove it…