After restore from backup (hanging logo) Not Working at all [Solved - Maxview Storage Manager]

Roon Core Machine

Device name STORAGE-PC
Processor 11th Gen Intel(R) Core™ i9-11900K @ 3.50GHz 3.50 GHz
Installed RAM 32.0 GB (31.8 GB usable)
System type 64-bit operating system, x64-based processor

Edition Windows 10 Pro
Version 21H2
Installed on ‎2022-‎05-‎19
OS build 19044.1706
Experience Windows Feature Experience Pack 120.2212.4170.0

Display driver is on board Intel with latest driver using its wizard, board drivers were updated with app (MSI). Device Manager is clear.

Networking Gear & Setup Details

Unifi Network 11 devices. 62 clients

Connected Audio Devices

Bryston BR-20 to Roon-Core as described in picture

Number of Tracks in Library

63000 (down from 65k? after 943)

Description of Issue

Due to compatibility issues with AMD Gigabyte motherboard (unable to access raid card setup from uefi) left me upgrading to this system.
Have tried the last three backup points and the last two from version 943 just a hanging white Roon logo pulsing. Tried previous version 936???(not sure) and it did database upgrade, flashed home screen for a Milli second, then back to hanging white Roon logo pulsing.

When I access from another PC it allows me to connect then get the same pulsing logo.

So tried a clean install not restoring from backup same problem guessing its not uninstalling cleanly.

FYI I have run two different AMD systems since 2018 for Roon no problem. Upgrade to Intel rig and it doesn’t work oh the irony.

Have .Net v.3.5,4.8, 6 I skipped 5 as support has ended.
Fresh install of Windows same result.

Passmark MemTest86 is clear after 4 passes tested CPU cores and memory.
So not likely a hardware error have checked permissions on Library before installing roon.

Reinstalled windows completed all updates this time did manual driver updates already knowing versions required as the MSI app looked sloppy.
Upon reinstall of Roon went straight to restore from backup. Completed relaunched prompted for login did so after 2-3 minutes was asked to unauthorize old version. Did so and still faced with same hanging logo will leave like this for several hours see what happens. Yes ports are forwarded in firewall.

Pitty being a holiday long weekend few people are dropping by to have a look and listen to the Bryston BR-20 on Roon…guess I’ll point Jriver at my music directories again.

.Net is 3.5 and 4.8 would have installed with latest updates.

Here is what happens when I connect from a Windows remote

Windows firewall is turned off no change. seems there is a problem establishing a secure connection to your servers.

When I browse to website listed response is: {“message”:“Route GET:/1/register not found”,“error”:“Not Found”,“statusCode”:404}

05/20 15:29:53 Warn: [easyhttp] [2] Post web exception without response: The request was aborted: Could not create SSL/TLS secure channel.
05/20 15:29:53 Warn: [inetdiscovery] failed to register: Result[Status=NetworkError]

I can reach the page so not sure its my firewall. So turned of the block aspect of firewall appliance (not windows firewall) to only detect and see what happens…still makes no sense as it worked the 19th unless certs have expired or been revoked since 19th?

SInce typing this three more logs have been created in Raatserver directory

While there is the error listed looking at Roon logs trial is false so login appears fine. Is it my library as a clean install goes the same route before adding directories. Jriver has cataloged my music files so is not permissions. Seems to load extensions for video card properly.
Why does Roon not make previous software versions available for download?

Guess I’ll wait for next version would be much less tolerant if I didn’t have an alternate way of listening to music. Why is there not a flag for nothing is working help? You would probably find trends much faster.
Have installed .net runtime v6 and restarted no change

What happens when you click ‘connect’ on the Windows remote?

When I access from another PC (remote) it allows me to connect then get the same pulsing logo.

WOW 5 days for someone who has nothing working?
Perhaps my lifetime subscription has expired?
Thanks in advance for any help.


Hello I have not been functional for 6 days now can you please provide older installers or other suggestions so I can get back working?
Reinstalled same Nvidia video card that was present in previous system no difference…
Unable to reinstall net 4.8 as its already installed. 4.8 .net troubleshooting tool reports no errors. .Net 6.0 is installed also.

Supportless in support :wink: do not take down a working Roon server until this is resolved or you might be like us with no working software…

Hi @Jerry_B,

Thank you for reaching out to us with your question and for the detail of your response. We’d like to apologize for the delayed response.We’ve made some recent changes to the support team structure and some reports have experienced a longer response time than usual. While there’s no excuse for your extended wait time, I wanted to provide some context.

From your response, it sounds like you’ve already tried a Core reboot and reinstall of Roon. I’d try manually setting aside RoonServer if you haven’t already. This step may resolve the issue, but if not, it will simplify and expedite troubleshooting by creating more stable, known conditions:

  • Make a Backup of your current RoonServer Database
  • Exit out of RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

Let me know if that helps, and we’ll proceed from there. We’ll be watching for your response.

Good day

Tried the above but did clean install of RoonServer (Roon back up is on raid array). My Roon Bridge/ remote found my Roon Server on the PC the server is installed on, so selected restore from backup selected most recent backup from May 19.
Left the room and now my remote bridge can’t find the server. So restarted the server. Then my Bridge/ remote was able to find server, connected. Was then prompted to log in, did so and back to pulsing Roon logo. The good news is there is now a RoonServer directory in local appdata directory. So progress of sorts. The firewall is disabled on the Roon-Server and now also on the Bridge/ Remote pc.

Tried my Apple iPhone XR Remote and selected the server Roon-Core at correct IP address version 1.8 (build 952) stable. same problem as Bridge/remote PC (which I also restarted and tried to connect again) Pulsing Roon logo

While I can select the server Roon-Core to connect, on the Apple Remote when I go to configure your devices it cannot see the Roon-Core. So guessing the server isn’t completely starting/ started up.

Hi @Jerry_B,

Ok, thank you for the update. Let’s proceed with a manual refresh of the entire database and then try to restore the May 19th backup again.

  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

I would restart your Remote devices for due diligence before attempting to connect after you’ve set aside the database. Let me know if this step helps!

We only installed Roon Server so I don’t have a Roon folder? So renamed RoonServer directory which had a Database folder that was almost 5gb in size. reinstalled RoonServer started server backup from prompt. Connect with Roon remote logged in and still pulsing roon logo after 5 minutes. So confirmed the RoonServer database directory was small and it was. Don’t understand what it doesn’t like about this machine.
So restarted RoonServer PC and waiting until RoonServer Icon said running then tried again, no login prompt just option to connect to server again, once successful Roon Logo pulsing.

So did a clean install again (backup logs first) deleted directories after uninstalling, restarting PC.
Reinstall Roon server, made sure it entered running state, then access from remote selected server (correct name and IP) again prompted to log in back to Pulsing Roon icon.
I have a critical error in log about binding. As follows…

05/26 15:44:56 Critical: scx: in OnBeforeEntry: System.InvalidOperationException: You must call the Bind method before performing this operation.

Reinstalling Windows going with an older version 21H1 the above is 21H2 see if that is what is causing problem…the trick is to not connect the internet during install and set policy, not to do automatic updates before you do reconnect internet.

Hey @Jerry_B,

I appreciate you pointing out that log error. Two quick follow up questions after having reviewed the case a little further:

  • Do you happen to have a program called Nero Wifi+Transfer installed on your PC?

  • Is there another app which is using port 1900 for your network?

I believe we’re close to identifying the issue here.

C:\Windows\system32>netstat -ab

the UDP port 1900 is used but thats on three of my computers and looks like a windows thing. Nothing forwarded in or out except for VOIP but thats on a different subnet and doesn’t use this port. Made the older Windows install key but haven’t used. So will wait out. I’ll get few lines of log before that critical error. Nevermind I see the reference to port 1900 for local host and ipadress. I installed Intel Proset on NIC let me remove that.
No difference I then used -ANO to find that local port 49667 is being used for 1900 another reoccuring error in event log is a “A fatal error occurred while creating a TLS client credential. The internal error state is 10013.”

I’ll reboot and enable wifi on motherboard and try to connect roon via my cell phone hotspot reception sucks around here but would eleminate network problems.

So reinstalled Windows with version 21H1.
Installed drivers, installed Roon did not restore from backup. Ran Roon logged in made sure I was at home screen. Went settings restore from backup and problem resolved (did take a minute or two to load).

Then a reboot for windows updates/ Intel driver update and Roon won’t start up again.

So why me? I rolled back the Intel driver but don’t have option to uninstall the two .net updates that installed. So assume it relates to that.

Be 10 days without Roon by the time someone answers Monday.
Feel like my music collection is being held hostage.
Back to Jriver.

These update results from Microsoft already with Windows 8 and 8.1 have driven me 20 years too late to Linux. If I already need more knowledge to keep an operating system running, I might as well choose more freely and learn what is added value.

Those who started much earlier tell me something about terminal commands and Linux fiddling that only It professionals can handle. That may be so. I hardly needed it with Ubuntu, Linux Mint and Manjaro.

In fact, today I have more update joy and time savings with Linux Manjaro, which I run in dual mode with Windows 10 and 11. With the KDE version I am close to the lock and feel of Windows 7. The day will come when Microsoft will be completely banned from my computers. That saves time, costs and nerves.

Even MVPs like Günther Born (proven MS expert) is now critical of all the “improvements” Michrosoft is introducing. He has stopped writing technical books about it and is quoted again and again because he is on the ball every day when something breaks.

Still, I would always welcome software that can support multiple operating systems. Being able to choose is an advantage, especially in the operating system base.

In all honesty, Linux dominates the computer world today and Microsoft is trying to keep up with Windows and Office. Those who dominate the desktop do not automatically have the best market position in a cloud solution.

Roon and JRiver have to live with what the base dictates.

Problem with Linux is I run a Adaptec raid card and APC UPS, so Roon’s linux version won’t work for me. Nor will custom baked installation to get functionality. I thought with large libraries it is also limited.

As for Microsoft they laid off their testers off in 2014 and now use their clients as guinea pigs for windows updates. (many software applications to like O365) They roll out in waves and when a significant number start rebooting or crashing in one wave the update is pulled. This often results in a minor inconvenience for most people as update removes itself for those scenario’s to be replaced by another successful one from another later.
When update just kills one application then the company making the application is left trying to repair the damage.
My plan is reloading windows without network cable, then delaying windows updates for 60 days before reconnecting NIC. I found it interesting that one .net 4.8 update is installed on this my main computer. The other says (Preview) is not, yet I am not in the Windows Insider program (I checked and confirmed).
So Roon might not even have this same problem with their own test machines.

Hard to complain when I didn’t pay for a single Windows 10 license all being upgraded from Win 7. Microsoft isn’t the only company doing things like this stereo and IT companies constantly release stuff letting client be beta testers.
Having not even been asked for logs yet I expect Roon thinks problem is at my end so know I am left to figure this out for myself.

I hate turning off Windows Updates because eventually they need to be turned back on.
Often leading to more problems. Was hoping to deal with this before I put other software back on.

So I suspect the problem comes from KB5010472 which is an update Preview released in May. Much easier doing this stuff on VM’s

1 Like

Yes, I know that, and that’s why today, before every purchase, we take a closer look at how the compatibility is. Manufacturers who do not want to support Linux are now completely dropped. For what is there, of course, must always be accessed to drivers, systems and updates that are still coming. Fortunately, Linux is coming closer and closer. That everything always works everywhere, I delusion.

Well I did in 2018 but perhaps its time to reanalyse this.
Windows is my world so if it can’t work there all I really care about is support for album art and metadata in my files by default, tons of options there now. Even with multi device support.

Trying to be patient is it normal to ignore people who are lifetime members?
@support been down since the 18th reported the 20th

I guess you’re saying Roon has been down that long.

Feels like they got my money and could care less about support

So perhaps too much detail.

I had a functioning AMD system for my storage work station. Due to an incompatibility I needed to upgrade. That AMD going to family member.
So purchased Intel system above. Which has been unsuccessful seems .net 4.8 breaks the ability for Roon to load (pulsing logo).
Just put original AMD system backup and its working fine again. (just transferring music back to it).

On the original AMD system the same updates are installed.

I have tried an earlier 21H1 iso for win10 setup and that worked until .Net 4.8, 05 2022 installed.
This AMD system has all the same software installed, Plex, photography, UPS, Adaptec management software.
The Intel system also running same software except Roon which won’t load.
Plex is running fine and works much better with Intel CPU (codecs they own).

Running two computers full time in summer is not really optimal.

Seems like something Intel or .Net based.

But it was not used the AMD image directly with all drivers on the Intel machine?

They are so different, the manufacturers give each other a leg up so that the other fails.