After Roon asked to update, I can only see online albums not my local library

Roon Core Machine

Nuc pc running rock

Networking Gear & Setup Details

Talk talk router

Connected Audio Devices

Both Ethernet connected and wirelessly connected

Number of Tracks in Library

Not sure as I can’t see them!

Description of Issue

When I started Roon today on my iPad , it requested that it update (update Roon not the app). Having done this, the behaviour was a bit screwy (couldn’t see speakers except Ethernet-connected ones) but after a reboot of the core and the network router all appeared fine. However I’ve realised that I can only see online albums from Tidal. I cannot see my local library.
Logging into the rock states I’m on Roon 2.0 build 1148
It states that the roon database and settings are OK.

Any suggestions?

You are running ROCK; where is your music stored?

I have a HDD attached to the nuc via usb. It’s attached and all seems fine (I’ve not touched it)

Please go to Settings > Storage, to confirm that the USB drive is attached (or check that it is available over the network.)

1 Like

Hmm. It’s not. It says (as you may already have suspected) - this drive is not available - check the drive or edit this folder if it’s been moved.

Well, I’ve not moved it so I wonder what’s happened…


(I really appreciate your help Martin…)


1 Like

If you have not tried this already, remove the usb connection from the NUC, power cycle the NUC then plug the USB cable back in.


Hi Mike, I’ve tried this but without success. Roon still shows only tidal albums and says of my library that it doesn’t exist or has been moved.
Any advice?
(I also tried a different usb socket just in case)
(Is there a way to browse the usb HDD to check the drive hasn’t failed or been wiped somehow in the update process?)

Do you have another laptop or PC you can attach the drive to check it?


Hmm. Attached the HDD to my Mac and it won’t mount. Should it? What format should it be? Does it require a PC rather than Mac? I don’t have a backup which is hugely stupid on my part…

Sorry, not familiar with MAC’s or what format they require. Hopefully someone else from the community will chime in with an answer.

Thanks Mike. Any help anyone? I’m really not keen to have to re-rip hundreds (or even more than 1000) CDs! Oof.

Another possible option, if there are local Computer shops in your area they could check it for you and possibly make a copy onto another device. That would beat re-ripping.

Hmm. Well I’ve tried attaching the drive to my mac and also a pc. I’ve tried different cables but no joy… the drive simply won’t mount. I can hear the drive spinning though. Should the drive attach to a mac/PC in theory?

When you attach it to a PC, what information about the HDD is shown in the Disk Management application of Windows? Can you post a screenshot? For example:

I see nothing except the main C: drive… see attached.
I can hear the HDD spinning but it simply won’t mount.
The curious thing is that this happened at the same time that Roon was updating.
Perhaps a coincidence - not sure…

Certainly looks as though the HDD is at fault. I second @Mike_LC 's suggestion to get it checked out further if you can.

Hey @Edward_Goodwin,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, I wanted to check in to see if you were able to properly mount your external drive back on your core. I would triple-check permission levels to ensure your ROCK has full access to the drive.

While this isn’t likely, I would also test different ports to ensure it isn’t a port failure on your ROCK and or Mac remote. Do you see anything pop up while in Disk Utility on your Mac?

What is the name of the external drive?

Dear Benjamin,
Thanks for the message. I’ve not managed to mount the external HDD on either a mac or a pc - disk utility on the mac doesn’t see it and the same for the PC equivalent (see screen grab above).

How do I check permission levels to ensure ROCK has full access to the drive? It’s been fine for the last few years but then after this update it just stopped working.

When you say different ports - do you mean different USB ports on my NUC pc (my Roon server)? If yes, I’ve already done that. Also different cables.

Regarding the name of the drive - hmm… good question. I have no idea and until it mounts, I don’t think I’ll be able to find out.

I look forward to hearing from you.

Is the USB drive mains powered or USB powered ,

Sometimes the cable or the power supply is limiting , I know you have tried changing cables , do you have another ?

How was the USB Drive formatted NTFS or exFAT. Roon OS 2.0 has a new USB Driver , it gave me grief in just the same way. Roon OS re-imported the whole set of tracks all 55k !!

I finally fixed it by reformatting it NTFS in Windows , mounting on ROCK and copying the files back via the NUC. Make sure you unmount properly once you get there

Put the USB drive into a Windows PC then Reboot , that worked for me. (If not reboot again) Once you can see it you can use the Disc Management windows above to check the partitions, I vaguely remember having to fix partitions

I just saw the no BU line , Once you see it – copy all files to the PC before doing anything else !!

Hi Mike,

Thanks for the reply. I’ve tried two different cables on three different computers. The drive is not powered separately but via the USB cable. I have no recollection as to how the drive is formatted - I will have formatted it however Roon/ROCK suggest.

For me, the update to Roon OS2.0 did not kill the drive - if I recall, the update from 1.8 to 2.0 wasn’t too bad (although some of my speakers haven’t enjoyed it… they seem to fall asleep and then don’t wake up - but that’s another story). The issue with the HDD failing (or whatever has happened) was a later update.

I’ll certainly try putting the drive back into the PC and rebooting with the drive attached. After all the ways I’ve tried, I’m not so hopeful though :frowning: Is there a way to read the drive when attached to my NUC (which only has a ROCK installed as the OS. I know I can address the ROCK system via its IP address but is there any other way to see a graphical user interface?