After Roon update Tidal login fails (MissingMethod)

Just got a Roon Update message on my iPad suggesting to update one or more of my devices. After my ROCK restarted, all my Tidal albums are missing. After logging into Tidal I get the following message “There was un unexpected error, please check your account details.(MissingMethod)”

My account details are valid, checking them on the Tidal app on my iPad.

I’ve had a really bad week upgrading to MacOS Catalina (don’t) and I was just winding down listening to Tidal…

Thanks for having a look.


Hi @Wim_van_Slooten,

Thanks for reaching out, and apologies for the trouble here.

Can you share a screenshot of the error messge?

Since experiencing this issue have you tried to reboot ROCK?

Same here. I have authorised Tidal again and now eveything works.

Hi Dylan,

It’s the login from the iPad that doesn’t seem to work work. Just logged in from my MacBook and that works fine. All my Tidal albums are back.

Thanks for the quick response!


1 Like

2 posts were split to a new topic: MissingMethod error logging in to TIDAL

Thanks for the update, @Wim_van_Slooten! Glad things are working for you now.

So I can get some additional data to the team, can you briefly describe your networking setup, as well as let us know which browser was being used on the iPad to try to log in?

My setup includes a new (November ‘’19) NUC with ROCK in ROON recommended configuration. Hardwired to a Synology NAS and Archer WiFi Router, AccessPoint via a Cisco Catalyst 2960-8TC switch. Endpoint is ALLO DigiOne Signature, also hardwired to the Cisco.

Logging in was done directly in the ROON app Settings menu on the iPad. No browser involved here. The Settings menu directly produced the above screen grab.

Logging in from the Settings menu of ROON on my PowerBook Pro however started my Safari browser. This worked fine.

Forgot to mention, my iPad is an iPad Air2 running iOS 13.3.2

2 posts were split to a new topic: iPad TIDAL login error

A post was split to a new topic: Error with TIDAL login from iPad

Hi @Wim_van_Slooten,

It looks like your iOS remote wasn’t fully up to date and was still using the old login method, which is why your other remote was able to login okay. Once your iOS device is updated to the latest Roon version (if it’s not already) there shouldn’t be any issues here.


I have exactly the same problem with my iPad (6th generation IOS 13.1.1) and I don’t know how to fix it.

the problem is fixed.
Very bad service from roonlabs not to specify an error message.
Why it isn’t possible to send a mail with the info “Please update your credit card data” but suggest a update as a method to block the tidal access instead?
It was just a coincidence that I found the reason for the login problem.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.