Again Roon does not work correctly with Linn Akurate DS endpoint

Dear #support,

I posted on this topic at around the same time last year. The issue went away after I replaced my old Mac Mini with a new one with the M1 chip. I am just back after spending a few months away, hoping that my problem might get magically fixed in the meantime. However, this didn’t happen.

Here are the details:

Core Machine (Operating system/System info/Roon build number)

Mac mini (M1, 2020) running OS X Big Sur 11.4 / Roon 1.8 (Build 831)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connection via Verizon Fios-G1100 router.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Emm DAC2X connected via USB. Linn Akurate DSM running version 4.75.360 connected via wired ethernet.

Description Of Issue

The EMM connection works perfectly. The networked Linn connection no longer works.

The first track takes forever to load. A typical error message is “Unexpected error communicating with audio device”. Then playback fails.

Connecting the Linn directly to Qobuz works fine but obviously I miss the Roon interface in that case.

I have had this problem for some time and have tried many potential solutions included rebooting all devices including the router.

Thanks in advance for your help,


Few things to try out:

Your Davaar version is not the latest one, update your Linn DSM.

Also check if your router has newer firmware upgrade available.

Check that the setting ”Subnet for Linn streaming” in Roon settings has correct ip address.

Enable multicast streaming on your router if not already enabled.

I’ve owned and still own Linn gear (currently Klimax System Hub 2016, Klimax Organik DSM 2020, Kiko). I’ve had best results connecting the Linn streamer, the server it is streaming from, and the router to a basic unmanaged switch like the Netgear GS105. Some routers are a bit too “smart” for Linn’s use of the local network.


Thank you #patouskii.

  • I mistakenly typed the wrong Linn software version. The Akurate is actually running 4.86.421.
  • The router firmware is automatically updated by Verizon.
  • Subnet for Linn streaming in Roon settings does (I believe) have the correct IP address:

As for “Enable multicast streaming on your router if not already enabled”, how would I discover and/or change my FIOS router settings?

Thanks again,


+1 on using a simple unmanaged switch such as the NETGEAR GS105 between the DS and the router.

My KDS kept faulting when connected directly to my router. Inserting the GS105 in the chain cured all the problems.

Dear #Martin_Kelly, thank you for your advice. I eventually did exactly what you suggested and everything works perfectly again.

1 Like

Dear #Fernando_Pereira, thank you for your suggestion. It works!

1 Like

Glad it has worked out for you Jim :grinning:

Linn kit is a bit sensitive when it comes to networking. But I’m glad you’ve got it sorted.

1 Like