AirPlay 2 Support in Roon for Paired HomePods

+1 for Airplay2 support to paired Homepods.

It was Roon’s quick and easy Airplay connectivity that got me to subscribe back in ‘15.

2 Likes

“mushrooms”? :thinking:

They keep us in the dark and feed us manure.

Ah! I have not heard that analogy before. :joy: :mushroom:

1 Like

+1 for support to HomePods in stereo pairs. Especially now that Apple has reduced the price, making this a more attractive option.

4 Likes

+1 more for paired homepod and airplay2 support

5 Likes

+1 PLEASE prioritize airplay 2 / paired homepods. Then Roon is the one platform to rule them all in the house. It’s all I lack.

4 Likes

+1 would be great, to have the possibility to stream stereo music (left and right) two different airplay loudspeakers (left and right).
Even better would be to stream surround sound to different loudspeakers. Even so there is not much surround sound music on the market.

1 Like

Looks like Roon has no intention in supporting the Apple paired Homepods? Think I’ve waited for over a year now.

1 Like

I would tend to agree. Especially, since Roon’s roadmap is secret and apparently takes no direction from subscribers/owners like us. Honestly, I love Roon and went for a life-time subscription right out of the gate, but if there is another product that is comparable I may jump.

I really dislike that we are kept in the dark about priorities and most importantly that we don’t have a voice into product development.

3 Likes

Hi all, saw this link In a post on this forum, and it worked! Roon is now playing my homepods (Stereo paired). Admin/Support, please share this, I’ve waited for a year!

Roon playing Homepod (paired)

If I can get Roon to play my Beoplay A9 then it’s a perfect interface.

I found it’s possible to create a stereo pair within Roon if one really wants this.
Here’s what you do:

  1. Enable each HomePod, making sure the Volume Control is set “Device Volume”, and within Roon send some music to figure out which one is Left and Right and then label them appropriately (using little pencil icon).

  2. While playing on one of the HomePods, click the signal path and at the top select “DSP”

  3. Within the DSP, click “+Add Filter” and select “Procedural EQ”, and then “+Add Operation” and add “Mute Channels”

  4. For this example (Right HomePod), mute the Left channel.

  5. Follow same instructions for Left HomePod and mute the Right channel/

  6. Group the speakers together and you now have a synced stereo pair! :slight_smile:

8 Likes

I didn’t think you could have DSP in grouped airplay , only RAAT suppose to be possible for groups and dsp. You sure it’s doing what you think?

https://kb.roonlabs.com/DSP_Engine:_Disabled_During_Zone_Grouping

Yes - tested with a lot of different distinct stereo tracks (Whole lotta love, most AC/DC lol, etc.).
One interesting tidbit, if you ask Siri to lower or raise volume, it treats them as a stereo pair (if you set them up that way on the Home app of course). I have single HomePods in other parts of the house as well, so if I ask the kitchen to raise the volume, only those two will go up.

Very odd as it shouldn’t.

Yeah I don’t see that error (or disclaimer):

Hey Craig - I gave this a try on my stereo-paird HomePods and it worked just like you described. I tested out some songs that I know to have hard panning of the music left to right and it sounded good. I then tried using the Qobuz app directed to the HomePods via AirPlay and playing the same tracks actually sounded a little smoother via Roon. So, overall this is a nice hack and it works!

Thank you :metal:t4:

1 Like

You’re welcome Ali!
Glad it worked out for you!

2 Likes

Brilliant solution Craig!

I followed your steps and got it to work for me.

To my amateur ears there is no timing difference between left and right and sure sounds like true stereo (albeit Airplay) from my paired HomePods.

I had to work around a setting on my “My Home” app that I used to set up the HomePods. I could make the DSP settings and group them. However, even though the play transport buttons worked, the track wouldn’t advance - no sound was playing.

I went into the iPhone app and changed this setting from

“Only People Sharing This Home” to

“Anyone On the Same Network.”

Enjoying my paired HomePods with Roon now. Very nice.

Thank you @Craig_Colthorp

Tom

2 Likes

That’s great Tom! Glad it worked out for you and thanks for your helpful tip about the Home app. Mine was set to “Anyone On The Same Network” already so didn’t run into that.

Cheers!

1 Like