Airplay and Roon 1.8 - Unable to get working

Core Machine

Roon Core
Dell R520
Ubuntu 20.04
32 Core Intel Xeon 3.2Ghz
128GB RAM
28TB RAID-6

Network Details

Roon Core <-> 48 Port Unifi Core Switch <-> Unifi Wireless Access Point <-> AirPlay Device(s)

Audio Devices

AppleTV → Amplifier → Speakers
AppleTV has latest firmware

Description of Issue

I am unable to configure any Airplay device with Roon. I have followed other instructions within this support forum.

Steps to reproduce below.

  1. Go to Settings
  2. Click Audio
  3. Scroll to roon tested section
  4. Three Apple TV via Airplay devices listed
  5. Click Enable on Apple TV 1, Password is Prompted
  6. No Password is displayed on the Apple TV
  7. Click Enter
  8. Roon shows a Gear icon
  9. Select Track for Apple TV 1 in the Device Selector
  10. Press Play
  11. No Audio, No Password, Roon goes from showing a Pause button to Play button after 5 seconds
  12. Configure Apple TV to Require Password (per other instructions found on this site)
  13. Click Gear and then Disable on Apple TV 1
  14. Click Enable next to Apple TV 1
  15. Enter Password from Step 12
  16. Roon shows a Gear icon
  17. Select Track for Apple TV 1 on the Device Selector
  18. Press Play
  19. No Audio, No Password, Roon goes from showing a Pause buton to Play button after 5 seconds

In the past, my Apple TVs usually show a 4 character password for 60 on first connect of a device. That is not happening with Roon.

I don’t usually play to my Apple TV, but I thought I would see if I could get it running. I started with the Apple TV zone disabled.

I set the ATV to require password. I entered a 4 digit password in the ATV settings. Then in Roon, I Enabled the Apple TV. I entered the 4 digits and clicked return (ok doesn’t work).

I then played to the zone and it worked.

Cheers, Greg

Thanks for the additional tip Greg! Sadly, it did not work for me. Here are the procedures I followed.

1: Entered AppleTV Settings
2: Click Airplay and Homekit
3: Click Allow Access
4: Click Require Password
5: Click On
6: Click Password
7: Set 4 Digit Numerical Password
8: Open Roon
9: Click Enable next to Apple TV
10: Enter 4 Digit Password
11: Roon shows Enabled with a Gear Icon
12: Select Apple TV in the Output Selector
13: Select a Track and Press Play
14: Progress bar does not progress, no sound is played, as before, roon stops playing

Are there log files or anything that I can use to troubleshoot this myself? I feel in the dark as to how this application is working and the lack of radical self-reliance for troubleshooting something that I feel should be very straight forward is unexpected. I don’t usually have to interact with a support forum for connecting an Airplay device (and it seems that a lot of other people have this problem)

Hi @Damien_Heiser,

I’m going to tag @support to help you out further. They may want to retrieve logs from you. It appears that you are enabling the AppleTV ok, but something is going wrong trying to play.

In the meantime, looking at your network info above, I assume the ATV is hardwired to the network. If so, could you try running it wireless and see if anything changes?

Cheers, Greg

Thanks for the update Greg. I have attempted both Wireless and Wired network connections of the Apple TV. I will await a message from support~

Hey @Damien_Heiser,

Thanks so much for taking the time to describe in detail the issue you’ve been running into. It seems that you’ve done the required steps - I am sorry it is not working.

If I understand correctly, you get to the point where your Apple TV is enabled in Settings → Audio and you can select it in the Zone Picker, but you cannot stream music to it. Can you stream music to other endpoints?

In the meantime, I’ve moved this thread into our technical team’s queue. You will hear back from one of them with more insight.

A post was split to a new topic: Apple TV does not work with Roon (after entering passcode)

This topic was automatically closed after 21 hours. New replies are no longer allowed.