Airplay code? Roon bricked!

I installed Roon 2.0 on a new MacMini, M1, system 13.0 as a roon core. I try to send a music stream of stored FLAC to a laptop via wifi Eero mesh network. I set Audiozone to laptop (either on laptop roon remote, or on Roon core via screen share), hit play, and I get an Airplay code displayed. I am on the same network. I have no idea where to enter that code, or how to make it not show it in the first place. Latter is preferred.

Essentially, Roon is bricked. How do I unbrick Roon? I want it to work without any airplay code displaying. Thanks.

This is a new thing, since I upgraded from an older iMac as roon server to Mac mini. Must have something to. do with OS13 or the Mac mini architecture. Never seen that airplay code before in my life.

I’m not sure if this is the issue here but it might help.

@Formula Getting good mileage from this screenshot!

2 Likes

Aye, it’s doing well!

2 Likes

@Formula. Thanks but does not work.

  1. I am on a Mac computer, not a Apple TV.
  2. On Airdrop and Handoff, I set "Allow Airplay for : Everyone.
  3. did it both on MacMini Roon server, as well as on Laptop with Roon Remote
  4. did restart. devices.
  5. Airplay code is still. displaying :frowning:

Any other ideas to unblock Roon?

1 Like

That was me that shared Formula’s solution.
My brain read Airplay as AppleTV.
Sorry about that.

@Traian_Boldea , you know much more about newer Macs than I do.
Any idea what’s going on here?

1 Like

I have only seen airplay code when connecting to a tv. But I do not use airplay that much.

What I do not understand is why airplay? From roon to another laptop (endpoint) I do not think requires airplay. @Daniel_Geiger what endpoints do you see on your settings/audio? I do not know how to reproduce this setup with laptop on airplay.

Also on my mini running Roon Server I do not have any airplay or handoff enabled

2 Likes

This!

////

1 Like

Agree on that Roon should use Wifi.
Some more info. Roon plays music via hardline USB to DAC. So Roon works.
In Roon core, If I go to Settings → Audio, under my laptop it reads “via AirPlay xxx.xxx.x.xx = IP address”
Is there a way to force Roon to use WiFi?

I figured that I can turn off Airplay Receiver in laptop under system preferences → sharing, then restart both Roon core and laptop, and that did the trick. Really bizarre the whole thing. So Roon defaults to Airplay to a device, and I do not see a way to manually switch to WiFi. Not sure whether that is a Roon or an Apple problem.

Now in Roon Core under Settings → Audio, the laptop is connected via. “CoreAudio”, whatever that means.

2 Likes

Are Mac audio drivers

I would disable that. From roon if you use it for other things. If you do not use it disable from sys prefs in osx. I think by doing one or another you force roon not to use airplay but still you can play audio via wifi by using another protocol
Happy that it works

Where can I disable airplay in Roon? I have not been able to find that. I’ve looked in Settings: General, and also Audio: Device Setup (including Show advanced), but no option to select communication protocols. Thanks!

1 Like

When you go into settings audio, each different option for the same device is a different protocol. You might get Roon Ready, Airplay and Chromecast options separately depending on your endpoint capabilities. If you are not getting a Roon Ready option then something is off with your endpoint config.

2 Likes

as @Henry_McLeod says protocols are grouped. So CoreAudio it is for computers, Airplay should be all grouped together, Roon Ready another group.

But if turning airplay from osx works I guess it is ok, maybe better to turn off airplay in the core computer in case you want airplay on your laptop.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.