AirPlay Device (BeoPlay A6) lost connection / freezes

Im using the latest version of Roon running on a MacMini (OSX Mojave) with three AirPlay devices (B&O A6) and an device from Devialet. The MacMini is connected to the internet via LAN-cable, the devices are connected via WLAN. (Ubiquiti AmpliFi Home Wi-Fi System AFi-HD)
The music is streamed via Tidal. But as I detected, the source makes no difference regarding this behavior.

Playing the music via Roon from the MacMini to the B&O A6 initially works without any problems. The same applies to the Devialet.
However, as soon as a certain time (approx. 6-8h) has passed during which no music was played to the B&O, the B&O is no longer recognized. Only switching off the network or the B&O makes it possible to play music again.
The Devialet is not affected by this behavior.
In the meantime I changed my whole WLAN-settings (from AirPort Extreme to Amplifi), and thhe B&Os were completely replaced because there was a fear that something was wrong with the WLAN module. But at the end, nothing changed. So the root cause of this issue can be in the area of roon.

Any help is appreciated since Im facing this issue since more than 8month.

Kind Regards

@support sounds like perhaps the B&O is going into power save mode maybe

That was something B&O assumed at the beginning, but in the meantime we can eliminate it as a root cause. The power save mode option is disabled.

Hey @Mathias_Zimmermann,

During this time, when the device is not recognized by Roon, are you able to play to it from other sources besides Roon?

Yes, from the native B&O app (in the meantime also for BeoPlay available), I m able to play music.

Thanks for the info, @Mathias_Zimmermann!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the behavior occurs (i.e. when the device becomes unavailable in Roon). Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

I can try to do that, but its impossible to pick to right time by chance. Because this issues happens during the night (or when the music doesn’t play between 6-8hours) and I can not commit the right time stamp. For example, this morning at 06:10am this issue happens.

That’s okay, @Mathias_Zimmermann. If you can give us a general timeframe (even if it’s not exact) for where this issue occurred that should give us what we need.

Just to verify, where is this app running from? Are you able to play to this device using the app from the Mac Mini directly?

If you leave the A6 playing (0 volume) for an extended period with non roon app - i.e. longer than the failure time does it disappear still… or is it ready and there when you change over to roon.

Ok, will provide the timeframe, when the issue occurs the next time.

This app runs on the iPhone, not on the MacMini.

I need to test it, never came up with this idea :wink:

Hey @Mathias_Zimmermann,

Can you try to use Airplay from the Mac Mini outside of Roon the next time the device is in this state? This way we can determine if it is only Roon that cannot see it, or if the Mac Mini itself isn’t able to see it.


I will do that.

Just to add something here. Its not the case that the speaker doesn’t appear in roon - they are visible there. But when I start to play music, the icon changes for the “pause”-symbol for 2 seconds and goes back to the “play”-symbol without any effect.

I assume the Mac mini is also not allowed to sleep

Correct, the MacMini is always on.

What is the DHCP lease time in the AmpliFi set to…not sure if this could be an issue but have you tried to note the IP addresses of the A6 each time its working then when it comes back again? Maybe its lease is dropping off after 8 hours and getting a new address? Maybe try a fixed IP or perhaps a reserved DHCP entry

from the AmpliFi manual

AmpliFi User Guide

• Lease Validity The IP addresses assigned by the DHCP server are valid only for the duration specified by the lease time. Increasing the time ensures client operation without interruption, but could introduce potential conflicts. Decreasing the lease time avoids potential address conflicts, but could lead to minor interruptions for the client while it acquires a new IP address from the DHCP server. Select the appropriate option: 1 hour, 2 hours,

4 hours, 8 hours, 12 hours, 1 day, 1 week, or 1 month (30 days), or 1 year (365 days).

Tap to save your changes.

• Static Leases Select this option to display a list of static IP addresses assigned to specific devices.

Thank you for your efforts! In fact, I’ve already tried that with fixed IP’s. The result is unfortunately identical. But I didn’t test it with an increased Lease validity. I will also check that!

If you use fixed IP already then the lease settings won’t apply…But you have to set the FIXED IP addresses outside the range of the DHCP ranges

@support I checked that this morning. (06:10am) via Roon the A6 is visible, but I can not play music. But when I start iTunes and select the A6 music is playing as expected.