AirPlay no sound

I configured my Windows PC with Roon Core and configured it to send to my Integra Audio/Video Receiver via AirPlay.
Windows and the Receiver seem to see each other, but there is no sound.

Roon is version 2.0 / 1272 / 64-bit (latest).
Integra Receiver is model DRX 3.2. It works fine over Wi-Fi directly to Tidal, for example.
Both devices are on the same home router, same SSID, and same IP Subnet.
Roon is pulling music from Tidal.

Roon works fine locally in the Windows default System Output, I can hear music through the PC built-in speaker.

I set the Roon Zone to Integra.
I set the Integra to AirPlay.
I have the Roon volume at 50, but have tried all levels.
I have the Integra volume at 50, but have tried all levels.
Nothing looks unusual in the Windows Volume Mixer.

In Roon Settings Audio, I have tried both Device Volume and Fixed Volume.
I have rebooted all the audio and network devices.
The PC can ‘ping’ the Receiver ok at a command line.

I set the Receiver to “Net” then “AirPlay”.

I selected the Integra Zone in Roon.
I can not get any sound to play.

I found a Community thread that said to maybe add a Password.
So I added an AirPlay password in the Integra.

The next time I chose Integra Zone, I was challenged for a password, so I entered it in Roon Core.
Still no sound.

Then as a quick test, I disabled the Integra Zone, and enabled it again.
When Roon asked me for the password, I intentionally typed the wrong password, and the zone failed, so I know that Roon is actually talking to the Integra receiver.

I can’t think of anything else. This should not be so difficult :slight_smile:

Hi @Joseph_Cronin

Welcome to the Roon Community.

I’m a fellow user.

Roon is only compatible with Airplay and not Airplay 2

Although some devices are Airplay 2 compatible and normally backward compatible, it’s looking like your receiver isn’t backward compatible to Airplay (1). Having said this, the info I found doesn’t state Airplay 2, just Airplay.

Can you Airplay to it from an iPhone or iPad?

I could be wrong, but doesn’t this receiver have Chromecast built in. Does this show up in the Roon audio settings.

Hi Menzies - thanks for the thoughts.
The receiver is from the mid-2010’s, so I’m guessing it’s AirPlay 1.
The on-screen menu doesn’t say either 1 or 2. That could be if Integra is sloppy with the wording, or it could be because AirPlay 2 hadn’t been invented yet :slight_smile:

The good news is, the receiver shows up in Roon / Audio / Devices:
Integra via AirPlay

So I have it Enabled, and double checked the volume method (device/fixed).

Chromecast is built in to it, but I don’t see that as a Roon option for this device.
For your other question about iPhone/iPad, I don’t have an iTunes account to test.

Hello Tech Support-
Can you provide any suggestions?
Thank you

Hello Tech Support-
It’s Day # 5 :slight_smile:
Can you provide any suggestions?
Thank you

Hi @Joseph_Cronin,

Is the device set up in Apple Home by chance?

If not, can you try setting it up there? This article is for a different device but the steps are the same. Please disable the device in Roon before embarking and let us know how it goes.


Hello Wes,

Thank you for the idea!
Unfortunately, Apple is not part of my home sound system, regarding the article you sent me.

My description is about a connection from Windows PC to Integra.
The Integra I have is approved on the Roon website as “Roon Tested”.

Please let me know what settings or troubleshooting I need to make this work.
Thank you.

Hi @Joseph_Cronin,

Here’s what I see repeating in your logging. Normally this would indicate a network issue but your comments lead me to believe it isn’t.

05/24 22:10:36 Trace: [airplay/client] server lost 1 packets starting at seq 23642
05/24 22:10:36 Warn: [airplay/client] packet with seq 23642 not found for retransmit
05/24 22:10:36 Trace: [airplay/client] server lost 1 packets starting at seq 23773
05/24 22:10:36 Warn: [airplay/client] packet with seq 23773 not found for retransmit
05/24 22:10:36 Trace: [airplay/client] server lost 1 packets starting at seq 23774
05/24 22:10:36 Warn: [airplay/client] packet with seq 23774 not found for retransmit
05/24 22:10:36 Trace: [airplay/client] server lost 1 packets starting at seq 23775

It’s absolutely filling up your logs and repeating this some 200 times per millisecond.

I totally understand your situation. If an ioS device can be borrowed to set it up in their Home app, it may resolve the issues though. This is based on some experiences of my own in getting soon-to-be certified or uncertified devices working with Roon.

If you’re sure that you have the 3.2 model, unfortunately, it is not Roon Tested. Here’s a snapshot from our page.

That said, it’s still possible that it could work via the Apple Home method. I can also provide you with instructions to wipe Roon and give it another go on a clean slate but we cannot guarantee that things will work as intended with products we haven’t tested. Reloading instructions below:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Please let me know if you have any other questions. Also, please let me know if you manage to get things working with this information. It will help other users if that is the case.


1 Like

Hi Wes,
I am so sorry about the Roon Tested issue - I’m sure I had read that in the past.

In that case, we’re OK to close the ticket. I understand if the item is not certified.

Take care.

@Joseph_Cronin, just a quick question before this closes. It appears the DRX-3.2 also supports Chromecast. Does this show as an opton in Roon Settings->Audio? If so, have your tried connecting to the DRX using Chromecast?

Hi Robert_F,
Thanks for thinking of Chromecast.
I can see and choose it in the Receiver menu.

I don’t see it in the Roon menu.

But one more thing about the network logging that Wes sent me.
I’m surprised that no one questioned me about Windows Firewall settings?
How I should configure it?
And anything to look for in troubleshooting?

Or, no questions about a 3rd party firewall?

I don’t understand why there isn’t a Setup Guide or a Troubleshooting Guide to cover issues like this.
Thank you.

@Joseph_Cronin, here is Roon’s FAQ on firewall settings:

Is Chromecast available as an optin in Roon Settings → Audio? You will need to select the gear icon and Enable it, same for AirPlay.

Many guides are available on the Roon website for setting up Roon, the Core, Remotes, network best practices, etc., starting here:

and here:

Thank you, everyone. OK to close Ticket.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.